Оглавление

Иллюстрированный самоучитель по Adobe After Effect 6

  • Введение
  • Урок 1. Общие сведения о цифровом видео
  • Урок 2. Интерфейс Adobe After Effects
  • Урок 3. Импорт клипов
  • Урок 4. Композиции
  • Урок 5. Слои в окне Timeline
  • Урок 6. Слои в окне Composition
  • Урок 7. Работа с файлами
  • Урок 8. Рисование
  • Урок 9. Прозрачность
  • Урок 10. Анимация
  • Урок 11. Эффекты
  • Урок 12. Титры
  • Приложение 1. Системные требования
  • Приложение 2. Список терминов
  • Приложение 3. Шпаргалки
  • Приложение 4. Палитра инструментов Tools
  • Приложение 5. Некоторые горячие клавиши


Урок 1. Общие сведения о цифровом видео

  • На этом уроке...
  • 1.1. Статические изображения
    • 1.1.1. Разрешение
    • 1.1.2. Глубина пиксела
    • 1.1.3. Качество (компрессия)
    • 1.1.4. Цвет
  • 1.2. Видео
  • 1.3. Звук
    • 1.3.1. Что такое звук?
    • 1.3.2. Частота дискретизации
    • 1.3.3. Глубина кодировки звука (формат)
    • 1.3.4. Моно и стерео
    • 1.3.5. Качество (компрессия)
  • 1.4. Резюме


На этом уроке...

Первый урок посвящен знакомству с принципами компьютерного видеомонтажа и графики и адресован, в первую очередь, новичкам в области цифрового видео. В нем в сжатой форме объясняются принципы хранения и обработки видео- и звукозаписей на компьютере, описываются основные параметры видеофайлов (размер, частота кадров и т. п.).

Уже довольно давно персональные компьютеры используются в качестве средства воспроизведения и редактирования цифрового видео. Технология, позволяющая отображать на экране монитора видео и воспроизводить через динамики звук, получила название мультимедиа. С точки зрения хранения мультимедийной информации на компьютере (вообще говоря, любые данные представляются на нем в виде файлов определенного типа), можно выделить несколько основных типов файлов:

  • Audio (звуковые, или аудио) — только звук, который проигрывается через акустическую систему (например, файлы с расширениями wav, mp3, aiff и т. п.);
  • Video (анимационные, или видео) — видео может быть беззвучным, а может и звуковым, т. е. сопровождаться синхронным звуком (файлы с расширениями avi, mov и т. п.);
  • Image (рисунки, или статические изображения) — обычные картинки (несколько условный тип, однако нам будет удобно говорить о нем в книге как о полноценной разновидности мультимедиа). Это файлы с расширениями gif, jpeg, tiff, pcx, bmp и т. п.

Общее название перечисленных типов файлов — это мультимедиа-, или просто медиа-файлы (рис. 1.1). Коротко остановимся на принципах хранения информации в медиа-файлах, начав с самого простого их типа (рисунков).

Рис. 1.1. Типы мультимедиа


1.1. Статические изображения

Вероятно, сегодня практически каждый пользователь представляет себе основной принцип хранения и отображения графической информации на компьютере. Тем не менее, скажем об этом несколько слов, чтобы последующие сведения о цифровом видео (которое представляет собой динамически сменяющую друг друга последовательность изображений) были для нас понятнее.


1.1.1. Разрешение

На первый взгляд, качественный рисунок, будучи отображенным на экране хорошего монитора, мало чем отличается от обычной фотографии. Однако на уровне представления изображения это отличие просто огромно. В то время, как фотографический снимок создается на молекулярном уровне (т. е. составляющие его элементы принципиально не различимы человеческим зрением, независимо от увеличения), рисунки на экране монитора (и, подчеркнем, в памяти компьютера) формируются благодаря пикселам (или пикселям) — элементарным составляющим изображения (чаще всего) прямоугольной формы. Каждый пиксел имеет свой определенный цвет, однако из-за их малого размера отдельные пикселы (почти или вовсе) неразличимы глазом, и у человека, рассматривающего картинку на экране монитора, их большое скопление создает иллюзию непрерывного изображения (рис. 1.2).

Примечание

Изображения на экранах компьютеров формируются при помощи пикселов квадратной формы. В отличие от компьютеров, во многих стандартах телевидения используются не квадратные, а прямоугольные пикселы. Параметром, характеризующим отношение размеров пикселов, выступает отношение их горизонтального и вертикального размеров, или пропорции пиксела (pixel aspect ratio). Более подробно с этой характеристикой вы можете познакомиться на уроке 4.

Рис. 1.2. Изображения на компьютере формируются благодаря пикселам

Каждый пиксел (кстати, слово pixel образовано от первых двух букв английских слов picture element) представляет информацию о некоторой "средней" интенсивности и цвете соответствующей области изображения. Общее число пикселов, представляющих рисунок, определяют его разрешение. Чем больше пикселов создают изображение, тем естественнее оно воспринимается человеческим глазом, тем, как говорят, выше его разрешение (рис. 1.3). Таким образом, пределом "качества" компьютерного рисунка является размер формирующих его пикселов. Более мелкие, чем пикселы, детали компьютерного рисунка совершенно теряются и в принципе невосстановимы. Если рассматривать такой рисунок в увеличительное стекло, то, по мере увеличения, мы увидим только расплывающееся скопление пикселов (см. рис. 1.2), а не мелкие детали, как это было бы в случае качественного фотоснимка.

Рис. 1.3. Общее число пикселов (разрешение) определяет качество изображения

Здесь стоит оговориться, что, во-первых мы имеем в виду традиционную (аналоговую, а не цифровую) фотографию (т. к. принцип цифровой фотографии как раз тот же самый, что и обсуждаемый принцип формирования изображения из пикселов), а во-вторых, даже для нее, говоря о качестве изображения, всегда следует помнить о самой технологии фотографии. Ведь изображение на фотопленке появляется благодаря прохождению света через объектив фотокамеры, и его качество (в частности, четкость и различение мелких деталей) напрямую зависит от качества оптики. Поэтому, строго говоря, "бесконечная" четкость традиционного фотографического снимка, о которой мы говорили, является некоторым преувеличением.

Примечание

На самом деле, современные цифровые фотокамеры позволяют зафиксировать изображение, разрешение которого практически не уступает аналоговому (в том смысле, что сейчас возможно оцифровать такое количество пикселов, которое будет "перекрывать" границы разрешения самой оптики). Однако для предмета нашей книги этот факт не играет важной роли, т. к. в настоящее время цифровое видео в подавляющем большинстве случаев передается именно с невысоким разрешением (относительно малым общим числом пикселов) и принимать во внимание такой параметр, как разрешение, просто необходимо.

Итак, немного упрощая, чтобы представить рисунок в цифровом виде, необходимо покрыть его прямоугольной сеткой размера MxN (M точек по горизонтали и N по вертикали). Это сочетание чисел MxN (например, 320x240, 800x600 и т. д.) и называют разрешением (resolution) изображения, или размером кадра (frame size). Затем следует усреднить данные о структуре изображения в пределах каждого пиксела и записать соответствующую информацию о каждом из MxN пикселов изображения в графический файл. Для цветного изображения это будет информация о конкретном цвете каждого пиксела (о компьютерном представлении цвета написано чуть ниже в этом разделе), а для черно-белых изображений — это информация об интенсивности черного цвета. Чтобы объяснить еще несколько важных параметров компьютерного представления изображений, остановимся далее чуть подробнее на их последнем типе — рисунках, выполненных в оттенках серого цвета (grayscale), т. е. в градации от белого до черного.


1.1.2. Глубина пиксела

Поскольку компьютер оперирует исключительно цифрами, то для описания интенсивности цвета отдельного пиксела он применяет определенное числовое значение, которое является целым числом, т. е. — 0, 1, 2 и т. д. К примеру, чисто белый цвет в черно-белых рисунках будет описываться нулевой интенсивностью, чисто черный — некоторым максимальным числом, а серые цвета — промежуточными значениями (в зависимости от их оттенка). Важным параметром, влияющим на качество представления изображения, является именно это максимальное значение интенсивности, которое (за вычетом единицы) называется глубиной пиксела (pixel depth).

Если глубина пиксела равна, к примеру — 128, то это означает, что (кроме белого и черного цветов, интенсивность которых, по определению, равна 0 и 127 соответственно) возможно представить на экране компьютера лишь 128 — 2 = 126 оттенков серого цвета (рис. 1.4, а). Промежуточные цвета отобразить будет невозможно, и (если таковые присутствовали в исходном изображении до оцифровки) они будут заменены наиболее близким оттенком из этих 126 градаций. В то же время для изображений с глубиной пиксела, равной 256, возможно отобразить в два раза больше оттенков, и поэтому такое изображение будет, скорее всего, существенно более естественным.

Минимально возможная глубина пиксела, равная 2, позволяет представить лишь два цвета — черный и белый (рис. 1.4, б) — и подходит для графического хранения черно-белых документов с линейной графикой (line art).

Рис. 1.4. Черно-белые изображения с одинаковым разрешением, но разной глубиной пикселов

Примечание

В качестве градаций глубины пиксела выбираются числа 2, ..., 128, 256 и т. д., т. к. все они являются степенями цифры 2, обеспечивая наиболее эффективное хранение данных на компьютере (оперирующем изначально числами в двоичном представлении). Напомним читателю, что один байт информации как раз эквивалентен хранению одного из чисел диапазона 0...255.


1.1.3. Качество (компрессия)

Хранение всей информации о том или ином изображении (т. е. о цвете каждого его пиксела) зачастую или невозможно, или неэффективно. Например, рисунок размером 800x600 пикселов требует записи информации о 800x600 = 480 000 пикселах. Если использовать глубину пиксела, равную 256 (т. е. кодировать каждый пиксел одним байтом), то размер файла, хранящего изображение (в оттенках серого цвета), будет равен почти половине мегабайта.

Примечание

Несколько забегая вперед отметим, что для хранения такого же цветного изображения потребуется файл уже в три раза большего размера (почти 1.5 Мбайт), а для хранения одной секунды цветного видео с кадром такого качества и типичной частотой кадров 24 к/с целых 40 Мбайт!

Чтобы уменьшить размеры файлов, хранящих изображения, применяются специальные программы, называемые компрессорами, или, по-другому, кодеками (codec — от англ, compressor/decompressor). Процедуру уменьшения размера медиа-файла называют компрессией или сжатием. Как правило, при сжатии некоторая часть информации о рисунке теряется, и его качество соответственно понижается. Многие программы-компрессоры позволяют регулировать степень ухудшения рисунков путем варьирования параметра, называемого качеством сжатия, которое обычно измеряется в процентах. Очевидно, что чем сильнее сжато изображение (т. е. чем меньше получившийся медиа-файл), тем хуже будет его качество (рис. 1.5).

Рис. 1.5. Два изображения с разным качеством компрессии

Все сказанное о рисунках в полной мере (и даже сильнее, т. к. при компрессии может учитываться дополнительная информация о последовательностях кадров) относится и к видеофайлам. Как правило, эффективность сжатия существенно зависит от структуры самого изображения, и правильный подбор программы-кодека зачастую позволяет достичь просто фантастических успехов в улучшении качества изображений. Очевидно, что следует выбирать те кодеки и так регулировать их параметры, чтобы, с одной стороны, обеспечить хорошее качество изображения, а с другой — скорость расчетов и приемлемый физический размер медиа-файла. Однако зачастую идеальный подбор кодека является "почти искусством" и под силу только очень опытным пользователям.


1.1.4. Цвет

Ограничимся самыми общими упоминаниями о технологии компьютерного отображения цветных изображений. Как известно, человеческий глаз устроен таким образом, что способен раздельно воспринимать три цвета, называемых основными: красный, зеленый и синий. Какой-либо предмет, имеющий определенный цвет, воспринимается нашим зрением как определенная комбинация этих основных цветов. Например, белый цвет ассоциируется нами как смесь всех трех основных цветов в максимальной равной пропорции, черный — как комбинация нулевых интенсивностей основных цветов, чисто синий цвет — как комбинация максимальной пропорции синего и нулевой — красного и зеленого, и т. д.

Именно на этом принципе и построено компьютерное представление цвета. Каждый пиксел цветного изображения кодируется тремя числами — сочетанием трех основных цветов: красного, зеленого и синего. Такую систему кодирования цвета называют моделью RGB (от англ, слов Red, Green, Blue — красный, зеленый, синий). Как правило, каждый цвет кодируется одним байтом информации, т. е. пропорции цветов представляются числами от О до 255. Разумеется, такая система передачи цвета является дискретной, т. е. не каждый имеющийся в природе цвет (число оттенков которого бесконечно) можно представить на компьютере. В этом смысле цифровое представление цвета имеет те же плюсы и минусы, что и рассмотренная нами выше передача интенсивности черно-белых изображений.

Примечание

Некоторые рисунки хранят информацию о цвете в других системах, например, CMYK-модели (голубой, пурпурный, желтый и черный), часто применяемой в бумажной полиграфии. Однако для представления на экране монитора компьютера сочетание этих цветов все равно пересчитывается в комбинацию основных цветов RGB.

Говоря о технологии передачи цвета на компьютере, нельзя не сказать о том, что она тесно связана с проблемой компрессии изображений. Нетрудно посчитать, что если каждый из основных цветов кодировать при помощи одного байта, то общее число возможных цветов составит более 16 миллионов. Кодировать каждый пиксел изображения с учетом такого большого количества цветов зачастую представляется расточительным. Поэтому многие кодеки используют несложный трюк, позволяющий значительно уменьшить размер графического файла. Они изначально, исходя из предварительного анализа исходного рисунка, готовят набор характерных именно для него цветов (например, 256 цветов), называемый цветовой палитрой (color palette). Информация об этих цветах записывается в определенном виде в графический файл, а потом уже изображение "перерисовывается" кодеком исключительно при помощи цветов из созданной палитры. Разумеется, некоторые цвета исходного рисунка при таком способе компрессии приходится заменять наиболее близкими цветами из палитры, что ухудшает качество изображения, но позволяет существенно сократить физический размер графического файла. При работе с цветными изображениями на компьютере важно постоянно помнить о принципе использования цветовых палитр, и в случае необходимости (для достижения лучшего качества цветопередачи или, напротив, в целях минимизации размера файла) корректировать параметры программы-компрессора.


1.2. Видео

Все, сказанное выше по отношению к статическим изображениям, относится и к видео. Надо лишь помнить о том, что впечатление просмотра видео на компьютере создается благодаря быстрому чередованию отдельных статических изображений, называемых кадрами (frames). Количество кадров, демонстрируемых в течение одной секунды, называется частотой кадров (frame rate). Психология человеческого восприятия такова, что при чередовании с частотой более 20 кадров в секунду они не воспринимаются как отдельные изображения, а полностью создают иллюзию просмотра динамической картины (рис. 1.6).

Рис. 1.6. Иллюзия просмотра видеофильма основана на принципе быстрого чередования кадров

Принцип покадрового видео, как вы знаете, лежит в основе традиционного (аналогового) кино и телевидения. Отличие компьютерного представления видео проявляется лишь на изложенных нами ранее характеристиках отдельных кадров видео как компьютерных изображений. Сведем все то, о чем мы уже рассказали, и то, о чем только собираемся рассказать, в одну таблицу (не касаясь пока звука, рассматриваемого в следующем разделе).

Заметим, что термином "Цифровое видео" здесь и далее мы обозначаем не только видео, которое воспроизводится на мониторе компьютера, но и современные "некомпьютерные" технологии (цифровые видеомагнитофоны, видеокамеры и т. п.).

Таблица 1.1. Цифровое и аналоговое видео

Параметр | Цифровое видео | Аналоговое видео (традиционное ТВ) | Аналоговое кино
Разрешение | Изображение дискретное, со | здается пикселами | Изображение непрерывное, создается на кинопленке на молекулярном уровне
Глубина | Определяется числом байт, кодирующим информацию об интенсивности каждого пиксела | Бесконечная (непрер ков, отсутствие града лее естественные цве | ывная шкала оттен-ции оттенков, наибо-та)
Качество сжатия | Выбирается пользователем; при этом за счет ухудшения качества изображения возможно значительное уменьшение размера видеофайла | Нельзя регулировать объем видеозаписи о теристиками носител пленка и т. п.) | максимальный пределяется харак-я (видеолента, кино-
Частота кадров | Иллюзия динамической карт дованию отдельных кадров (; | инки создается благод 20 кадра/с и более) | аря быстрому чере-
Звук | Цифровой, записываемый по принципу дискретизации | Аналоговый (бесконеч | ное число градаций)

Исторически сложилось, что разные стандарты кино и ТВ поддерживают различную частоту кадров. Приведем характеристики некоторых из них:

  • 24 (кадра/с) — используется для создания кинофильмов на кинопленках (классический кинематограф);
  • 25 (кадров/с) — стандарт PAL/SECAM, европейский стандарт телевидения;
  • 29.97 (кадров/с) — стандарт частоты кадров для NTSC (североамериканского стандарта телевидения);
  • 30 (кадров/с) — режим, довольно часто применяемый для создания компьютерных мультимедийных продуктов.

При работе с цифровым видео важное значение имеет договоренность о нумерации отдельных кадров. Способ и формат расстановки числовых меток, связанных с каждым кадром, называется таймкодом (timecode) кадра. Чаще всего используется отображение таймкода в стандарте NTSC, определяющий нумерацию кадров в пределах каждой секунды фильма, т. е. в виде час : минута : секунда : кадр. Например, таймкод 01:37:10:21 означает 21-й кадр 10-й секунды 37-й минуты 1-го часа от начала фильма. Однако наряду с таким представлением иногда применяются и альтернативные варианты нумерации кадров (например, сквозная нумерация кадров по порядку от начала до конца, без ссылки на время, т. е. 0, 1, 2, ..., 100 000, 100 001, 100 002 и т. д.).

Рис. 1.7. Качество цифрового видео зависит от разрешения и других параметров отдельных кадров

Подытожим основной принцип компьютерного представления видео: эффект восприятия человеческим зрением динамической картины создается благодаря последовательной демонстрации (с достаточной частотой) отдельных кадров (см. рис. 1.6). При этом каждый кадр является стандартным компьютерным рисунком, обладая всеми его характерными качествами (рис. 1.7), а для уменьшения размеров видеофайлов часто применяются специальные программы-кодеки, большинство из которых используют принцип схожести последовательных кадров друг с другом.


1.3. Звук

Посвятим данный раздел объяснению основных моментов возникновения, распространения и восприятия человеком звука, а также главным параметрам, связанным с представлением цифровой аудиоинформации.


1.3.1. Что такое звук?

С физической точки зрения, звук, в широком смысле этого слова, представляет собой колебания частиц окружающей среды (воздуха), передающиеся от точки к точке. Процесс распространения звука (в несколько упрощенном виде) происходит следующим образом. Некоторый источник (например, струна музыкального инструмента, мембрана динамика акустической системы или т. п.) совершает быстрые колебания с определенной частотой и амплитудой. Частотой называется количество повторений цикла колебаний в секунду, а амплитудой — максимальное отклонение колеблющегося тела от среднего состояния, измеряемое, например, в миллиметрах.

В результате взаимодействия источника звука с окружающим воздухом частицы воздуха начинают сжиматься и расширяться в такт (или "почти в такт") с движениями источника звука. Затем, в силу свойств воздуха как текучей среды, происходит передача колебаний от одних частиц воздуха другим (рис. 1.8).

Рис. 1.8. К объяснению распространения звуковых волн

В результате колебания передаются по воздуху на расстояние, т. е. в воздухе распространяется звуковая или акустическая волна, или, попросту, звук. Звук, достигая уха человека, в свою очередь, возбуждает колебания его чувствительных участков, которые воспринимаются нами в виде речи, музыки, шума и т. д. (в зависимости от свойств звука, продиктованных характером его источника).

Чем больше амплитуда колебаний источника, тем больше интенсивность возбуждаемых им звуковых волн (т. е. значение локальных сжатий и разрежений воздуха, происходящих в звуковой волне), следовательно, тем громче звук, воспринимаемый нашими органами слуха. Интенсивность звука в технике принято измерять в децибелах, сокращенно дБ (dB). Зависимость интенсивности звука от времени (рис. 1.9) является исчерпывающей информации об этом звуке.

Частота звука, как уже было сказано, измеряется в единицах в секунду, или, по-другому, в герцах, сокращенно Гц (Hz). Частота определяет высоту тона, определяемую нашим ухом. Малые, или низкие, частоты (порядка сотен герц) связаны в нашем сознании с глухими басами, а большие, или высокие, частоты (десятки тысяч герц) — с пронзительным свистом. Таким образом, человеческий слух способен воспринимать звук от сотен до десятков тысяч герц, а более низкие и более высокие, чем порог слышимости, частоты называются соответственно инфразвуком и ультразвуком.

Рис. 1.9. График динамики интенсивности звуковых волн является их исчерпывающей характеристикой

Примечание

В отношении звуковых волн часто используются производные единицы частоты— килогерц (кГц), равная 1000 Гц и, реже, мегагерц (МГц), равная 106 Гц. Чтобы не запутаться, имейте в виду, что мегагерцы, описывающие быстродействие компьютеров, никакого отношения к звуку не имеют (они определяют частоту электрических колебаний в процессоре).

На самом деле, подавляющее большинство знакомых нам звуков не является колебаниями определенной частоты, а представляют собой смесь различных частот, или спектр. Однако некоторые частоты в спектре чаще всего доминируют, определяя наше общее впечатление от звука, который мы слышим (об этом можно судить и по приведенному на рис. 1.9 графику интенсивности звука).

Итак, звук является акустическими волнами, передаваемыми в воздухе, и его основными характеристиками являются частота и интенсивность, а полноценной записью звуковых волн может быть признан временной график интенсивности.


1.3.2. Частота дискретизации

Очевидно, что для записи звука на компьютере требуется представить в цифровом виде график зависимости интенсивности звука от времени. Для этого достаточно записать в аудиофайл последовательные значения интенсивности звука, измеренные через определенные (чаще всего, равные) промежутки времени (рис. 1.10). Чем чаще будет произведена такая запись, тем большая информация о звуке будет сохранена, и, соответственно, тем лучше и естественнее будет передан при помощи компьютера звук, однако тем большим по размеру получится звуковой файл.

Итак, частотой дискретизации (rate) называется частота записи графика интенсивности, при помощи которой звук представляется в цифровом виде. Например, частота 5000 Гц означает, что каждая запись звука производится через временные интервалы 1/5000 = 0.0002 с.

Очевидно, что частота дискретизации для звуковых файлов имеет то же значение, что и разрешение для видеофайлов.

Рис. 1.10. Цифровое представление звука связано с дискретизацией временной зависимости интенсивности


1.3.3. Глубина кодировки звука (формат)

Подобно действию рассмотренного нами ранее для видеофайлов параметра глубины пиксела, в аудиофайлах каждое текущее значение интенсивности звука может быть кодировано с использованием различного числа возможных градаций. Таким образом, глубина кодировки звука определяет количество битов информации, кодирующих интенсивность звуковой волны в каждый момент времени. Очевидно, что чем больше количество записываемых в звуковой файл битов, тем с лучшей точностью и разрешением по интенсивности прописывается в цифровом виде звук, тем лучше и естественнее качество звучания.

Поясним сказанное на простом примере (рис. 1.11). Рассмотрим малый интервал времени, для которого имеется несколько измеренных значений интенсивности (для определенных отсчетов времени с равными промежутками). Эти значения интенсивности обозначены на рисунке крестиками. Если использовать высокую глубину кодировки, то при помощи достаточного числа бит информации можно записать в звуковой файл данные значения интенсивности с большой точностью (столбики на рис. 1.11, б). Однако, в целях уменьшения размера файла, глубина кодировки может быть уменьшена. Это означает, что имеющееся в распоряжении компьютера число бит информации будет недостаточным, чтобы записать точные значения интенсивности, а вместо них в файл будут записаны наиболее близкие допустимые значения (столбики на рис. 1.11, и). Разумеется, из-за отличий в исходном звуковом сигнале и записанной в аудиофайл информации качество воспроизведения звука во втором случае будет гораздо худшим. Подчеркнем, что в обоих случаях использовалось одинаковое значение частоты дискретизации.

Рис. 1.11. К объяснению смысла параметра глубины кодировки звука (глубина кодировки левого графика меньше)


1.3.4. Моно и стерео

Упомянем о хорошо известном всем стереофоническом эффекте, позволяющем синхронно воспроизводить из двух различных динамиков различный звук. Как известно, формат моно связан с записью в аудиофайл одной звуковой дорожки, а формат стерео — двух (в последнем случае размер файла по сравнению с монофоническим удваивается благодаря записи в один аудиофайл двух зависимостей интенсивности звука от времени — пример показан на рис. 1.12).

В последнее время все более широкую популярность приобретают многоканальные стереофонические эффекты (предусматривающие воспроизведение не двух, а большего числа звуковых каналов, что, естественно, в соответствующее число раз увеличивает размеры файлов). В этом случае важную роль приобретает схема расстановки динамиков относительно слушателя, поскольку многоканальная стереофония позволяет создать полноценный "эффект присутствия" (хорошим примером является стандарт Dolby Surround, применяемый в современном кинематографе).

Рис. 1.12. Формат стерео связан с синхронной записью в один файл двух звуковых каналов


1.3.5. Качество (компрессия)

Чем больше частота дискретизации и глубина кодировки звука, тем качественнее результат воспроизведения аудиофайла, но и, к сожалению, тем больше его физический размер. Для уменьшения размеров звуковых файлов применяются специальные программы, называемые (как и в случае видеофайлов) компрессорами, или кодеками (codec). Процедуру уменьшения размера звукового файла также называют компрессией, или аудиосжатием.

В последнее время (в основном, благодаря широко известной технологии МРЗ) появились новые, просто фантастические, возможности чрезвычайно эффективно сжимать звуковые файлы, оставляя их качество очень хорошим. Эти технологии постоянно совершенствуются, с каждым годом открывая для пользователей все более широкие возможности.


1.4. Резюме

Принцип цифрового видео связан с представлением фильма в форме последовательностей кадров, т. е. статических изображений, сформированных пикселами. Качество видео зависит от многих факторов: свойств программы-компрессора, разрешения изображения, частоты кадров и т. д.


Урок 2. Интерфейс Adobe After Effects

  • На этом уроке...
  • 2.1. Запуск программы After Effects
  • 2.2. Окно Project
  • 2.3. Окно Timeline
  • 2.4. Окна Layer, Footage и Composition
  • 2.5. Работа с несколькими композициями
  • 2.6. Палитры
  • 2.7. Резюме


На этом уроке...

Начнем наше первое знакомство с приложением Adobe After Effects с краткого описания особенностей его интерфейса, наиболее важными из состава которого являются три окна — Project (Проект), Timeline (Монтаж) и Composition (Композиция).

  • Чего мы хотим:

  • понять базовые принципы монтажа в After Effects;
  • выяснить назначение трех основных окон After Effects: Project (Проект), Composition (Композиция) и Timeline (Монтаж);
  • освоить вспомогательные элементы интерфейса After Effects;
  • научиться создавать новые композиции;

  • Нам потребуется:

  • программа Adobe After Effects, которая должна быть установлена на вашем компьютере.


2.1. Запуск программы After Effects

Нажмите кнопку Start (Пуск) и выберите в главном меню ОС Windows пункт Adobe After Effects 6.0.

Примечание

Впоследствии вы сможете запускать приложение After Effects двойным щелчком на файлах проектов, которые вы до этого сохранили. Эти файлы имеют расширение аер, например, start.aep.

После загрузки на экране появится окно приложения After Effects с новым (пустым) проектом (рис. 2.1). При этом основное окно приложения After Effects включает в себя несколько дочерних окон, с назначением каждого из которых мы разберемся ниже. Активным является диалоговое окно Tip of the Day (Совет дня) с полезным советом пользователю о работе в After Effects. Для того чтобы закрыть этот диалог, достаточно нажать кнопку OK либо нажать клавишу <Enter> на клавиатуре. Если вы хотите просмотреть новый совет, нажмите в диалоге Tip of the Day кнопку Next Tip (Следующий совет).

Рис. 2.1. Вид окна After Effects после запуска

Примечание

Чтобы отменить опцию показа совета дня при каждом запуске After Effects, достаточно снять в диалоге Tip of the Day (Совет дня) флажок проверки Show Tips at Startup (Выводить советы при запуске).


2.2. Окно Project

Начинать работу в After Effects следует с действий в окне Project (Проект) (рис. 2.2), являющегося своеобразной библиотекой как исходных клипов — "кирпичиков", из которых вы будете монтировать фильм, так и результатов вашей работы — композиций.

Здесь и далее словом клип (по аналогии с терминологией программы Adobe Premiere) будем называть исходные медиа-файлы (т. е. те, которые приготовлены вами заранее для обработки в After Effects). Термин фильм (или, как принято в After Effects, термин композиция) будем использовать по отношению к результату вашей работы в After Effects. В начальной стадии работы клипы импортируются из внешних, предварительно заготовленных, файлов. В ее завершающей фазе созданный фильм экспортируется либо в медиа-файл, либо (при наличии соответствующей аппаратуры) на видеоленту или какое-либо внешнее цифровое видеоустройство.

Рис. 2.2. Окно Project с новым, безымянным проектом Untitled Project

Управление процессом создания фильма в Adobe After Effects организовано, как и в программе Adobe Premiere, на понятии проекта (project). По аналогии с программой Microsoft Word, проект в After Effects соответствует по смыслу документу Word. Только в последнем вы создаете текстовый документ, а в проекте After Effects — видеофильм. Поэтому проект является своеобразной записью программы действий по монтажу и добавлению спецэффектов отдельным элементам фильма.

Окно Project (Проект) — самое главное. Оно содержит список всех клипов, используемых в данном проекте (как исходных, так и результирующих). В заголовке окна приведено название самого проекта, т. е. того файла, в котором хранится проект (на рис. 2.2 на заголовок наведен указатель мыши). При начале работы над новым проектом окно Project (Проект) пустое и готово к заполнению исходным материалом, из которого впоследствии вы будете создавать фильм.

Попробуем добавить новый элемент в окно Project (Проект). А именно, создадим новую композицию, т. е. новый (пока пустой) фильм, который мы впоследствии будем монтировать. Для этого:

1. Выберите в верхнем меню Composition (Композиция) пункт New Composition (Создать композицию).

2. В открывшемся диалоге Composition Settings (Установки композиции) нажмите кнопку ОК (рис. 2.3), не меняя никаких параметров.

Рис. 2.3. В диалоговом окне Composition Settings можно настроить ее параметры

В результате в окне Project (Проект) появится новый элемент — Соmp1 (Композиция 1) (рис. 2.4), а также автоматически откроются два новых окна — Timeline (Монтаж) и Composition (Композиция), при помощи которых осуществляется редактирование фильма (рис. 2.5).

Рис. 2.4. Новая композиция добавилась к списку в окне Project

Примечание 1 — для пользователей Adobe Premiere

Окно Composition (Композиция) программы After Effects по своему назначению соответствует окну Monitor (Монитор) Adobe Premiere.

Примечание 2

В программе After Effects, как правило, одни и те же операции могут быть выполнены посредством различных (эквивалентных) действий пользователя — в частности, при помощи верхнего или контекстного меню, клавиатуры или кнопок на разных панелях инструментов, а также с применением палитр. В данной книге мы не будем каждый раз сообщать вам обо всех возможных способах выполнения операций, выбирая один или два из них (чаще всего отдавая предпочтение контекстному меню или панели инструментов и минимально используя клавиатуру). По мере накопления опыта работы в After Effects вы сможете изучить все эти способы и выбирать наиболее удобный именно для вас.

Примечание 3

На самом деле в заголовке окна Composition (Композиция) вы видите имя открытой в нем композиции. Тем не менее, здесь, и далее во всей книге, мы будем ради определенности называть это окно именно так: Composition (Композиция).

Рис. 2.5. Новая композиция открывается в окнах Timeline и Composition

Теперь закроем появившиеся на экране окна Timeline (Монтаж) и Composition (Композиция), чтобы, во-первых, продемонстрировать, что они могут быть (без ущерба для проекта) временно скрыты, и, во-вторых, научиться впоследствии эти окна, когда они понадобятся, вызывать на экран.

1. Закройте окно Timeline (Монтаж) нажатием кнопки управления окном Close (Закрыть), находящейся в верхнем правом углу этого окна.

2. Так же закройте окно Composition (Композиция).

3. Повторите эти действия для закрытия всех остальных дочерних окон, если они присутствуют на экране наряду с окном Project (Проект).

Результатом этих действий будет наличие единственного окна — Project (Проект).

Закрытие окна Project (Проект) при помощи кнопки управления окном (самой верхней правой кнопки) означает завершение работы над текущим проектом и автоматически ведет к закрытию всех остальных окон. Поэтому никогда не закрывайте это окно, если вы хотите продолжить редактирование вашего фильма.

Рис. 2.6. Проект, содержащий три пустые композиции

Примечание

В After Effects 6.0 можно одновременно редактировать несколько фильмов. Если, к примеру, повторить описанные ранее действия по созданию новой композиции, то их результатом будет появление еще одного элемента списка в окне Project (Проект) под именем Соmр 2 (Композиция 2). Потом можно так же создать и третий фильм — Соmр 3 (Композиция 3), и т. д. Окно Project (Проект), содержащее три вновь созданные таким способом композиции, показано на рис. 2.6. Каждая композиция редактируется независимо в окнах Timeline (Монтаж) и Composition (Композиция), при этом одни композиции могут быть вставлены в виде составной части в другие композиции (см. далее).


2.3. Окно Timeline

Окно Timeline (Монтаж) (рис. 2.7) служит для управления процессом создания фильма (или, по-другому, композиции) из исходных клипов.

Если окно Timeline (Монтаж) скрыто, то, чтобы оно появилось на экране, дважды щелкните на имени интересующей вас композиции в окне Project (Проект), т. е. в данном случае на элементе Соmр 1 (Композиция 1). В результате на экране появятся окна Timeline (Монтаж) и Composition (Композиция), относящиеся к фильму Соmр 1 , которые были нами ранее скрыты.

Рис. 2.7. Строение окна Timeline

Если вы работали ранее с приложением Adobe Premiere, то вам уже хорошо известно назначение и основные свойства этого элемента интерфейса. Однако в After Effects окно Timeline (Монтаж) имеет, по крайней мере, две очень важные отличительных особенности.

Во-первых, оно может содержать одну или несколько закладок (в зависимости от общего количества композиций в проекте). На рис. 2.7 на закладку с именем единственной в нашем проекте композиции наведен указатель мыши. Если проект содержит несколько композиций (см. рис. 2.6), то осуществлять переход между ними следует при помощи щелчка на соответствующей закладке.

Во-вторых, основным объектом, над которым совершаются действия, является не клип, как в программе Premiere, а слой (layer), как в Adobe Photoshop. Поэтому процесс редактирования фильма в окне Timeline (Монтаж) очень похож на редактирование рисунков в программе Adobe Photoshop и заключается в следующем. Клипы, из которых формируется фильм, располагаются, как бы друг над другом, по слоям. Список слоев, наряду с их атрибутами, приводится в левой половине окна Timeline (Монтаж). Вообще говоря, слои могут содержать не только исходные медиа-файлы, подготовленные заранее и взятые откуда-то с дисков вашего компьютера, но и цветные заставки, создаваемые вами текст, рисунки, анимацию и т. д.

На рис. 2.7 в данный момент нет ни одного слоя, поскольку мы пока не добавляли их в наш фильм (с тем, как вставить в качестве слоя видео из внешнего файла, мы познакомимся на уроке 3). Слои располагаются друг над другом в указанном пользователем порядке, и в этом же порядке их изображения будут накладываться друг на друга, создавая тем самым кадры фильма. При этом различным слоям могут быть назначены различные характеристики прозрачности, маски, спецэффекты, анимация и т. п. Собственно, набор этих возможностей и позиционирует место программы After Effects среди других средств компьютерного видеомонтажа. Как может выглядеть окно Timeline (Монтаж), если в него добавлены один или несколько слоев, вы можете увидеть, пролистав страницы данной книги вперед.

Конечно, не стоит забывать о том, что редактирование фильма в After Effects подразумевает работу над каждым его кадром. Поэтому особенности расположения слоев следует задавать в привязке к времени фильма (или, что то же самое, к номеру кадра). Для этих целей в правой части окна Timeline (Монтаж) находится временная шкала или линейка времени (time ruler), определяющая место каждого кадра для каждого слоя композиции (рис. 2.8).

Рис. 2.8. Индикатор текущего кадра на шкале времени окна Timeline выделяет определенное место в фильме

Один из кадров композиции всегда является выделенным, что отображается при помощи линии редактирования и индикатора текущего кадра (current-time indicator), выполненного в виде ползункового регулятора (см. рис. 2.8). Линия редактирования является специальным элементом интерфейса, характерным практически для всех видеоредакторов, и представляет собой вертикальную линию, которая пересекает шкалу времени в окне Timeline (Монтаж) в определенном месте. Таким образом, из всего фильма в каждый момент времени выделяется один из кадров, имеющий особое значение (мы его будем называть текущим кадром), Таймкод текущего кадра приводится в левой верхней части окна Timeline (Монтаж) (см. рис. 2.7) в виде активной надписи (выполненной с подчеркиванием).

Выделение текущего кадра в After Effects, и в видеоредакторах вообще, имеет то же назначение, что и курсор, отмечающий определенные места в тексте в обычных текстовых редакторах (таких, как Microsoft Word или Notepad). Изображение текущего кадра демонстрируется в окне Composition (Композиция), а большинство операций пользователя по редактированию фильма применимо как раз к текущему кадру (или, по крайней мере, устанавливает текущий кадр в качестве граничного при назначении того или иного спецэффекта).

Таким образом, процесс монтажа композиций в After Effects заключается в расположении исходных клипов вдоль временной шкалы и последующим применении к ним разнообразных эффектов. Фактически то, что мы видим в окне Timeline (Монтаж), является исчерпывающей записью редактируемого нами фильма и однозначно определяет то, как будет выглядеть его каждый кадр. Именно составленная схема расположения клипов по слоям и назначение им различных эффектов и является предметом записи в файл проекта After Effects.


2.4. Окна Layer, Footage и Composition

Окно Composition (Композиция) служит для (статического или динамического) отображения определенного кадра фильма и, по строению и назначению, очень похоже на типичный проигрыватель медиа-файлов (такой, к примеру, как Microsoft Windows Media Player или Quick Time компании Apple). Примерно так же выглядят и другие вспомогательные окна — Layer (Слой) и Footage (Клип) — с той оговоркой, что они служат для просмотра содержимого какого-либо из слоев, входящих в композицию, или исходного материала соответственно (рис. 2.10, 2.11).

Примечание

Для того чтобы открыть любое из перечисленных окон, соответствующие элементы (т. е. композиции, слои и клипы) должны быть предварительно созданы в проекте. Пока наш проект содержит только одну пустую композицию, а с остальными составными частями проекта мы познакомимся на следующих уроках, когда будем говорить об импорте (см. урок 3) и слоях (см. урок 4).

Рис. 2.9. Окно Composition с пустым текущим кадром композиции Соmр 1

Рис. 2.10. Окно Layer служит для просмотра текущего кадра отдельного слоя композиции

Рис. 2.11. Окно Footage предназначено для просмотра исходных клипов

Чтобы открыть композицию или ее отдельный слой, или исходный клип в соответствующем окне:

  • для открытия окна Composition (Композиция) — дважды щелкните на названии композиции в окне Project (Проект), при этом, одновременно с окном Composition (Композиция) будет открыто и окно Timeline (Монтаж).
  • для открытия окна Layer (Слой) — дважды щелкните на названии нужного вам слоя композиции в окне Timeline (Монтаж);
  • для открытия окна Footage (Клип) — дважды щелкните на названии клипа с исходным материалом (видео- или аудиофайла, цветной заставки или т. п.) в окне Project (Проект).

Пользователям Adobe Premiere

В приложении Adobe Premiere окну Composition (Композиция) соответствует по смыслу окно Monitor (Монитор), а окну Footage (Клип) — окно Clip (Клип). А вот окно Layer (Слой) является уникальным для программы After Effects, поскольку только в ней редактирование производится по слоям.

Назначение окон Composition (Композиция) и Layer (Слой), с одной стороны, и окна Footage (Клип), с другой, различно. Первые два служат для управления процессом редактирования пользователем композиций в After Effects и отображают кадры несуществующего пока фильма (или слоя этого фильма), а окно Footage (Клип) предназначено для просмотра исходных медиа-файлов (в которых нельзя чего-либо изменить). Поэтому строение этих двух типов окон также несколько отличается: первые (см. рис. 2.9, 2.10) содержат специфические элементы управления, предназначенные для редактирования фильма, а вторые (см. рис. 2.11) — стандартные элементы управления обычного медиа-проигрывателя (кнопки Старт, Стоп и т. п.). В частности, нажатие кнопки Старт (на нее на рис. 2.11 наведен указатель мыши) запускает воспроизведение исходного клипа.

Подобно окну Timeline (Монтаж), все эти окна могут иметь одну (см. рис. 2.9) или несколько закладок, каждая из которых представляет соответствующую композицию (рис. 2.20). Таким образом, одновременно можно открыть несколько клипов в окне Footage (Клип), несколько композиций или несколько слоев в окнах Composition (Композиция) и Layer (Слой) соответственно (рис. 2.20). В этом случае переключаться между различными открытыми клипами, слоями или фильмами следует при помощи закладок. Более того, все окна могут быть совмещены и друг с другом в едином окне также посредством закладок. Для того чтобы просмотреть клип, слой или композицию, следует щелкнуть на закладке с нужным именем.

Повторимся, что редактирование фильма в After Effects записывается (в принятой разработчиками символической форме) в окне Timeline (Монтаж). Очень важным моментом при этом является правильное (часто с точностью до кадра) позиционирование слоев относительно линейки времени. Чтобы точно осуществлять временную привязку кадров фильма, а также для удобства работы с изображением каждого кадра, окно Composition (Композиция) синхронизовано с окном Timeline (Монтаж) посредством приведенного в предыдущем разделе понятия текущего кадра.

Номер текущего кадра (или по-другому, как вы помните с прошлого урока, его таймкод) отображается одновременно (для удобства пользователя) в различных окнах After Effects, в том числе, в нижней части окна Composition (Композиция). Повторимся, что на этот же кадр в окне Timeline (Монтаж) указывает находящаяся в нем линия редактирования и индикатор текущего кадра (рис. 2.12).

Вероятно, вы заметили, что на рис. 2.12 в окне Layer (Слой) отображается иной номер кадра, нежели в других местах. Дело в том, что окно Layer (Слой) демонстрирует кадр слоя, который выделен в фильме линией редактирования и отмечает, соответственно, таймкод этого кадра относительно начала этого слоя, а не начала фильма. Поскольку слой crawford.avi начинается не с самого начала композиции (см. рис. 2.12), то таймкоды текущего кадра в окнах Layer (Слой) и Composition (Композиция) не совпадают.

Рис. 2.12. Окна Composition и Layer всегда отображают текущий кадр, отмеченный линией редактирования в окне Timeline

В первый момент текущим кадром является самый первый (точнее, нулевой) кадр фильма. Его таймкод — 0:00:00:00. Для выделения другого кадра в качестве текущего предусмотрены различные способы. Например, вот как можно выделить начальный кадр десятой секунды фильма:

  • при помощи окна Timeline (Монтаж) или Layer (Слой) — щелкните в соответствующем месте на шкале времени любого из этих окон либо перетащите ползунок в нужное место шкалы (рис. 2.13). В результате линия редактирования переместится в это место (рис. 2.14), а данный кадр отобразится в окне Composition (Композиция). Обратите внимание, что по мере перетаскивания ползунка таймкод отмечаемого им кадра отображается в соответствующих полях таймкода всех окон. Таким образом, несложно позиционировать линию редактирования на кадр с нужным номером;

Рис. 2.13. Для перемещения текущего кадра перетащите ползунок в нужное место на шкале времени

Рис. 2.14. Линия редактирования в окне Timeline указывает на кадр 0:00:10:00 (нулевой кадр 10-й секунды)

  • при помощи окна Composition (Композиция) — щелкните на таймкоде текущего кадра и затем введите численное значение нового таймкода в открывшемся диалоге Go To Time (Перейти к кадру). После нажатия в диалоге кнопки ОК линия редактирования переместится на этот кадр (рис. 2.15).

Примечание

Тот же диалог введения таймкода для перехода к другому кадру можно вызвать щелчком на подчеркнутой надписи с таймкодом текущего кадра в окне Layer (Слой) или Timeline (см. рис. 2.15).

Рис. 2.15. Используйте диалог Go To Time для ввода вручную числового значения таймкода


2.5. Работа с несколькими композициями

Как уже было сказано, After Effects позволяет редактировать одновременно несколько композиций, которые могут быть как совершенно независимыми, так и являться составными частями друг друга.

Примечание

Однако в After Effects (как и в Adobe Premiere) можно иметь в открытом виде только один проект.

Создадим еще две пустые композиции и вставим затем одну из них в виде составной части в созданную ранее композицию Соmр1 .

Для создания новых композиций воспользуемся не верхним меню, как раньше, а альтернативными возможностями:

1. Нажатием правой кнопки мыши вызовите из пустой области списка в окне Project (Проект) всплывающее (контекстное меню) и выберите в нем пункт New Composition (Создать композицию) (рис. 2.16). В открывшемся диалоговом окне Composition Settings (Установки композиции) нажмите кнопку ОК .

2. Нажмите кнопку Create a New Composition (Создать новую композицию), которая находится на панели инструментов, расположенной в нижней части окна Project (Проект) (рис. 2.17), а затем нажатием кнопки ОК закройте появившийся диалог Composition Settings (Установки композиции).

Результатом этих действий будет создание двух новых пустых композиций — Соmр 2 и Соmр 3 (см. рис. 2.6) вдобавок к существовавшей ранее (также пустой) композиции Соmр 1 .

Рис. 2.16. Создание новой композиции при помощи контекстного меню

Рис. 2.17. Создание новой композиции при помощи панели инструментов окна Project

По мере создания новых композиций они будут открываться в окнах Timeline (Монтаж) и Composition (Композиция) при помощи организации соответствующих закладок. Для перехода от одной композиции к другой в том или ином окне необходимо щелкнуть на нужной закладке (рис. 2.18).

Рис. 2.18. Листание существующих композиций в окне Timeline

Для того чтобы закрыть одну из композиций, достаточно нажать маленькую кнопку закрытия закладки, расположенную справа от имени соответствующей композиции (рис. 2.19). Чтобы впоследствии вновь загрузить эту композицию в окна Timeline (Монтаж) и Composition (Композиция), следует дважды щелкнуть на ее названии в списке окна Project (Проект).

Рис. 2.19. Закрытие одной из композиций в окне Timeline

Иногда бывает полезным иметь на экране одновременно два (или даже больше) экземпляра окна Timeline (Монтаж) и/или окна Composition (Композиция), в каждом из которых будет открыта для редактирования своя композиция. Для этого следует разделить окно Timeline (Монтаж) или окно Composition (Композиция) следующим образом. Схватитесь указателем мыши (т. е. нажмите и удерживайте левую кнопку мыши) за закладку той композиции, которую вы хотите открыть в новом окне. Перетащите эту закладку (т. е не отпуская левой кнопки мыши, переместите указатель) на любое свободное место экрана (рис. 2.20). Отпустите левую кнопку мыши.

Рис. 2.20. Разделение окна Timeline

В результате на экране появится дубликат окна с открытой в нем композицией (рис. 2.21).

Рис. 2.21. Результат разделения окна Timeline

В данном примере мы разделяли окно Timeline (Монтаж), но точно таким же способом можно открыть разные композиции в нескольких окнах Composition (Композиция) (рис. 2.22).

Повторимся, что закрыть любое из окон можно нажатием соответствующей кнопки управления окном в его правом верхнем углу. Кроме того, можно вновь соединить открытые в разных окнах композиции. Чтобы совместить окна, схватитесь за закладку с именем композиции в одном из окон и перетащите ее на другое окно.

Рассмотрим теперь то, как производится наполнение композиций мультимедийным материалом. Для примера вставим композицию Соmр 3 в виде составной части в композицию Соmр 1 . Для этого:

1. Откройте композицию Соmр 1 в окне Timeline (Монтаж) щелчком на соответствующей закладке.

2. Схватитесь за название композиции Соmр 3 в окне Project (Проект) и перетащите его в область слоев окна Timeline (Монтаж) (рис. 2.23).

В результате композиция Соmр 3 будет вставлена в композицию Соmр 1 в виде нового слоя с тем же именем Соmр 3 (рис. 2.24).

Рис. 2.22. Результат разделения окна Composition

Рис. 2.23. Вставка композиции Соmр 3 в композицию Соmр 1

Рис. 2.24. Композиция Comp 3 вставлена в композицию Соmр 1 в виде нового слоя

Примечание

Точно так же в After Effects осуществляется вставка в композиции других элементов (видео- или звуковых клипов, титров и т. д.). Об этом будет идти речь на следующих уроках.


2.6. Палитры

Программы, разрабатываемые компанией Adobe, как правило, имеют характерный элемент интерфейса, называемый палитрами (palettes).

Рис. 2.25. Палитры

Палитры, по сути, являются несколько облегченными вариантами типичных окон и служат для совершения определенных действий по редактированию фильма. В After Effects имеется несколько палитр, каждая из которых предназначена для осуществления сходных по смыслу операций. На рис. 2.25 показано, как выглядят некоторые из палитр.

Чтобы вызвать на экран ту или иную палитру, необходимо воспользоваться пунктом меню Window (Окно). Центральная часть этого меню включает список имеющихся палитр (рис. 2.26), и выбор определенного элемента списка выводит на экран соответствующую палитру.

Рис. 2.26. Вызов на экран и скрытие палитр производится при помощи пункта меню Window

На рис. 2.26 изображена палитра Tools (Инструментарий), имеющая в After Effects особое значение. При первом запуске программы она автоматически появляется на экране, и впоследствии практически всегда нужна при редактировании фильмов. Инструментарий содержит ряд кнопок, соответствующих различным инструментам, и показывает, какой из инструментов является выбранным в каждый момент времени (кнопка такого инструмента находится в нажатом состоянии). Для выбора нужного инструмента достаточно просто нажать соответствующую кнопку на палитре Tools (Инструментарий). Некоторые из кнопок скрыты, и для их вызова следует воспользоваться маленькими пиктограммами-стрелками, которые вы видите в углах некоторых из кнопок.

Каждый инструмент служит для определенных действий с фильмом. Например, самый первый инструмент — Selection (Выбор) — предназначен для выделения различных элементов на кадре фильма, второй инструмент — Rotation (Поворот) — для вращения содержимого того или иного слоя и т. д. Более подробно о назначении и приемах работы с палитрой Tools (Инструментарий) мы расскажем на уроке 6.

Еще одна очень важная палитра — это Info (Информация). Она содержит самые важные сведения о выделенном в данный момент элементе кадра и особенно удобна, поскольку эти сведения являются контекстно-зависимыми (т. е. при выделении текстовых объектов содержат такую информацию, как тип и размер шрифта, для графических примитивов — цвет и тип линий и заливок и т. п.). Для вызова этой палитры выполните следующие действия:

1. Раскройте выпадающее меню Window (Окно).

2. Выберите в нем пункт Info (Информация).

В результате палитра Info (Информация) появится на экране, возможно, в комбинации с другими палитрами (рис. 2.27). На ее примере покажем, как можно разделять и совмещать палитры (что бывает важно для повышения удобства работы в After Effects).

Рис. 2.27. Палитра Info может быть совмещена с другими палитрами

Чтобы разделить скомбинированные палитры:

1. Схватитесь указателем мыши за закладку нужной вам палитры, например, Info (Информация).

2. Перетащите закладку за пределы окна палитры.

В результате палитры будут разделены (рис. 2.28). По похожему принципу (перетаскивая закладку одной из палитр на другую палитру) можно совместить различные палитры в одном окне. Напомним, что, кроме того, можно закрыть окна ненужных вам палитр при помощи кнопки управления окном (рис. 2.29).

Рис. 2.28. Для разделения совмещенных палитр перетащите одну из их закладок за пределы палитры

Рис. 2.29. Скрыть палитру можно при помощи кнопки управления окном


2.7. Резюме

В завершение урока перечислим коротко основные детали интерфейса приложения After Effects, которые помогают осуществлять операции в окнах:

  • верхнее меню (menu bar) — строка меню, находящаяся под заголовком основного окна After Effects (см. рис. 2.1);
  • контекстные (или всплывающие) меню (context menu, pop-up menu)— меню, появляющиеся при нажатии в том или ином месте правой кнопки мыши. Это особенно удобный и развитый в продуктах компании Adobe способ редактирования, поскольку состав всплывающих меню зависит от того места, в котором вы его вызываете, и вам легко найти в нем нужную команду (см. рис. 2.16);
  • палитры — специфические вспомогательные окна, позволяющие осуществлять те или иные операции;
  • меню окон и палитр (window menu) — специфические меню, характерные для продуктов Adobe и непривычные для пользователей других программ. Эти меню вызываются нажатием кнопки с треугольной стрелкой, которую легко отыскать в правой верхней части каждого окна и практически у каждой палитры (рис. 2.30), и содержат наборы команд, характерные для данного окна или палитры;
  • панели инструментов (toolbars) — многочисленные панели, размещенные в окнах и комбинирующие различные элементы управления;
  • горячие клавиши (shortcuts) — очень эффективный способ для опытных пользователей. Если вы часто применяете определенные команды, намного быстрее выполнять их нажатием сочетания клавиш на клавиатуре, чем вызовом меню или инструментов;
  • указатель мыши — в зависимости от места, на которое он наведен, и выбранных сочетаний опций окна (например, при том или ином активном инструменте) указатель выглядит по-разному. Если вы проработаете с After Effects некоторое время, то привыкнете к внешнему виду указателя, что будет помогать вам увереннее ориентироваться в возможностях редактирования в каждый момент времени;

Рис. 2.30. Меню окна Project

  • активные надписи и регуляторы параметров — характерный элемент интерфейса, который применяется для регулировки различных численных параметров (рис. 2.31).

Рис. 2.31. Активная надпись

Например, одна из таких надписей представляет таймкод текущего кадра в окне Timeline (Монтаж). Числовое значение параметра, представленного активной надписью, как правило, можно изменить непосредственно с клавиатуры (щелкнув предварительно на надписи мышью), а перетаскивание линии подчеркивания влево или вправо указателем мыши уменьшает или увеличивает значение параметра соответственно. Некоторые регуляторы параметров выполнены в виде характерных индикаторов, позволяющих визуальным способом корректировать их значение (рис. 2.32);

  • вложенные списки — еще одна деталь интерфейса, характерная для сложных программ, позволяющая представить в компактной форме группы сходных по смыслу параметров того или иного объекта. Вложенные списки устроены в виде иерархической последовательности списков, объединяющих группы сходных по смыслу параметров. Для того чтобы развернуть скрытую часть вложенного списка, достаточно щелкнуть на характерной треугольной кнопке, обращенной вправо (рис. 2.33). Для скрытия развернутого списка также следует щелкнуть на данной кнопке, которая в этом случае направлена вниз (рис. 2.34).

Рис. 2.32. Регулятор параметра

Рис. 2.33. Чтобы раскрыть содержимое вложенного списка, щелкните на треугольной кнопке

Рис. 2.34. Вложенный список развернут


Урок 3. Импорт клипов

  • На этом уроке...
  • 3.1. Импорт файлов
  • 3.2. Сохранение проекта
  • 3.3. Клипы в окне Project
  • 3.4. Просмотр клипов
  • 3.5. Резюме


На этом уроке...

Разберемся, как следует в Adobe After Effects начинать работу над подготовленными вами ранее мультимедийными файлами.

  • Чего мы хотим:

  • импортировать в After Effects видео и звук из внешних файлов;
  • просмотреть эти файлы средствами After Effects.

Нам потребуется:

  • любой видеофайл (он может быть беззвучным), например, файл с расширением avi;
  • любой звуковой файл, например, файл с расширением wav;
  • любой графический файл, например, с расширением bmp.


3.1. Импорт файлов

Начинать работу в After Effects следует с действий в окне Project (Проект) (рис. 3.1).

Рис. 3.1. Окно Project

Как мы уже говорили, при загрузке программы After Effects создается новый проект, являющийся, по сути, записью всех ваших действий по редактированию фильма. Вначале проект пуст, и ваша задача — поместить туда необходимые файлы или в терминах видеомонтажа — клипы. Поэтому для того, чтобы начать монтировать полноценный фильм с помощью, вам необходимо иметь исходные видео-, звуковые или графические файлы на своем компьютере, проводя различные манипуляции с которыми, в итоге вы получите фильм. Эти файлы, или, по-другому, исходный материал (footage), может появиться в результате предварительной записи видео на цифровые носители (видеокамеры и т. п.), оцифровки аналогового видео при помощи устройств видеозахвата (capture devices), первичного монтажа (например, в программе Adobe Premiere или Windows Movie Maker) и т. д. Звуковые файлы могут быть изначально записаны с помощью микрофона, подключенного к звуковой карте вашего компьютера, а статические изображения — подготовлены в одном из графических редакторов (к примеру, в Adobe Photoshop или Microsoft Paint).

Вы должны хорошо представлять себе, где именно расположены исходные медиа-файлы на дисках вашего компьютера и, по возможности, не менять их расположения на протяжении того времени, пока работаете над проектом в After Effects. Заметим, что при помощи средств ОС Windows XP удобно ориентироваться в содержимом медиа-файлов (рис. 3.2).

Рис. 3.2. Предварительный просмотр первого кадра видеофайла в Windows XP

В частности, двойной щелчок на имени того или иного (видео- или звукового) файла позволяет запустить его просмотр или прослушивание в окне установленного в системе проигрывателя, например, Windows Media Player (рис. 3.3).

Рис. 3.3. Просмотр видеофайла при помощи проигрывателя Windows Media Player

В любом случае перед тем, как получить возможность делать что-либо с предварительно подготовленными медиа-файлами, необходимо поместить их в окно Project (Проект) программы After Effects, или, говоря иначе, импортировать их в проект.

Для того чтобы импортировать файлы в проект:

1. Щелкните правой кнопкой мыши в свободной области окна Project (Проект).

2. В появившемся контекстном меню выберите Import>File (Импорт>Файл) (рис. 3.4).

Рис. 3.4. Начало импорта файла в проект After Effects

3. В открывшемся диалоге Import File (Импорт файла) перейдите к содержимому той папки, в которой находятся нужные вам медиа-файлы (рис. 3.5).

Рис. 3.5. Импорт файла

4. Выделите тот файл в списке содержимого папки, который вы хотите импортировать (в нашем случае это файл movie.avi).

5. Нажмите кнопку Open (Открыть).

В результате имя файла (наряду с его атрибутами) появится в окне Project (Проект) (рис. 3.7).

Рис. 3.6. Управление видом списка файлов при импорте

Рис. 3.7. Импортированный файл появляется в окне Project

Примечание 1

В диалоговом окне Import File (Импорт файла) можно управлять видом списка медиа-файлов при помощи соответствующего выпадающего меню (рис. 3.6). В частности, очень удобен вид просмотра Thumbnails (Миниатюры), позволяющий непосредственно в диалоговом окне Import File (Импорт файла) просматривать первые кадры файлов.

Примечание 2

Вызвать диалоговое окно Import File (Импорт файла) можно и более простым способом: двойным щелчком на любом пустом месте окна Project (Проект). Для освоившихся в среде After Effects пользователей можно также посоветовать активнее применять дополнительные возможности импорта исходных файлов и организации окна Project (Проект) при помощи папок, подобно тому, как обычные файлы размещаются на диске компьютера.

Если вы захотите импортировать в проект еще какие-либо исходные файлы, чтобы использовать их в создаваемом фильме, то сделать это можно в любой момент работы с After Effects, используя ту же последовательность действий.

Примечание

Медиа-файлы, имеющиеся у вас на компьютере, могли быть изначально сжаты при помощи различных кодеков (см. урок 1). Если соответствующий кодек не был предварительно установлен в операционной системе, то After Effects при импорте выдаст предупреждение о невозможности распознать данный медиа-файл (рис. 3.8).

Рис. 3.8. Файлы, сжатые при помощи кодеков, не установленных в ОС, не распознаются After Effects

Медиа-файлы других типов импортируются в проекты точно так же. Однако описанный способ импорта вовсе не является единственно возможным. На примере файла с рисунком image.bmp рассмотрим, как можно осуществить импорт при помощи техники перетаскивания (drag-and-drop).

1. Расположите на экране одновременно и окно программы After Effects, и окно той папки, в которой находится медиа-файл, который вы собираетесь импортировать в проект. В нашем случае это файл image.bmp (рис. 3.9).

Рис. 3.9. Импорт файла в проект After Effects при помощи перетаскивания из папки в ОС Windows

2. Схватитесь за пиктограмму или название файла в папке.

3. Перетащите файл в окно Project (Проект) в программе After Effects.

В результате файл будет импортирован в проект, и его название появится в окне Project (Проект).

Для того чтобы закрепить полученные навыки, импортируем (любым из описанных способов) еще один файл, на этот раз со звукозаписью, например, sound.wav. Сделайте это самостоятельно.

Таким образом, мы теперь имеем в окне Project (Проект) три файла с различными типами медиа: видеофайл movie.avi, звуковой файл sound.wav и рисунок image.bmp (см. рис. 3.12).

Примечание

Если медиа-файлы, которые вы собираетесь импортировать в проект, использовались в последнее время в этом или других проектах, то осуществить их импорт можно проще и быстрее. Для этого в верхнем меню File (Файл) наведите указатель мыши на пункт Import Recent Footage (Импорт недавнего клипа) и в появившемся подменю выберите нужный вам медиа-файл (рис. 3.10).

Рис. 3.10. Импорт файла, с которым вы недавно работали в After Effects, удобно осуществлять при помощи подменю Import Recent Footage верхнего меню File


3.2. Сохранение проекта

Окно Project (Проект) является библиотекой медиа-файлов, из которых вы собираете свой фильм. Бросая на него взгляд, можно сразу сказать, какие файлы задействованы в проекте, и каковы их основные атрибуты. Название текущего проекта отображается в заголовке его окна, причем, пока вы не сохранили вновь созданный проект, он условно называется именем Untitled Project.aep (см. рис. 3.1, 3.7).

Для того чтобы работа по редактированию проекта не пропала, его следует сохранить на диске вашего компьютера. Для этого:

1. Выберите в верхнем меню File>Save (Файл>Сохранить).

2. В открывшемся диалоге Save Project As (Сохранить проект как) введите желаемое имя проекта (рис. 3.11), например, start.aep.

3. Нажмите кнопку ОК.

Рис. 3.11. Сохранение проекта в файле

В результате проект будет сохранен в файле, и имя этого файла появится в заголовке окна Project (Проект) (см. рис. 3.11). Более подробную информацию о способах работы с файлами проектов After Effects вы получите на уроке 7.

Впоследствии применение команды File>Save (Файл>Сохранить) будет приводить к сохранению проекта в том же самом файле (без вывода диалогового окна).

Совет

По мере редактирования фильмов в After Effects чаще сохраняйте файл с проектом, чтобы при каком-либо сбое в работе программы ваш труд не пропал даром.


3.3. Клипы в окне Project

Рассмотрим основные детали строения окна Project (Проект), используя в качестве примера импортированные нами только что файлы movie.avi, sound.wav и image.bmp (см. рис. 3.12). Условимся также называть (чтобы не нарушать параллель с программой Adobe Premiere) медиа-файлы, уже импортированные в проект After Effects, клипами (clip), хотя в оригинале разработчики After Effects называют их материалом (footage). Таким образом, у нас в проекте присутствуют: один видеоклип, один аудиоклип и один клип со статическим изображением.

Под заголовком окна Project (Проект) находится область предварительного просмотра, содержащая миниатюру первого кадра и перечень наиболее важных свойств клипа, выделенного в окне Project (Проект). Для того чтобы увидеть информацию о клипе и его миниатюру, вам достаточно выделить его в списке клипов, находящемся под областью предварительного просмотpa и занимающем большую часть окна Project (Проект). Список клипов организован в виде таблицы и содержит не только их имена, но и дополнительную информацию, размещенную в столбцах. Возможно, все столбцы не будут помещаться в окно Project (Проект), и для Того чтобы их увидеть, вам потребуется слегка увеличить ширину окна, передвинув указателем его правую границу вправо.

Рис. 3.12. Клипы в окне Project (выделен видеоклип)

Попробуйте теперь щелкнуть на всех клипах по очереди — и вы увидите, информация какого рода доступна в области предварительного просмотра для клипов разных типов (сравните при этом ее с информацией о клипах, приведенной в столбцах таблицы).

1. Щелкните в списке на видеоклипе movie.avi — его кадр загрузится в миниатюру области предварительного просмотра (см. рис. 3.12).

2. Щелкните на звуковом клипе sound.wav — в области миниатюры вы увидите пустой кадр и под ним график интенсивности звука. Это указывает на то, что клип содержит только звук (рис. 3.13).

Примечание

Если видеоклип не немой, как в нашем случае, а звуковой, то миниатюра в окне Project (Проект) содержит и амплитудный график интенсивности звука (как для аудиоклипа с рис. 3.13).

Рис. 3.13. В окне Project выделен звуковой клип

3. Щелкните на клипе со статическим изображением image.bmp — вы сможете наблюдать в миниатюре соответствующий рисунок, импортированный из графического файла (рис. 3.14).

Рис. 3.14. В окне Project выделен клип со статическим изображением

4. Щелкните теперь на любом свободном месте окна Project (Проект), т. е. за пределами любого из клипов. Выделение со всех клипов снимется, а область предварительного просмотра станет пустой (рис. 3.15).

Рис. 3.15. Выделение со всех клипов снято

В завершение разговора об импорте нельзя не сказать несколько слов о том, что происходит в программе After Effects, когда мы импортируем в проект файлы. Очень важно понимать, что при этом не создается никаких копий исходных медиа-файлов, а просто информация о них считывается After Effects. Фактически возникновение клипов в окне Project (Проект) представляет собой просто появление соответствующей ссылки и установление скрытой связи с указанным медиа-файлом.

Таким образом, ни при импорте, ни при дальнейших (часто весьма замысловатых) операциях пользователя в приложении After Effects с исходными медиа-файлами абсолютно ничего не происходит. Все действия по редактированию клипов (такие, как их урезание, применение эффектов и т. д.) заключаются, во-первых, в извлечении программой After Effects необходимой информации из медиа-файла и, во-вторых, в формировании на ее основе вторичного изображения кадра и саундтрека фильма. При этом производится обработка изображения с учетом всех назначенных пользователем эффектов, созданных рисунков и титров и т. п., с тем, чтобы рассчитать окончательный кадр фильма. Такой процесс обработки видео называется рендерингом (rendering).

При просмотре скомпонованного в After Effects фильма программа осуществляет рендеринг кадров настолько быстро, насколько ей это позволяет производительность вашего компьютера. Если компьютер быстродействующий и имеет достаточный объем оперативной памяти, то обработка изображения и выдача итогового видео могут производиться в режиме реального времени. Для менее мощных компьютеров требуется дополнительное время на осуществление рендеринга и подготовку файлов предварительного просмотра.

Завершающим же этапом работы с фильмом является его экспорт, т. е. последовательная обработка компьютером всех кадров композиции, при которой производится извлечение информации из исходных файлов и вычислительная обработка по соответствующим алгоритмам согласно всем действиям пользователя, записанным в проекте. В результате сгенерированный фильм записывается (или, как говорят, экспортируется) в новый медиа-файл (либо сразу выводится на внешнее устройство, если оно надлежащим образом подключено к компьютеру). Еще раз подчеркнем, что исходные медиа-файлы не подвергаются никаким изменениям, а служат простыми поставщиками данных для последующей обработки в After Effects.


3.4. Просмотр клипов

Просмотреть и/или прослушать любой исходный видеоклип можно непосредственно в After Effects с помощью предусмотренного для этого окна Footage (Клип). К примеру, запустим на воспроизведение клип movie.avi.

1. Щелкните дважды на имени интересующего вас клипа (т. е. movie.avi) в окне Project (Проект) — его первый кадр откроется в появившемся окне Footage (Клип) (рис. 3.16), которое служит в After Effects проигрывателем.

Рис. 3.16. Исходные видеоклипы просматриваются в окне Footage

2. Нажмите в окне Footage (Клип) кнопку Start (Старт) (на нее на рис. 3.16 наведен указатель мыши). В результате клип начнет воспроизводиться в этом окне, а внешний вид кнопки Start (Старт) изменится на тип Stop (Стоп) (рис. 3.17).

Рис. 3.17. Для приостановки воспроизведения клипа следует нажать кнопку Stop

3. Остановите воспроизведение клипа нажатием кнопки Stop (Стоп) в окне Footage (Клип) (см. рис. 3.17). В результате воспроизведение клипа приостановится, а эта кнопка опять приобретет вид Start (Старт), нажатием которой можно будет возобновить воспроизведение клипа с текущего кадра.

Примечание

По умолчанию окно Footage (Клип) использует для просмотра исходных клипов минимальные средства управления воспроизведением (похожие на средства проигрывателя Windows Media Player, как показано на рис. 3.16, 3.17, или QuickTime). Наряду с этим, имеется возможность открыть исходный клип и в стандартном для After Effects окне просмотра (рис. 3.18), таком же, как Layer (Слой) или Composition (Композиция). Для этого в момент двойного щелчка на имени клипа в окне Project (Проект) следует удерживать на клавиатуре клавишу <Alt> (или клавишу <Option>, в том случае, если вы работаете в среде Mac OS).

Точно так же, как видеофайлы, в окне Footage (Клип) могут быть просмотрены звуковые файлы (рис. 3.19) и рисунки (рис. 3.20). Конечно, в разных случаях состав кнопок окна Footage (Клип) будет различным в зависимости от типа воспроизводимой информации.

Необходимо отметить, что воспроизводить (и затем обрабатывать) в After Effects возможно только те типы файлов, которые поддерживаются этой программой (их полный перечень вы найдете в разд. 7.2). Если вы предпримете попытку импортировать файл неизвестного формата, то будет выдано сообщение об ошибке (например, такое, как показано на рис. 3.21).

Рис. 3.18. Воспроизведение клипа в стандартном для After Effects окне Footage

Рис. 3.19. Прослушивание звукового клипа в окне Footage

Рис. 3.20. Просмотр в окне Footage статического изображения

При просмотре исходных клипов у пользователя часто возникает желание изменить масштаб их изображения (увеличить для того, чтобы различить детали клипа, или уменьшить, например, в целях экономии места на экране). Сделать это, в случае видеоклипов, можно простым изменением размеров окна Footage (Клип). Просто перетащите любую из границ окна Footage (Клип) в нужном направлении, и изображение кадра видеоклипа подстроится под изменившиеся размеры окна (рис. 3.22).

Рис. 3.21. При попытке импорта файла неизвестного формата выдается сообщение об ошибке

Рис. 3.22. Просмотр кадра видеоклипа в окне Footage в измененном масштабе

Окно Footage (Клип), в случае клипов со статическими изображениями, содержит панель инструментов в нижней части окна (см. рис. 3.20, 3.23).

Рис. 3.23. Выбор масштаба просмотра клипа с рисунком в окне Footage

Самый левый элемент панели представляет собой выпадающий список, при помощи которого можно выбрать масштаб изображения (рис. 3.23). При просмотре клипов со статическими изображениями перетаскивание границ окна Footage (Клип) не ведет к изменению масштаба рисунка, а служит для выбора отображения той или иной области рисунка (рис. 3.24).

Рис. 3.24. Для статических клипов изменение размера окна Footage служит в целях отображения той или иной области рисунка

Кроме того, для управления просмотром исходных статических изображений удобно использовать палитру Tools (Инструментарий).

1. Выберите в верхнем меню Window>Tools (Окно>Инструментарий).

2. Откройте в окне Footage (Клип) рисунок (если он у вас не открыт) и установите при помощи выпадающего списка Scale (Масштаб) какой-либо крупный масштаб просмотра (например, 200% или 800%).

3. Выберите в палитре Tools (Инструментарий) инструмент Hand (Рука) (рис. 3.25).

Рис. 3.25. Различные инструменты палитры Tools служат для проведения тех или иных действий

4. Наведите указатель мыши на окно Footage (Клип) с рисунком. При этом указатель изменит свой вид на пиктограмму руки.

5. Хватаясь за любое место рисунка при помощи инструмента Hand (Рука), перетащите изображение клипа в каком-либо направлении (рис. 3.26).

Рис. 3.26. Инструмент Hand служит для перемещения видимой части рисунка относительно активного окна (в данном случае окна Footage)

В результате в окне Footage (Клип) отобразится другой участок изображения статического клипа (сравните рис. 3.25 и 3.26). Таким образом, посредством "перетаскивания" инструментом Hand (Рука) можно смещать изображение относительно окна Footage (Клип), просматривая интересующие вас участки в крупном масштабе.

Помимо этого, можно управлять масштабом просмотра статических клипов при помощи инструмента Zoom (Масштаб).

1. Выберите в палитре Tools (Инструментарий) инструмент Zoom (Масштаб).

2. Наведите на окно Footage (Клип) с рисунком указатель мыши, который при этом приобретет вид пиктограммы с изображением лупы.

3. Щелкните в любом месте рисунка — масштаб его отображения увеличится (рис. 3.27).

Рис. 3.27. Увеличение масштаба просмотра статического клипа при помощи инструмента Zoom

4. Нажмите и удерживайте клавишу <Alt> — указатель приобретет вид лупы со знаком "минус" внутри.

5. Повторите щелчок на рисунке при нажатой клавише <Alt>. В результате масштаб отображения рисунка уменьшится (рис. 3.28).

Рис. 3.28. Уменьшение масштаба при помощи инструмента Zoom

Таким образом, при помощи панели инструментов удобно совершать те или иные действия в окне Footage (Клип) с рисунком. Обратите внимание, что не все кнопки на панели Tools (Инструментарий) доступны при работе с окном просмотра статического клипа. Недоступные кнопки соответствуют инструментам, которые служат для редактирования тех или иных действий с композициями.

В зависимости от того, какое из окон After Effects является активным в данный момент, панель Tools (Инструментарий) предлагает тот или иной набор доступных инструментов, соответствующий допустимому набору операций в активном окне.

1. Сделайте активным окно Footage (Клип) с видеофайлом и обратите внимание, что почти все инструменты панели Tools (Инструментарий), в частности, инструмент Hand (Рука), становятся недоступными (рис. 3.29).

2. Откройте какую-либо композицию в окне Composition (Композиция), и вы увидите, что в этом случае большинство инструментов палитры Tools можно использовать.

Рис. 3.29. Большинство инструментов являются недоступными при работе с видеоклипом в окне Footage


3.5. Резюме

Импорт видео, звука и рисунков из внешних файлов для использования их в After Effects осуществляется при помощи команды Import>File (Импорт> Файл) верхнего меню File (Файл). Просматривать исходные файлы можно при помощи окна Footage. О том, как именно можно добавить клипы в композиции, мы расскажем на следующем уроке.


Урок 4. Композиции

  • На этом уроке...
  • 4.1. Создание новой композиции
    • 4.1.1. Создание новой композиции
    • 4.1.2. Строение окна Timeline
    • 4.1.3. Создание композиции с установками исходного видеофайла
    • 4.1.4. Работа с несколькими композициями
  • 4.2. Установки композиций
    • 4.2.1. Просмотр и редактирование установок
  • 4.3. Добавление слоев в композицию
    • 4.3.1. Сценарий
    • 4.3.2. Вставка клипов
    • 4.3.3. О просмотре композиций
  • 4.4. Резюме


На этом уроке...

Перейдем к составлению композиций из исходных клипов и разберемся с тем, как они могут добавляться в окно Timeline (Монтаж). Кроме того, мы научимся переходить к нужным кадрам вдоль линейки времени и управлять ее масштабом, а также познакомимся с тем, как нужно правильно расставлять слои в окне Timeline (Монтаж).

  • Чего мы хотим:

  • составить композицию (т. е. новый фильм) из исходных клипов (сценарий фильма приведен в разд. 4.3);

  • Нам потребуется:

  • те же три файла, что и на прошлых уроках (см. урок 3): видео, звуковой и графический.

  • Что полезно вспомнить:

  • как создаются новые композиции (см. урок 2)
  • каковы основные свойства цифрового представления видеозаписей (см. урок 1);
  • как осуществляется импорт исходных файлов в проекты (см. урок 3).


4.1. Создание новой композиции

Рассмотрим, какими способами в After Effects можно создавать новые композиции и какие основные средства окна Timeline (Монтаж) предназначаются для их редактирования.


4.1.1. Создание новой композиции

Для начала создадим новую композицию, в которую мы добавим исходные клипы.

1. Создайте новый проект и импортируйте в него три файла: видеофайл movie.avi, звуковой файл music.wav и рисунок image.bmp (о том, как это сделать, мы подробно говорили на уроке 3 — возможно, вместо создания нового проекта вам будет удобнее просто открыть созданный на этом уроке проект start.aep).

2. Начните создание новой композиции нажатием кнопки New Composition (Создать композицию) на панели инструментов окна Project (Проект) (рис. 4.1).

Рис. 4.1. После импорта в проект исходных файлов начните создание новой композиции

3. В открывшемся диалоге Composition Settings (Установки композиции) вместо предлагаемого по умолчанию имени создаваемой композиции введите желаемое название, например, Chaplin (рис. 4.2).

Рис. 4.2. Введите желаемое имя создаваемой композиции в Composition Name диалога Composition Settings

4. Нажмите в диалоге кнопку ОК, не меняя никаких других параметров (подробный разбор параметров композиции мы отложим до следующего раздела).

Примечание

Обратите внимание на то, что все установки композиции предлагаются вам программой After Effects, исходя из принятых параметров по умолчанию. В случае, если вам требуется создать новый фильм на основе установок какого-либо из исходных клипов, можно воспользоваться другим способом создания композиции (см. далее в этом же разделе).

В результате в окне Project (Проект) появится новый элемент — композиция Chaplin (рис. 4.3), которая одновременно откроется в двух новых окнах — Timeline (Монтаж) и Composition (Композиция). Поскольку эта композиция только что создана, ни одного слоя в ней пока нет, т. е. столбец Source Name (Название источника) в окне Timeline (Монтаж) является пустым.

Рис. 4.3. Результат создания новой композиции Chaplin


4.1.2. Строение окна Timeline

Скажем несколько слов о строении окна Timeline (Монтаж). Оно включает в себя несколько групп элементов управления:

  • непосредственно под заголовком окна находится одна (как в нашем случае) или несколько (если вы редактируете одновременно сразу несколько различных композиций) закладок. Пока наш проект содержит единственную композицию Chaplin. Вся остальная область окна Timeline (Монтаж), которую вы видите под закладками, относится к данной композиции;
  • под закладкой находится панель инструментов окна Timeline (Монтаж), которая начинается с активной надписи номера кадра (таймкода). В правой части вы видите шкалу времени;
  • оставшаяся, наибольшая, область окна содержит список слоев, входящих в фильм, и их атрибутов (слева), а также (под шкалой времени) схематическое расположение места слоев в фильме. Пока наша композиция ничего не содержит, список слоев является пустым.

Перед тем как перейти к добавлению клипов в созданную композицию, проведем несколько простых опытов, которые позволят нам лучше разобраться в особенностях окна Timeline (Монтаж).

Обратите внимание на то, что переместиться далее некоторого времени (по умолчанию 30 с) по шкале времени в окне Timeline (Монтаж) не удается. Это означает, что общая длительность композиции составляет 30 с, а за пределы композиции выйти невозможно. Если вы хотите изменить продолжительность фильма, то следует обратиться к его установкам, вызывая соответствующее диалоговое окно при помощи меню окна Timeline (Монтаж).

Как вы помните, один из кадров композиции в каждый момент времени является выделенным и называется текущим кадром. Его номер вы видите как в окне Timeline (Монтаж), так и в окне Composition (Композиция). Чтобы перейти к другому кадру при помощи окна Timeline (Монтаж), достаточно схватиться указателем мыши за ползунковый регулятор на шкале времени (индикатор текущего кадра) и перетащить его на желаемое место (рис. 4.4). Можно также просто щелкнуть на нужном вам кадре шкалы времени, и он станет текущим, а линия редактирования, соответственно, "перескочит" на этот кадр, а его изображение откроется в окне Composition (Композиция).

Рис. 4.4. Чтобы перейти к нужному кадру фильма, перетащите по шкале времени окна Timeline ползунковый регулятор текущего кадра

Может оказаться, что не все время композиции (в нашем случае 30 с) укладывается в видимой области временной шкалы, а часть ее просто не помещается в окно Timeline (Монтаж). В этом случае следует использовать полосу прокрутки, расположенную, в самом низу окна Timeline (Монтаж) (рис. 4.5). Перемещая ползунок на полосе прокрутки, вы сможете сделать доступным в видимой области шкалы времени любой участок фильма.

Рис. 4.5. Перемещая бегунок полосы прокрутки области клипов в окне Timeline, можно переходить к интересующему вас участку фильма

Важная возможность шкалы времени связана с тем, что пользователь может в любой момент изменять ее масштаб, выбирая наиболее удобное пространство для монтажа фильма, "приближая" или "отдаляя" (во времени) редактируемую область.

Для того чтобы выбрать масштаб временной шкалы, можно использовать несколько возможностей:

  • перетаскивание ползункового регулятора масштаба (Zoom Slider) влево или вправо в целях его плавного уменьшения или увеличения соответственно (рис. 4.6);
  • нажатие кнопок Zoom Out (In time) (Уменьшить временной масштаб) или Zoom In (In time) (Увеличить временной масштаб), которые расположены по бокам регулятора масштаба;
  • использование индикатора полной длительности.

Рис. 4.6. Для того чтобы изменить масштаб временной шкапы в окне Timeline (т. е. "приблизить" или "отдалить" область клипов), следует использовать регулятор масштаба

Обратимся теперь к области клипов, которая содержит, помимо столбца Source Name (Название источника), еще несколько столбцов со служебной информацией о клипах и примененных к ним эффектах. В зависимости от того, какие именно операции вы проводите в окне Timeline (Монтаж), удобно скрывать неиспользуемые в данный момент столбцы, увеличив тем самым долю временной шкалы и пиктограмм клипов. Для скрытия двух разных групп столбцов (столбцов переключения свойств слоя и столбцов с атрибутами слоя) служат две кнопки Expand or Collapse Pane (Развернуть или свернуть панель) в нижней части окна Timeline (Монтаж) (рис. 4.7). Их нажатие либо скрывает соответствующую группу столбцов, либо (если столбцы были скрыты) выводит ее на экран. Выполните следующие операции:

1. Поэкспериментируйте с ползунковым регулятором и кнопками регулировки масштаба (рис. 4.6), обращая внимание на изменения, происходящие при этом со шкалой времени.

2. Скройте все поддающиеся этой операции столбцы атрибутов слоев (см. рис. 4.7).

3. Щелкните на заголовке оставшегося столбца Source Name (Название источника), обращая внимание на то, что его название должно измениться на Layer Name (Название слоя). Повторите эту операцию, замечая, что название столбца стало первоначальным. Как вы понимаете, данная опция связана с возможностью представления слоев в окне Timeline (Монтаж) либо по имени слоя, либо по имени исходного клипа, создавшего этот слой.

4. Вызовите меню окна Timeline (Монтаж) и наведите в нем указатель мыши на пункт Columns (Столбцы). В появившемся подменю со списком столбцов окна Timeline (Монтаж) обратите внимание на те из них, которые выделены флажками (это значит, что данные столбцы присутствуют на экране). Поэкспериментируйте с подменю Columns (Столбцы), скрывая и вновь вызывая те или иные столбцы окна Timeline (Монтаж).

Рис. 4.7. Некоторые (вспомогательные) столбцы в окне Timeline могут быть временно скрыты нажатием кнопки Expand or Collapse the Layer Switches pane


4.1.3. Создание композиции с установками исходного видеофайла

Итак, мы научились создавать новые композиции, освоили основные возможности окна Timeline (Монтаж) и теперь можем обратиться к добавлению клипов из окна проекта. Перед тем как перейти к вставке клипов из окна Project (Проект), скажем о втором возможном способе создания новых композиций — на основе имеющихся в проекте клипов. Напомним, что пока мы создавали новые композиции с установками, которые предлагались After Effects по умолчанию и которые мы не изменяли.

Очень часто при работе с After Effects возникает задача создания новой композиции на основе свойств некоторого исходного клипа. Попросту говоря, вам может понадобиться определенным образом отредактировать видеофайл, например, применив к нему спецэффекты, добавив титры, дорисовав что-либо на видеоизображении и т. п. (очень часто именно в этом и заключается необходимость использования самой программы After Effects для редактирования видео). Для решения такой задачи желательно создать новый фильм с теми же самыми установками, что имеет исходный видеофайл.

1. Выделите в окне Project (Проект) желаемый видеоклип (в нашем случае movie.avi), на основе установок которого вы собираетесь создать новую композицию.

Рис. 4.8. Для создания новой композиции на основе установок некоторого клипа начните с его перетаскивания из списка клипов окна Project

2. Захватите этот клип указателем мыши (рис. 4.8) и перетащите его на кнопку New Composition (Создать композицию) на панели инструментов окна Project (Проект) (рис. 4.9).

Рис. 4.9. Для завершения создания композиции с установками клипа отпустите этот клип на кнопке New Composition в окне Project

После того как вы отпустите кнопку мыши, новая композиция будет создана, причем, во-первых, ее установки будут идентичны установкам клипа movie.avi (без требования дополнительных подтверждений), и, во-вторых, эта композиция появится не пустой, а уже будет содержать слой movie.avi (рис. 4.10).

Рис. 4.10. В результате создается новая композиция на основе свойств выбранного клипа, содержащая его в качестве слоя

Чтобы убедиться в различии установок двух композиций нашего проекта:

1. Выделите в окне Project (Проект) исходный видеоклип movie.avi и обратите внимание на его атрибуты, перечисляемые в области предварительного просмотра (см. рис. 4.8).

2. Выделите в окне Project (Проект) композицию Movie Comp 1 и убедитесь в том, что ее основные установки (размер кадра и длительность) совпадают с установками видеоклипа movie.avi (рис. 4.11). Обратите внимание на то, что поскольку данная композиция уже содержит слой movie.avi, то в миниатюре отображается стартовый кадр композиции, т. е. стартовый кадр имеющегося в ней слоя.

Рис. 4.11. Новая композиция имеет те же самые установки, что и использованный при ее создании клип

3. Выделите в окне Project (Проект) композицию Chaplin (рис. 4.12). Вы увидите, что она имеет другие установки, нежели предыдущая композиция.

Рис. 4.12. Установки композиции, созданной командой File>New, выбирались по умолчанию


4.1.4. Работа с несколькими композициями

After Effects позволяет производить монтаж фильмов в многооконном режиме, т. е. одновременно редактировать несколько композиций. При этом следует помнить, что такая работа возможна только в пределах одного проекта (т. е. нельзя открыть в один момент два проекта).

Закладки с названиями композиций (composition tab) служат для того, чтобы раскрывать в окне Timeline (Монтаж) желаемую композицию, а также для закрытия и перераспределения композиций.

1. Щелкните сначала на одной закладке, а затем на другой и понаблюдайте, как та или другая композиция открываются в окне Timeline (Монтаж).

2. Схватитесь за одну из закладок и вытащите ее за пределы окна Timeline (Монтаж). Вы увидите, как возникнет еще одно окно Timeline (Монтаж) с той композицией, закладку которой вы перетащили.

3. Перетащите ту же самую закладку на прежнее место — два окна Timeline (Монтаж) совместятся в одном, и вы снова сможете переключать композиции при помощи закладок.

4. Нажмите кнопку закрытия композиции на одной из закладок — данная композиция исчезнет из окна Timeline (Монтаж).

5. Перейдите в окно Project (Проект) и дважды щелкните на имени только что закрытой композиции. Вы увидите, что она снова возникнет, наряду со своей закладкой, в окне Timeline (Монтаж), а ее кадр откроется в окне Composition (Композиция). Таким способом можно вновь открыть композиции, временно убранные с экрана.


4.2. Установки композиций

Определить установки новой композиции лучше всего на стадии создания, поскольку в дальнейшем просматриваться кадры фильма в окне Composition (Композиция) будут именно на основе этих установок. Поэтому рекомендуется выбирать установки, ориентируясь на планируемые свойства создаваемого видеофайла. Тем не менее изменить установки композиции с легкостью можно в любой момент работы над проектом.


4.2.1. Просмотр и редактирование установок

Продемонстрируем, как можно просмотреть (и, при надобности, отредактировать) установки фильма при помощи диалогового окна Composition Settings (Установки композиции):

1. Вызовите из пустой области окна Timeline (Монтаж), открытого на закладке с новой композицией, контекстное меню.

2. Выберите в контекстном меню пункт Composition Settings (Установки композиции).

3. Просмотрите установки в открывшемся диалоговом окне Composition Settings (Установки композиции), обращая внимание на его тождественность диалогу, открывавшемуся при создании новой композиции.

4. Закройте диалог нажатием кнопки Cancel (Отмена).

Как вы видите, при таком способе создания композиции можно не задумываться об ее установках, а если их впоследствии потребуется поменять, то можно сделать это при помощи диалогового окна Composition Settings (Установки композиции).

Рис. 4.13. Просмотр установок в диалоге Composition Settings

Перечислим теперь установки композиции, собранные в диалоге Composition Settings (Установки композиции) (рис. 4.13), имея в виду, что со смыслом большинства из них мы познакомились во вводной части нашей книги (см. урок 1).

Закладка Basic (Основные установки)

Эта закладка содержит следующие установки:

  • в поле Composition Name (Название композиции) вводится имя композиции, которое идентифицирует ее в окне Project (Проект) и появляется в заголовках и закладках окон Timeline (Монтаж) и Composition (Композиция);
  • при помощи выпадающего списка Preset (Предустановки) можно выбрать один из имеющихся наборов установок, заготовленных разработчиками After Effects. Например, пункт DV означает задание характерных параметров композиции, которые будут оптимальными для ее последующего вывода на цифровое устройство формата Digital Video. Если вы не уверены в выборе одной из имеющихся предустановок для вашей композиции, либо если вы предполагаете, что ее формат должен отличаться от этих предустановок, то можно задать все параметры композиции вручную;

Совет

Даже если вы используете одну из предустановок для определения формата композиции, будет нелишним просмотреть конкретные установки, чтобы убедиться в том, что все они выставлены верно.

  • две кнопки справа от списка Preset (Предустановки) — Save (Сохранить) и Delete (Удалить) — позволяют сохранить перечень текущих установок в качестве предустановки пользователя или, соответственно, удалить текущую предустановку из списка;
  • размер кадра композиции в пикселах по горизонтали и вертикали задается в полях числового ввода Width (Ширина) и Height (Высота). Изменение этого параметра в процессе редактирования композиции требует осторожности, т. к. следует учитывать изменение относительных размеров уже созданных слоев относительно нового размера кадра композиции. Старайтесь до начала монтажа определиться с размером кадра, который будет использоваться для экспорта фильма. Важно также учитывать, что, если вы готовите фильм для демонстрации на каком-либо телевизионном оборудовании, отношение размеров по горизонтали и вертикали должно соответствовать типу аппаратуры, на которой будет воспроизводиться ваша композиция. Например, многие телевизионные системы используют отношение ширины к высоте кадра, равное 4:3;
  • флажок проверки Lock Aspect Ratio (Выдерживать отношение размеров) предназначен для удобства регулировки размера кадра с учетом скрытого параметра отношения размеров по горизонтали и вертикали. Если флажок выставлен, то изменение пользователем одного из размеров кадра будет автоматически вести к пересчету и второго размера (в соответствии с текущим отношением размеров по вертикали и горизонтали). Если флажок снят — ширину и высоту кадра можно менять независимо друг от друга, не выдерживая пропорции между ними;
  • раскрывающийся список Pixel Aspect Ratio (Пропорции пиксела) задает отношение размеров отдельных пикселов, которые формируют изображение кадров. В большинстве случаев (в частности, для мониторов компьютеров) верным будет выбор варианта Square Pixel (Квадратные пикселы), если же вы собираетесь демонстрировать фильм на специальной телевизионной аппаратуре, обязательно сверьтесь со стандартом пропорций пиксела, которые она использует. В некоторых стандартах телевидения (например — DV NTSC, DV 1) используются не квадратные, а прямоугольные пикселы. В случае выбора неправильной пропорции пикселов изображение фильма при просмотре его на мониторе соответствующего стандарта будет искаженным (вытянутым по горизонтали или вертикали), в то время как на экране монитора компьютера фильм будет смотреться правильно;
  • раскрывающийся список Frame Rate (Частота кадров) — устанавливает частоту кадров композиции, т. е. число кадров, демонстрирующихся в течение одной секунды. Этот параметр также выставляется автоматически при выборе одной из предустановок;
  • Resolution (Разрешение) — выпадающий список, который позволяет выбрать разрешение кадра, демонстрирующегося в окне Composition (Композиция) при редактировании фильма. Полное разрешение означает представление каждого кадра с максимальным качеством, что иногда очень сильно замедляет работу в After Effects. В частности, просмотр композиции в реальном времени бывает невозможен, т. к. компьютер (особенно, если он у вас не самый мощный) попросту не успевает с нужной быстротой производить расчет кадров. Возможно, ускорить работу позволит выбор худшего разрешения (но это даст проигрыш в качестве картинки при работе с композицией). Разрешение можно выбрать не только в окне Timeline (Монтаж), но и в окне Composition (Композиция);
  • поля ввода Start Timecode (Начальный таймкод) или Start Frame (Начальный кадр) предназначены для возможного задания номера стартового кадра композиции, отличного от нулевого таймкода. Эта опция предусмотрена для удобства редактирования в некоторых специальных случаях, например, при монтаже составного фильма из нескольких композиций, идущих друг за другом, и не влияет на рендеринг;
  • в поле ввода Duration (Длительность) задается длительность композиции, т. е. максимальное значение по шкале времени в окне Timeline (Монтаж).

Закладка Advanced (Дополнительные установки)

Менее важные и реже используемые установки сгруппированы под закладкой Advanced (Дополнительно) и содержат следующие параметры (рис. 4.14).

Рис. 4.14. Дополнительные установки композиции в диалоге Composition Settings

  • Anchor (Управление привязкой) — задает способ изменения размера изображения кадров при масштабировании слоев. Можно привязать процесс масштабирования либо к углу (corner) кадра слоя, либо к его границе (edge);
  • параметры Shutter Angle (Направление движения шторки) и Shutter Phase (Фаза шторки) задают установки для эффекта размытия при движении (motion blur). Этот эффект имитирует (для анимации) съемку видеокамерой, принцип которой заключается в фотографировании каждого кадра фильма путем краткосрочного открытия шторки объектива;
  • при работе со вложенными композициями важны установки Preserve Resolution (Сохранять разрешение) и Preserve Frame Rate (Сохранять частоту кадров), которые задают метод рендеринга вложенных композиций. Если эти флажки выставлены, то при расчете изображения кадров фильма, содержащего вложенную композицию, ее разрешение и частота кадров будут такими, как определено в установках данной вложенной композиции (а не в композиции, в которую она вставлена).
  • раскрывающийся список Rendering Plug-In (Модули 3D-рендеринга) позволяет выбрать алгоритм расчета кадров композиции, содержащей трехмерные слои. Помимо встроенных средств рендеринга трехмерных слоев, в After Effects имеется возможность использования подключаемого программного модуля, который во многих случаях обеспечивает расчет более реалистичной объемной картинки.


4.3. Добавление слоев в композицию

Итак, мы выполнили два подготовительных действия, которые необходимо осуществить перед собственно началом компоновки фильма, а именно:

  • создали новую композицию (мы назвали ее Chaplin);
  • импортировали в проект нужные нам клипы, из которых мы собираемся монтировать фильм.

Порядок этих действий значения не имеет, главное состоит в том, что теперь мы можем приступить к монтажу композиции.


4.3.1. Сценарий

Составим простой фильм из имеющихся в нашем распоряжении трех клипов, начав его монтаж на этом уроке, а завершив его на следующем. Будем придерживаться следующего модельного сценария:

  • в начале фильма на протяжении 3 с демонстрируется заставка (статическое изображение image.bmp);
  • на второй секунде начинается музыкальное сопровождение (проигрывается содержимое звукового файла music.wav);
  • после заставки начинает воспроизводиться видеофайл movie.avi;
  • общая длительность фильма составляет 30 с (если видеоклип movie.avi или звуковой клип music.wav длятся дольше, то они обрываются одновременно на 30-й секунде).

Примечание

Приведенный сценарий является типичным примером линейного монтажа, т. е. компоновке фильма "из кусочков" клипов, при котором с их изображением никаких дополнительных операций не производится. В противоположность линейному монтажу (подразумевающем простую "нарезку" видео- и звукового ряда и расположение их в желаемом порядке вдоль линейки времени), нелинейный монтаж означает применение к различным частям фильма разнообразных спецэффектов, которые трансформируют изображение кадров. Разумеется, программа After Effects является представителем приложений нелинейного монтажа, обладая богатой коллекцией самых разнообразных эффектов. Линейный монтаж (за исключением простейших случаев типа нашего текущего примера) осуществлять в After Effects неудобно, и для него гораздо лучше использовать программу Adobe Premiere (взаимодействию After Effects с Premiere посвящен разд. 7.2).

Вставка любого клипа в фильм производится при помощи добавления этого клипа в окно Timeline (Монтаж). При этом стиль монтажа может быть различным и зависит, главным образом, от опыта и привычек пользователя. Можно, к примеру, сначала перенести все клипы в окно Timeline (Монтаж) и расположить их в нужном порядке, а можно по очереди добавлять клипы, расставляя их в композиции, по мере вставки в фильм, в соответствии со сценарием. Мы изберем второй путь и будем, по ходу дела, разбираться с тем, что происходит в различных окнах After Effects. Затем (см. разд. 5.1, 5.2) мы отредактируем длительность клипов в соответствии со сценарием и продемонстрируем, как можно изменять относительно линейки времени положение слоя, который уже добавлен в композицию.


4.3.2. Вставка клипов

Начнем с монтажа заставки (статического изображения):

1. Откройте в окне Timeline (Монтаж) закладку с нужной вам композицией (в нашем случае Chaplin).

2. Установите линию редактирования на тот кадр композиции, который вы хотите совместить с началом клипа. Мы хотим вставить клип image.bmp в самое начало фильма, поэтому текущим кадром следует выбрать стартовый кадр композиции, т. е. с номером 0:00:00:00 (рис. 4.15).

Рис. 4.15. Начните вставку клипа в композицию с выбора кадра, с которого будет начинаться клип

Примечание

Как вы помните (см. разд. 4.1), выбрать текущий кадр можно либо перетаскиванием ползунка (индикатора текущего кадра) на нужное место на шкале времени, либо вводом с клавиатуры таймкода в диалоге, появляющемся после щелчка на активной надписи номера текущего кадра в окне Timeline (Монтаж).

3. Перейдите в окно Project (Проект) и выделите в нем клип image.bmp.

4. Схватитесь указателем мыши за клип image.bmp в окне Project (Проект) и перетащите его на окно Timeline (Монтаж) (рис. 4.16). Отпустите кнопку мыши над областью слоев в этом окне.

Рис. 4.16. Для вставки клипа в фильм перетащите его из окна Project на окно Timeline

В результате клип будет вставлен в композицию, и в окне Timeline (Монтаж) появится новый слой, который будет иметь то же имя, что и клип, т. е. image.bmp (рис. 4.17).

Примечание

Несложно догадаться, почему на рис. 4.17 мы видим, что лишь часть рисунка image.bmp поместилась в кадр композиции. Действительно (см. рис. 4.13), размер кадра композиции Chaplin установлен в значение 320x240, в то время, как размер кадра рисунка (см. рис. 3.14) составляет 768x576.

Рис. 4.17. Результат вставки клипа image.bmp в фильм

Как видно из рис. 4.17, то место, которое добавленный нами клип image.bmp (точнее, как принято в терминологии After Effects — слой image.bmp) будет занимать в фильме, отображается в окне Timeline (Монтаж) в виде прямоугольной пиктограммы, расположенной вдоль линейки времени. Левая граница прямоугольника (начало клипа), отмеченная характерным значком, находится на стартовом кадре композиции, т. е. кадре с номером 0:00:00:00 (рис. 4.18). Начало клипа (или слоя) в программах Adobe Premiere и After Effects принято также называть их входной точкой, или просто входом (in-point), а конец слоя — его выходной точкой, или выходом (out-point). Начало и конец слоя визуализируются при помощи входных и выходных маркеров, соответственно, у левой и правой границ прямоугольника, представляющего в окне Timeline (Монтаж) слой.

Рис. 4.18. Начало и конец слоя в окне Timeline

Длительность статических клипов является условной (т. к. никаких изменений с ними с течением времени не происходит). При импорте статических клипов им назначается некоторая длительность, которую можно определить при помощи установок After Effects. По умолчанию слою image.bmp (см. рис. 4.13) была назначена длительность 30 с, как и продолжительность всей композиции. Соответственно, и образованный этим клипом одноименный слой в окне Timeline (Монтаж) имеет длительность 30 с, т. е. занимает все время композиции Chaplin.

Обратите внимание, что после добавления клипа в фильм его текущий кадр остался тем же самым, что и в окне Composition (Композиция) этот кадр является уже не пустым (черным), а заполнен изображением слоя image.bmp. Просматривая другие кадры композиции, вы можете убедиться в том, что вся она пока состоит из статического изображения, начинающегося с нулевой секунды и длящегося 30 с, т. е. до самого конца композиции.

Теперь таким же образом вставим в композицию видеоклип movie.avi:

1. Выберите желаемый текущий кадр композиции Chaplin, на который вы хотите вставить клип, т. е. кадр 0:00:03:00.

2. Перетащите указателем мыши клип movie.avi из окна Project (Проект) на окно Timeline (Монтаж) под слой image.bmp. Перед тем как отпустить кнопку мыши, обратите внимание, что в окне Timeline (Монтаж) в процессе вставки в него клипа схематически отображается будущее место создаваемого слоя. Если вы (при нажатой кнопке мыши) наводите указатель на графическую область окна под шкалой времени, то в процессе перетаскивания клипа можете наблюдать, как смещается его предполагаемое место влево и вправо относительно шкалы. Отображение предполагаемого места слоя сопровождается синхронной индикацией номера кадра композиции, на который будет осуществлена вставка начала клипа (рис. 4.19). Таким образом, уже в процессе вставки нового слоя в фильм можно визуально определить его место в данном фильме. Если переместить указатель из графической области окна Timeline (Монтаж) в левую область списка слоев, то индикатор текущего кадра покажет значение 0:00:03:00, т. е. тот самый номер кадра, который был установлен до перетаскивания.

Рис. 4.19. В процессе вставки слоя в композицию в окне Timeline отображается предполагаемое место создаваемого слоя

В результате в окне Timeline (Монтаж) появится второй слой, на котором будет расположен видеоклип movie.avi (рис. 4.20). Таким образом, опытные пользователи After Effects могут сэкономить время монтажа, перетаскивая клипы из окна Project (Проект) сразу на нужное место фильма в окне Timeline (Монтаж), ориентируясь на шкалу времени и таймкод кадра.

Рис. 4.20. Результат вставки в фильм видеоклипа movie.avi


4.3.3. О просмотре композиций

В завершение урока скажем еще несколько слов о способах просмотра композиций при их редактировании в After Effects. Во-первых, как мы уже говорили, в любой момент в окне Composition (Композиция) отображается текущий кадр фильма, выделенный линией редактирования. Щелкая в разных местах шкалы времени, можно просматривать кадры композиции по одному (в статическом режиме). Во-вторых, имеется возможность просматривать композицию в динамике, т. е. подобно тому, как вы просматриваете видео в обычной программе-проигрывателе.

Статический просмотр относительно временной шкалы, который мы использовали до сих пор, осуществляется постоянно. Для правильного отображения текущего кадра композиции After Effects необходимо осуществить его рендеринг, т. е. обработку изображения в соответствии с монтажом, выполненным пользователем. Если установлена соответствующая опция, кадры композиции, рендеринг которых завершен, отмечаются цветными штрихами на шкале времени.

Чтобы эффективно использовать окно Timeline (Монтаж), необходимо хорошо представлять себе назначение его основных элементов на линейке времени. Помимо основной области линейки (шкалы времени), с которой мы работали до сих пор, над ней имеется более узкая область, являющаяся индикатором полной длительности композиции. Если в основной области шкала отображается в масштабе, выбранном пользователем (т. е. показывается некоторый фрагмент композиции), то на верхней области та же самая информация отображается относительно полной длительности композиции.

Таким образом, при самом мелком масштабе, когда в окно Timeline (Монтаж) загружена композиция целиком, показания обоих шкал совпадают (рис. 4.21). Когда выделен лишь некоторый временной фрагмент композиции, верхний индикатор полной длительности композиции показывает, где именно в ней находится отображаемая в данный момент область (рис. 4.22). Выделенная на обеих шкалах серая зона (на каждой шкале в своем масштабе) называется рабочей областью (work area) композиции, и именно она обрабатывается в ходе рендеринга и экспорта композиции.

Рис. 4.21. Индикатор полной длительности композиции дублирует основную шкалу времени, если развернуто все содержимое окна Timeline

Рис. 4.22. Индикатор полной длительности отображает место выделенного шкалой времени фрагмента относительно общей длительности композиции

Для динамического просмотра композиций имеется специальная палитра, называемая палитрой Time Controls (Управление воспроизведением). Вызвать ее можно выбором одноименного пункта меню Window (Окно). Палитра имеет стандартный набор элементов управления процессом воспроизведения видеофильмов. Перечислим верхний ряд кнопок (рис. 4.23):

Рис. 4.23. Палитра Time Controls используется для управления процессом воспроизведения композиций

  • First Frame (Первый кадр) — перемещает линию редактирования на первый кадр композиции;
  • Previous Frame Back (Кадр назад) — перемещает на один кадр назад;
  • Play / Pause (Проиграть / Приостановить) — равномерно проигрывает клип от текущего кадра, при повторном нажатии во время воспроизведения приостанавливает его на последнем демонстрировавшемся кадре;
  • Next Frame (Кадр вперед) — перемещает на один кадр вперед;
  • Last Frame (Последний кадр) — перемешает линию редактирования на первый кадр композиции;
  • Audio (Звук) — включает/выключает звук;
  • Loop (Цикл) — меняет режим воспроизведения (циклический или от начала до конца);
  • RAM Preview (Предварительный просмотр) — сначала осуществляет рендеринг, а затем проигрывает рабочую область композиции.

При помощи остальных элементов управления можно просматривать фрагменты композиции (при помощи ползункового регулятора и полосы протяжки в середине палитры), а также менять дополнительные параметры просмотра (частоту кадров и разрешение). В процессе воспроизведения фильма (если только не выбран просмотр RAM Preview) After Effects пытается произвести расчет всех кадров композиции в режиме реального времени (рис. 4.24).

Рис. 4.24. After Effects пытается рассчитывать и воспроизводить кадры композиции в режиме реального времени

Если быстродействия компьютера для этого не хватает, то фильм демонстрируется в замедленном варианте (так быстро, насколько возможно). При этом в палитре Time Controls (Управление воспроизведением) отображается соответствующая информация (рис. 4.25).

Рис. 4.25. Когда рендеринг фильма в режиме реального времени невозможен, он воспроизводится в замедленном варианте


4.4. Резюме

Создание новых композиций может производиться на основе установок пользователя, стандартных наборов предустановок, предусмотренных разработчиками After Effects, а также путем дублирования установок некоторого исходного клипа. Добавление слоев в композиции осуществляется перетаскиванием соответствующих клипов из окна Project (Проект) в окно Timeline (Монтаж).


Урок 5. Слои в окне Timeline

  • На этом уроке...
  • 5.1. Расположение слоев в окне Timeline
    • 5.1.1. Вставка и порядок расположения слоев в композиции
    • 5.1.2. Удаление слоев из композиции
  • 5.2. Подгонка длительности слоев
  • 5.3. Управление слоями в окне Timeline
    • 5.3.1. Столбец Source Name/Layer Name
    • 5.3.2. Панель инструментов окна Timeline
  • 5.4. Резюме


На этом уроке...

На этом уроке мы подробно поговорим о том, какие манипуляции со слоями можно совершать в окне Timeline (Монтаж), а также более детально разберемся со строением его окон и назначении имеющихся в них элементов управления.

  • Чего мы хотим:

  • завершить монтаж композиции (см. урок 4);
  • научиться редактировать длительность и положение слоев композиции;
  • освоить средства окна Timeline (Монтаж).

  • Нам потребуется:

  • проект, который монтировался на двух предыдущих уроках, включающий три медиа-файла: видео, звуковой и графический (см. урок 3).

  • Что полезно вспомнить:

  • как осуществляется вставка клипов в композиции и какие существуют простейшие действия над слоями в окне Timeline (Монтаж) (см. урок 4).


5.1. Расположение слоев в окне Timeline

Окно Timeline (Монтаж) является основным при настройке основных свойств слоев, их взаимного расположения, назначении анимации и эффектов и т. п.


5.1.1. Вставка и порядок расположения слоев в композиции

Прежде чем проанализировать взаимное расположение слоев и их роль в формировании кадра композиции, добавим в нее звуковой клип music.wav. Сделаем это несколько иначе, нежели на предыдущем уроке, чтобы показать, что вставка клипа в композицию может осуществляться не только путем перетаскивания его в окно Timeline (Монтаж), но и при помощи окна Composition (Композиция).

1. Выберите желаемый текущий кадр композиции Chaplin, на который вы хотите вставить клип, т. е. кадр 0:00:02:00.

2. Откройте окно Composition (Композиция) с этим кадром композиции Chaplin.

3. Перейдите в окно Project (Проект) и перетащите из него указателем мыши клип music.wav на окно Composition (Композиция) (рис. 5.1).

Рис. 5.1. Вставка клипа music.wav в фильм при помощи его перетаскивания в окно Composition

В результате клип будет вставлен в композицию в виде звукового слоя (рис. 5.2). Обратите внимание, что при таком способе новый слой займет самое верхнее место и будет располагаться над остальными слоями.

Примечание

Вставить клип в композицию можно еще и третьим способом, перетаскивая его на название нужной композиции в окне Project (Проект) (рис. 5.3).

Как видно из рис. 5.2, теперь мы имеем в нашей композиции Chaplin три слоя, располагающиеся друг над другом. Если место звукового слоя music.wav роли не играет, то порядок взаимного расположения слоев с изображением имеет ключевое значение. Поскольку слой image.bmp расположен в списке слоев окна Timeline (Монтаж) над слоем movie.avi, то и при формировании кадра его изображение будет полностью перекрывать изображение нижнего слоя.

Рис. 5.2. Результат вставки в фильм слоя music.wav

Рис. 5.3. Вставить клип в фильм можно и путем его перетаскивания на название нужной композиции в окне Project

Просмотрите по очереди несколько кадров композиции и убедитесь в том, что слой, расположенный выше, полностью скрывает изображение нижних слоев (см. рис. 5.2, 5.4).

Рис. 5.4. Кадры верхнего слоя заслоняют кадры нижнего

Конечно, в окне Timeline (Монтаж) можно с легкостью изменять порядок расположения слоев композиции. Разберемся в этом на простом примере, "перетасовывая" слои фильма Chaplin и обращая внимание на происходящие изменения в окнах Timeline (Монтаж) и Composition (Композиция). Для того чтобы перенести слой в окне Timeline (Монтаж) по вертикали, следует просто перетащить его со старой позиции на новую. Изменим, к примеру, порядок следования слоев в композиции Chaplin на обратный: звуковой слой music.wav отнесем на самое последнее место, позади остальных слоев, а верхним сделаем слой с видео, т. е. movie.avi.

1. Схватитесь за название слоя music.wav в окне Timeline (Монтаж) и перетащите его ниже, под другие слои. По мере перетаскивания предполагаемое положение слоя будет показываться жирной горизонтальной линией (рис. 5.5). Отпустите кнопку мыши — слой music.wav окажется самым нижним в композиции.

Рис. 5.5. Чтобы изменить порядок наложения слоев, перетащите один из них по вертикали в окне Timeline

2. Таким же образом (рис. 5.6) переместите слой с рисунком image.bmp на одну позицию вниз, под слой movie.avi. В результате слой movie.avi окажется над слоем image.bmp и поэтому будет полностью заслонять его изображение в зоне перекрывания этих слоев, т. е. начиная с третьей секунды фильма (рис. 5.7).

Рис. 5.6. В процессе перетаскивания слоя по вертикали его новое положение отмечается жирной горизонтальной линией

Рис. 5.7. В результате изменения порядка наложения слой movie.avi заслоняет слой image.bmp

3. Переместите линию редактирования в окне Timeline (Монтаж) на какой-нибудь кадр первых трех секунд композиции и убедитесь в том, что в ее начале (до входной точки верхнего слоя movie.avi) кадр композиции формирует рисунок со слоя image.bmp (рис. 5.8).

Рис. 5.8. До входной точки верхнего слоя movie.avi кадр композиции формируется из изображения следующего слоя image.bmp

4. Просмотрите еще несколько кадров композиции, чтобы убедиться, что вся она смонтирована в полном соответствии со сценарием. Сначала на протяжении 3 с демонстрируется статическая заставка (см. рис. 5.8), а затем до конца композиции идет воспроизведение видео (рис. 5.7), поскольку слой с видео находится над слоем image.bmp. Музыкальное сопровождение начинается со 2-й секунды фильма.

Примечание

Мы провели монтаж фильма, пользуясь исключительно техникой наложений, т. е. располагали начала слоев в нужных местах композиции так, чтобы они должным образом заслоняли нижние слои. Можно действовать и по-другому, определяя точно начало и конец каждого слоя в фильме. С этими операциями, которые обобщенно называются подгонкой слоев, мы познакомимся на уроке 6.

Заметим, что определить место создаваемого слоя в окне Timeline (Монтаж) в иерархии остальных слоев можно непосредственно в процессе его вставки в композицию. К примеру, создадим еще один слой на основе клипа image.bmp, причем расположим его, еще на стадии вставки, из окна на самой верхней позиции, над остальными слоями.

1. Схватитесь указателем мыши за клип image.bmp в окне Project (Проект) и перетащите его на окно Timeline (Монтаж), ориентируясь на отображаемое в процессе перетаскивания положение нового слоя по вертикали.

2. Отпустите кнопку мыши, когда черная линия, указывающая предполагаемую позицию нового слоя, окажется над остальными слоями (рис. 5.9).

Рис. 5.9. Для того чтобы определить место создаваемого слоя при его вставке в композицию, перетащите его на желаемый уровень (среди существующих слоев) в окне Timeline

В результате в окне Timeline (Монтаж) новый слой будет самым верхним, и в окне Composition (Композиция) мы увидим кадр этого слоя (рис. 5.10).

Рис. 5.10. В результате определения места нового слоя image.bmp на стадии добавления в композицию он оказывается самым верхним


5.1.2. Удаление слоев из композиции

Если вы уверены, что какой-либо из слоев композиции вам больше не понадобится, то его можно легко удалить. Продемонстрируем это на примере дубликата слоя image.bmp, который мы добавили последним, и который является верхним слоем композиции. Щелкните в окне Timeline (Монтаж) на слое, который вы хотите удалить, например, самом верхнем слое image.bmp композиции Chaplin. Щелчок можно осуществлять на любом месте этого слоя — в графической области или столбце с его именем. В результате слой приобретет выделение.

Нажмите клавишу <BackSpace> на клавиатуре.

После этого слой image.bmp пропадет из окна Timeline (Монтаж) (рис. 5.11), однако сам клип image.bmp останется в проекте, и, при желании, его можно будет использовать повторно, добавляя его снова в композицию.

Рис. 5.11. Чтобы удалить выделенный слой из композиции, нажмите клавишу <BackSpace>

Если вы хотите не только удалить слой из композиции, но и вовсе исключить соответствующий исходный файл из проекта, то следует обратиться к окну Project (Проект). Достаточно выделить клип, который вы хотите удалить в списке клипов окна Project (Проект), и нажать кнопку Delete на панели инструментов этого окна (рис. 5.12).

Рис. 5.12. Чтобы удалить клип из проекта, нажмите кнопку Delete на панели инструментов окна Project

При необходимости надо также подтвердить намерение удалить клип из композиций, в которых он до этого использовался, в дополнительном диалоговом окне (рис. 5.13).

Рис. 5.13. Подтверждение удаления клипа из проекта


5.2. Подгонка длительности слоев

Несмотря на то, что мы полностью выполнили сценарий, который планировали, проведем еще некоторые действия по монтажу фильма, которые помогут нам разобраться с тем, как можно располагать слои по времени в окне Timeline (Монтаж). Уже в процессе вставки слоев мы расположили их входные точки в нужном порядке. Заметим, однако, что длительность слоя image.bmp пока совпадает с длительностью всей композиции, а тот факт, что он формирует кадр композиции только в ее начале, объясняется наложением на него верхнего видеослоя movie.avi. Это не самый лучший стиль монтажа, т. к. впоследствии (для решения каких-то новых задач) вам может потребоваться настроить прозрачность видеослоя, что вызовет прохождение через него изображения заставки. Для того чтобы монтаж композиции стал более надежным, желательно, чтобы слой image.bmp заканчивался на том же кадре, с которого начинается видеослой movie.avi, т. е. с кадра 0:00:03:00.

Как вы уже догадались, начало (вход) и конец (выход) любого слоя отображаются в графической области окна Timeline (Монтаж) характерными пиктограммами, ограничивающими левый и правый края прямоугольника (представляющего этот слой). Например, ранее, на рис. 5.2 или 5.11, вы видели входные точки (или маркеры) всех трех слоев, расположенные на различных кадрах композиции в соответствии со сценарием; на рис. 5.4 можно заметить конец (выходную точку) только одного слоя image.bmp. Остальные слои имеют длительность большую, нежели длительность всей композиции (т. к. исходные клипы для этих слоев более продолжительные), поэтому их выходы остаются как бы справа за пределами линейки времени окна Timeline (Монтаж).

Редактирование места расположения слоев вдоль линейки времени, или, говоря иначе, подгонка слоев в окне Timeline (Монтаж), может производиться тремя основными способами:

  • местоположение слоя вдоль линейки времени может быть изменено путем перетаскивания указателем мыши влево или вправо по графической области окна Timeline (Монтаж). Хвататься указателем мыши следует за центральную часть прямоугольника, символизирующего слой. При этом длительность слоя остается неизменной, а сам он сдвигается ближе к началу или концу композиции соответственно;
  • начало клипа может быть смещено влево или вправо вдоль линейки времени путем перетаскивания входной точки слоя. При этом длительность слоя соответственно увеличивается или уменьшается, а первый кадр этого слоя также изменяется;
  • аналогично, конец клипа, т. е. его выход, можно перетаскивать влево или вправо вдоль линейки времени. При этом сдвигается также последний кадр этого слоя, а его длительность, соответственно, уменьшается или увеличивается.

Итак, нам требуется уменьшить длительность слоя image.bmp, установив его выходную точку в позицию 0:00:03:00.

1. Перейдите к завершающей части фильма в окне Timeline (Монтаж), чтобы был виден конец слоя image.bmp. При необходимости используйте полосу прокрутки окна Timeline (Монтаж) или индикатор полной длительности композиции.

2. Схватитесь за выходную точку слоя image.bmp и начните перетаскивать ее влево. По мере перетаскивания в окне Timeline (Монтаж) вы будете наблюдать предполагаемое новое место слоя image.bmp, которое выделяется, а также сопровождается выводом таймкода соответствующего кадра (рис. 5.14).

Рис. 5.14. Для начала подгонки слоя image.bmp схватитесь за его входной или выходной маркер

3. Не отпуская кнопки мыши и ориентируясь на показания строки с тайм-кодом в окне Timeline (Монтаж), наведите указатель на кадр 0:00:03:00.

4. Отпустите кнопку мыши — длительность слоя уменьшится, и его конец окажется в начале 3-й секунды композиции (рис. 5.15).

5. Просмотрите несколько кадров композиции, чтобы убедиться, что теперь она смонтирована в полном соответствии со сценарием. Сначала на протяжении 3 с демонстрируется статическая заставка (рис. 5.15), а затем до конца композиции идет воспроизведение видео. Музыкальное сопровождение начинается со 2-й секунды фильма.

Рис. 5.15. Перетащите маркер конца слоя на новое место


5.3. Управление слоями в окне Timeline

Монтаж композиций в окне Timeline (Монтаж) связан, главным образом, с настройкой взаимного расположения слоев (т. е. их порядка по вертикали и подгонкой слоев вдоль шкалы времени), а также с назначением слоям определенных атрибутов и параметров. Для настройки параметров слоев, с одной стороны, и для удобства их редактирования, с другой, окно Timeline (Монтаж) имеет целый арсенал элементов управления (рис. 5.16). Перечислим их, сопроводив краткими пояснениями.

Рис. 5.16. Элементы управления окна Timeline (Монтаж)


5.3.1. Столбец Source Name / Layer Name

Столбец с названиями слоев Layer Name (Название слоя) или исходных клипов, т. е. источников Source Name (Название клипа) содержит (для каждого слоя):

  • треугольную кнопку раскрытия вложенного списка свойств слоя (таких, как маски, назначенные эффекты и т. д.);
  • метку с цветом, назначенным данному слою (цвет можно поменять, выбирая его из контекстного меню, вызываемого на данной метке);
  • номер слоя (присвоенный ему программой (After Effects);
  • название слоя (layer name) или название клипа (source name) в зависимости от желания пользователя.

Выполните следующие операции:

1. Щелкните на заголовке столбца Source Name / Layer Name и вы увидите, что его название поменялось, а вместо перечня названий слоев (если до этого столбец назывался Layer Name) он содержит теперь имена исходных клипов.

2. Щелкните еще раз на заголовке столбца — он вновь вернется в первоначальное состояние.

3. Щелкните на треугольной кнопке управления вложенного списка свойств для какого-либо из слоев, что приведет к его раскрытию. Возможно, раскрывшаяся часть списка (в зависимости от того, какие эффекты назначены слою) содержит дополнительные группы свойств, снабженные такими же стрелками раскрытия вложенного выпадающего списка.

4. Скройте раскрытый список повторным нажатием треугольной кнопки (которая, как вы видите, изменяет свое направление в зависимости от состояния списка). Таким образом, вы, с одной стороны, сразу осознаете иерархическую структуру эффектов, назначенных данному слою, а, во-вторых, экономите экранное пространство, поскольку имеете возможность гибко управлять раскрытием и скрытием областей вложенных списков.


5.3.2. Панель инструментов окна Timeline

Перечислим кнопки, которые находятся на панели инструментов (Timeline window buttons) в верхней части окна Timeline (Монтаж), позволяют управлять включением и выключением различных режимов редактирования слоев и опций их вставки в композиции (рис. 5.16):

  • выключатель динамического предварительного просмотра (Disable Dynamic Preview);
  • черновой режим 3D-эффектов (Draft 3D);
  • выключатель отображения скрытых слоев (Shy Layers), который позволяет скрыть с экрана те слои, которые были скрыты с кадра композиции при помощи их собственных переключателей;
  • выключатель режима плавного перехода кадров (Frame Blending), т. е. специального алгоритма, улучшающего качество анимации при помощи сглаживания;
  • выключатель эффекта размытия при движении (Motion Blur), т. е. обратного эффекта, размывающего контуры объектов, которым назначена анимация, что делает ее восприятие более реалистичной и похожей на просмотр стандартного кинофильма.

Панель инструментов содержит пять кнопок, управляющих всеми слоями сразу. В столбце Switches/Modes (Переключатели/Режимы), находящемся под ней, можно задать те же самые параметры для каждого индивидуального слоя в отдельности (рис. 5.17). Перечислим эти режимы (слева направо):

Рис. 5.17. Переключатели отдельных слоев в окне Timeline

  • переключатель скрытия данного слоя;
  • переключатель отображения преобразований для слоев, представляющих собой вложенные композиции;
  • качество отображения содержимого слоя (можно задать черновое);
  • выключатель режима плавного перехода для данного слоя;
  • выключатель эффекта размытия при движении (Motion Blur) для данного слоя;
  • выключатель эффектов, примененных к слою;
  • переключатель регулировочного слоя (если он включен, то данный слой является регулировочным, т. е. автоматически определяет примененные к нему эффекты для всех слоев, расположенных ниже него);
  • переключатель трехмерности слоя (если он выставлен, слой воспринимается программой After Effects в качестве трехмерного).

Выключатели слоя (Аудио / Видео / Соло / Запирание)

Панель с выключателями, позволяющими временно скрыть слой из композиции, либо, напротив, включить его. Если возле слоя имеется пиктограмма в виде глаза (и/или акустического динамика), то видео (и/или звук), составляющие слой, включаются в состав композиции. Если снять данные переключатели для каких-либо слоев, то это их временно изымет из фильма, что очень удобно при монтаже сложных композиций, а также важно для правки определенных слоев (чтобы остальные слои не мешали монтажу в окне Composition).

Рис. 5.18. Выключатели слоев в окне Timeline: Аудио / Видео / Соло / Запирание

Пиктограмма в виде окружности Solo (Соло) позволяет временно выключить все слои, кроме тех, для которых установлен данный атрибут. Самая правая из пиктограмм с изображением замка временно (до ее последующего снятия) запрещает любое редактирование данного слоя.

В верхней части окна Timeline (Монтаж), над рассмотренной группой переключателей, находится строка с таймкодом текущего кадра (current time), которая представляет его номер в соответствии с выбранной системой (см. урок 1). В скобках отображается текущая частота кадров. При щелчке на номере кадра выводится диалоговое окно, при помощи которого можно численно задать его новое значение, т. е. перейти к желаемому кадру композиции, введя его вручную с клавиатуры.

Вспомогательные столбцы

При помощи команды Columns (Столбцы) меню окна Timeline (Монтаж) можно вызвать на экран или, наоборот, скрыть, столбцы со вспомогательной информацией (рис. 5.19). Многие из них будут разобраны ниже, когда мы обратимся к изучению конкретных задач монтажа в After Effects.

Рис. 5.19. Скрыть или вызвать вспомогательные столбцы можно при помощи меню окна Timeline

Перечислим столбцы, которые могут присутствовать в окне Timeline (Монтаж):

  • Comment (Комментарии) — включает текстовые комментарии пользователя к слоям;
  • Modes (Режимы) — показывает переключатели различных режимов слоев: смешения (при настройке прозрачности слоев), маски и т. п. (см. урок 9);
  • Switches (Переключатели) — перечисляет значения параметров слоя на ключевых кадрах в виде активных надписей, что позволяет регулировать эти параметры;
  • Parent (Родительский) — показывает, какой слой, если таковой назначен, является родительским по отношению к данному (все настройки, кроме прозрачности, примененные к родительскому слою, автоматически применяются к данному, т. е. дочернему, слою);
  • Keys (Прозрачные наложения) — состоит из навигатора ключевых кадров анимации (см. урок 10);
  • In (Вход) — состоит из перечня значений начальных кадров слоев (т. е. их входных маркеров);
  • Out (Выход) — включает значения номеров конечных кадров слоев (т. е. их выходных маркеров);
  • Duration (Длительность) — представляет длительности слоев;
  • Stretch (Растяжение) — включает значения растяжений слоев во временном масштабе.


5.4. Резюме

На этом уроке мы познакомились с приемами редактирования в After Effects слоев, а также научились базовым принципам линейного монтажа, в том числе расположению слоев в желаемом порядке друг над другом и один за другим, относительно шкалы времени в окне Timeline (Монтаж).


Урок 6. Слои в окне Composition

  • На этом уроке...
  • 6.1. Слои в окнах Composition и Layer
    • 6.1.1. Инструментарий
    • 6.1.2. Окна Composition и Layer
    • 6.1.3. Копирование, вставка и дублирование слоя
    • 6.1.4. Разбиение слоя
  • 6.2. Размещение, масштабирование и повороты слоя
    • 6.2.1. Перемещение слоев по кадру композиции
    • 6.2.2. Масштабирование слоев
    • 6.2.3. Поворот слоя
    • 6.2.4. Управление привязкой
    • 6.2.5. Отражение слоев
    • 6.2.6. Выравнивание и расположение слоев
    • 6.2.7. Параметры слоев в окне Timeline
  • 6.3. Трехмерные (3D) слои
  • 6.4. Резюме


На этом уроке...

На этом уроке мы обратимся к действиям со слоями, которые можно совершать в окне Composition (Композиция), и познакомимся с наиболее часто используемыми инструментами палитры Tools (Инструментарий), которые применяются при редактировании слоев в этом окне.

  • Чего мы хотим:

  • научиться редактировать слои в окне Composition (Композиция), освоить операции размещения, масштабирования и поворота слоев.

  • Нам потребуется:

  • любые два видео- (или просто графических) файла для тренировки навыков редактирования слоев в окне Composition (Композиция).

  • Что полезно вспомнить:

  • как осуществляется Timeline (Монтаж) (см. уроки 4, 5).


6.1. Слои в окнах Composition и Layer

На прошлом уроке мы имели дело с приемами редактирования слоев в окне Timeline (Монтаж) и разобрались в том, что действия над слоями в этом окне связаны, главным образом, с просмотром и регулировкой различных (чаще всего, числовых) атрибутов слоев.


6.1.1. Инструментарий

Многие действия над слоями могут быть выполнены с одинаковым успехом в окне Timeline (Монтаж), либо в окне Composition (Композиция). Операции в окнах Composition (Композиция) и Layer (Слой) связаны, в основном, с визуальным методом редактирования, т. е. вы работаете непосредственно на изображении слоя (рисуете, настраиваете прозрачность, поворачиваете или двигаете слой и т. п.). Для осуществления любых действий над слоем в окне Composition (Композиция) служит палитра Tools (Инструментарий) (рис. 6.1).

Рис. 6.1. Палитра Tools

Палитра Tools (Инструментарий) включает в себя следующие кнопки выбора инструментов:

  • Selection (Выбор) — для выделения, перемещения и масштабирования слоев;
  • Rotation (Вращение) — для поворотов слоев;
  • Camera (Камера) — для управления спецэффектом камеры;
  • Hand (Рука) — для перемещения видимого поля вдоль кадра в окне Composition (Композиция);
  • Zoom (Масштаб) — для выбора масштаба отображения кадра;
  • Pan Behind (Панорама) — для управления местоположением точки привязки относительно слоя;
  • Brush (Кисть) — для рисования графических примитивов на слоях;
  • Clone Stamp (Клонирование) — для создания масок специального вида;
  • Eraser (Ластик) — для редактирования масок;
  • Rectangular Mask (Прямоугольная маска), Elliptical Mask (Эллиптическая маска) — для создания масок;
  • Text (Текст) — для создания текстовых титров;
  • Реn (Перо) — для рисования масок сложной формы.

Примечание

Перечисленные инструменты называются в оригинале Selection Tool, Hand Tool, Text Tool и т. д. Здесь и далее мы опускаем слово Tool (Инструмент), чтобы не загромождать текст книги.

Не все инструменты, предусмотренные в After Effects, присутствуют одновременно в палитре Tools (Инструментарий). Некоторые из них скрыты за имеющимися кнопками. Как правило, несколько инструментов со сходным назначением размещаются в одной кнопке палитры Tools (Инструментарий), и для их вызова на экран необходимо нажать и удерживать соответствующую кнопку, а затем в появившемся подменю выбрать желаемый инструмент (рис. 6.2). Кнопки тех инструментов, которые имеют скрытую группу, снабжены характерными стрелочками в правом нижнем углу.

Более подробно о назначении каждого из инструментов мы расскажем на соответствующих уроках нашей книги.

Рис. 6.2. Выбор скрытого инструмента в палитре Tools


6.1.2. Окна Composition и Layer

Как мы уже говорили, изображения кадров слоев можно просматривать и редактировать в двух окнах, имеющих сходное строение:

  • окно Composition (Композиция) — показывает скомпилированный текущий кадр всей композиции, включающий изображение всех слоев (рис. 6.3);

Рис. 6.3. Окно Composition показывает текущий кадр композиции

  • окно Layer (Слой) — показывает только один из слоев (рис. 6.4).

Рис. 6.4. Окна Layer показывают кадры только одного из слоев композиции

Большинство действий над слоем можно выполнить как в одном, так и в другом окне. Однако некоторые операции проводятся либо только в окне Layer (Слой) (например, рисование линий на слоях), либо в окне Composition (Композиция) (масштабирование, повороты слоев и т. п., требующие регулировки взаимного положения слоя относительно кадра всей композиции).

В окнах Composition (Композиция) и Layer (Слой) можно задать некоторые вспомогательные опции отображения кадра. В частности, можно вызвать на экран границы безопасного размещения кадра и границы безопасного размещения титров. Это бывает важно из-за того, что некоторые типы аппаратуры воспроизведения видео несколько "обрезают" кадр со всех сторон, поэтому часть изображения может не попасть в окончательный фильм. Для включения отображения безопасных границ (safe margins) достаточно нажать соответствующую кнопку в нижней части окна (рис. 6.5).

Рис. 6.5. Безопасные зоны размещения изображения кадра и титров


6.1.3. Копирование, вставка и дублирование слоя

Со слоями в Adobe After Effects можно производить стандартные операции, находящиеся в пункте верхнего меню Edit (Правка) и принятые в большинстве компьютерных программ.

  • Сору (Копировать) — копирует выделенный слой в буфер обмена;
  • Paste (Вставить) — вставляет скопированный или вырезанный ранее слой из буфера обмена в позицию линии редактирования;
  • Cut (Вырезать) — удаляет выделенный слой, помещая его при этом в буфер обмена;
  • Duplicate (Дублировать) — создает дубликат выделенного слоя в окне Timeline (Монтаж);
  • Clear (Удалить) — удаляет выделенный слой.

Для осуществления перечисленных операций достаточно сначала выделить слой, а затем ввести желаемую команду. На рис. 6.6 и 6.7 показан пример создания дубликата слоя (на рис. 6.7 созданный дубликат немного сдвинут в сторону, чтобы его было лучше видно).

Рис. 6.6. Дублирование слоя при помощи верхнего меню

Примечание

Перечисленные операции правки стандартны и могут применяться в After Effects не только к слоям, но и другим объектам. Требуется лишь предварительно выделить нужный объект.

Рис. 6.7. В результате дублирования в композицию добавляется новый слой с изображением и настройками исходного слоя


6.1.4. Разбиение слоя

Иногда в процессе монтажа композиций возникает задача разбиения одного слоя на несколько слоев с теми же параметрами. Для разбиения слоя следует воспользоваться соответствующей командой меню Edit (Правка).

1. Выделите тот слой, который вы хотите разбить.

2. Поместите линию редактирования на тот кадр, который будет разделять слои, образованные при разбиении (рис. 6.6).

3. Выберите в верхнем меню Edit>Split Layer (Правка>Разбить слой).

В результате (рис. 6.8) исходный слой будет разбит на два независимых слоя, разделенных линией редактирования.

Рис. 6.8. В результате разбиения образуются два слоя, разделенных линией редактирования


6.2. Размещение, масштабирование и повороты слоя

Перейдем теперь к базовым приемам монтажа слоев в окне Composition (Композиция). На примере редактирования взаимного расположения двух слоев разного размера рассмотрим, как осуществляются перемещение, масштабирование и повороты их изображений на кадре фильма в окне Composition (Композиция). Рассмотрим проект, содержащий два видеофайла с разными размерами кадра (рис. 6.9).

Рис. 6.9. Слой Big Sky.tif имеет тот же размер кадра, что и композиция

Поочередно поместите два слоя (с разными размерами кадра) в композицию (рис. 6.9, 6.10). Обратите внимание, что по умолчанию слои выравниваются по центру композиции, выдерживая соотношение размеров кадра.

Примечание

Если бы размер кадра какого-либо слоя был больше размера кадра композиции, то в ее кадр поместилась бы лишь часть кадра слоя, а остальная часть осталась бы за его пределами.

Рис. 6.10. Размеры кадра слоя Frozen.mpg меньше кадра композиции


6.2.1. Перемещение слоев по кадру композиции

Рассмотрим теперь, как можно переместить изображения кадра какого-либо слоя относительно кадра композиции.

1. Сделайте активным инструмент Selection (Выбор).

2. Выделите желаемый слой. Если вы затрудняетесь сделать это в окне Composition (Композиция), то выделите его в окне Timeline (Монтаж). В результате очертания слоя в окне Composition (Композиция) будут выделены несколькими маркерами обрамления.

3. Схватившись за середину слоя в окне Composition (Композиция), перетащите его на новое место (рис. 6.11).

Рис. 6.11. Перемещение слоев по кадру композиции производится перетаскиванием при помощи инструмента Selection

Совсем необязательно, чтобы все изображение слоя размещалось в пределах кадра композиции, любые фрагменты вы можете оставить за его пределами. Однако помните, что After Effects включит в фильм только ту часть области редактирования окна Composition (Композиция), которая будет составлять его кадры.


6.2.2. Масштабирование слоев

Изображение любого слоя в окне Composition (Композиция) можно увеличить или уменьшить в размерах.

1. Выделите желаемый слой, щелкая на нем в окне Composition (Композиция) или Timeline (Монтаж).

2. Хватаясь инструментом Selection (Выбор) и перетаскивая в нужную сторону маркер обрамления слоя в окне Composition (Композиция), увеличьте или уменьшите его размер (рис. 6.12).

Рис. 6.12. Масштабирование слоев производится перетаскиванием маркеров обрамления при помощи инструмента Selection

Примечание 1

Для того чтобы пропорции слоя были при масштабировании сохранены, удерживайте при этом нажатой клавишу <Shift>. Если вы хотите изменять размер изображения слоя малыми шагами (для его точной регулировки держите нажатой при масштабировании слоя клавишу <Alt>).

Примечание 2

Следует иметь в виду, что, если вы растягиваете изображение слоя до размера, большего исходного клипа (если этот слой был импортирован из внешнего файла), окончательное качество композиции неминуемо ухудшится.


6.2.3. Поворот слоя

Повороты слоев осуществляются специально предназначенным для этого инструментом Rotation (Вращение) (рис. 6.13).

Рис. 6.13. Повороты слоев вокруг точки привязки осуществляются инструментом Rotation

1. Выделите слой.

2. Выберите инструмент Rotation (Вращение).

3. Перенесите указатель мыши на изображение слоя в окне Composition (Композиция) и, перетаскивая его инструментом Rotation (Вращение), поверните на желаемый угол.


6.2.4. Управление привязкой

Важно отметить, что поворот слоя производится вокруг некоторого центра вращения, задаваемого специальной точкой на кадре слоя, называемой точкой привязки (anchor point). По умолчанию при создании слоя точка привязки помещается в центр его изображения, но ее можно перенести в любую другую точку. Точка привязки обозначается на слое окружностью с крестом внутри. Она не влияет на внешний вид самого слоя, но играет определяющую роль как при вращении слоев, так и при некоторых других операциях (например, при отражении).

Для того чтобы изменить положение точки привязки относительно изображения слоя, следует воспользоваться инструментом Pan Behind (Панорама) (рис. 6.14).

Рис. 6.14. Инструмент Pan Behind служит для управления положением точки привязки

Для перемещения точки привязки выделенного слоя достаточно схватиться за нее этим инструментом и перетащить на новое место (рис. 6.15). На рис. 6.16 вы видите пример вращения слоя инструментом Rotation (Вращение) относительно нового положения точки привязки (сравните рис. 6.16 с рис. 6.13, на котором точка привязки была в центре изображения слоя).

Рис. 6.15. Перемещение точки привязки относительно слоя в окне Composition

Помните, что при последующем перемещении инструментом Selection (Выбор) изображения слоя по кадру композиции точка привязки будет смещаться вместе с ним, сохраняя положение относительно слоя неизменным.

Рис. 6.16. Пример поворота слоя вокруг точки привязки, находящейся в кадре композиции вне изображения


6.2.5. Отражение слоев

Помимо возможности изменить размер и ориентацию слоя в кадре композиции, его можно также отразить. Отражение настраивается тем же способом, что и масштабирование, при помощи инструмента Selection (Выбор). Для отражения слоя просто перетащите один из маркеров его выделения, который соответствует направлению отражения, за точку привязки этого слоя (рис. 6.17).

Рис. 6.17. Для отражения слоя перетащите любой маркер выделения за точку привязки

Отражение, как и повороты слоя, осуществляется относительно точки привязки. Если точка привязки находится за пределами слоя, то слой при отражении переместится с одного места на другое в кадре композиции (рис. 6.18).

Рис. 6.18. Пример отражения слоя, точка привязки которого находится за пределами слоя


6.2.6. Выравнивание и расположение слоев

Если в пределах кадра композиции находится изображение не одного, а нескольких слоев, то иногда возникает проблема их упорядочивания в определенном направлении. Для решения данной задачи в After Effects имеется специальное средство, называемое палитрой Align (Выравнивание).

Рис. 6.19. Перед тем как ввести команду выравнивания, выделите слои и вызовите на экран палитру Align

Чтобы симметрично расположить несколько слоев в кадре композиции:

1. Выделите желаемые слои. Напоминаем, что для выделения нескольких слоев удобно использовать клавишу <Shift>.

2. Вызовите на экран палитру при помощи команды меню Window>Align & Distribute (Окно>Выравнивание и расположение) (рис. 6.19).

3. Нажмите в палитре Align (Выравнивание) кнопку с пиктограммой, представляющей желаемый тип выравнивания (на рис. 6.20 приведен пример выравнивания по горизонтали, а на рис. 6.21 — по вертикали).

Рис. 6.20. Выравнивание нескольких слоев в кадре композиции производится при помощи палитры Align

Рис. 6.21. Пример выравнивания по вертикали


6.2.7. Параметры слоев в окне Timeline

Возможно, вы обратили внимание на то, что синхронно с изменениями, которые вы производите над слоями в окне Composition (Композиция), в соответствующих строках вложенных списков слоев окна Timeline (Монтаж) также происходят изменения. Это связано с тем, что, меняя положение или иные свойства слоев в окне Composition (Композиция), вы фактически меняете и параметры расположения слоев относительно кадра композиции, хранимые в окне Timeline (Монтаж). С другой стороны, меняя числовые значения этих параметров непосредственно в окне Timeline (Монтаж), можно также управлять слоем. Таким образом, окно Timeline (Монтаж) содержит исчерпывающую запись всех действий пользователя по редактированию в проекте активной композиции.

Рис. 6.22. Параметры слоев можно регулировать в окне Timeline

Для настройки того или иного параметра вам следует раскрыть соответствующий вложенный список Transform (Преобразование) в окне Timeline (Монтаж) и отрегулировать желаемым образом его числовое значение, ориентируясь при этом на изменения, которые происходят со слоем на кадре композиции в окне Composition (Композиция). Список значений параметров приведен в столбце Switches (Переключатели), который можно загрузить в окно Timeline (Монтаж) (если он временно скрыт) при помощи команды Columns (Столбцы) (рис. 6.22).


6.3. Трехмерные (3D) слои

Особым типом слоев в After Effects являются пространственные или трехмерные (3D) слои. Слои такого типа позволяют довольно реалистично имитировать эффект трехмерного изображения.

Рис. 6.23. Для назначения слою атрибута трехмерности установите в окне Timeline соответствующий переключатель режима

Трехмерный слой можно получить путем преобразования обычного двумерного (плоского) слоя, как бы продолжая его изображение за плоскость кадра, для чего используются специальные средства After Effects. Трехмерные слои получаются из обычных простым присвоением им признака трехмерности.

Для того чтобы определить любой слой композиции в качестве трехмерного слоя, в окне Timeline (Монтаж) выставите возле названия слоя переключатель режима трехмерности (рис. 6.23).

Примечание

Если снять в окне Timeline переключатель трехмерности слоя, то он вернется к обычному плоскому представлению, потеряв всю информацию о его протяженности вдоль оси Z.

После задания трехмерности слоя его можно редактировать как пространственный, т. е. уже не в двух (X, Y), а в трех измерениях (X, Y, Z), о чем говорит символическое представление системы координат, появляющееся в районе точки привязки. На рис. 6.23 она плохо различима, а вот если сделать фон композиции белым и вынести точку привязки за пределы слоя, то направление трех осей X, Y и Z будет хорошо заметно. При наведении указателя на каждую из осей появляется название оси, что говорит о возможности передвинуть (или повернуть) слой в том или ином направлении (рис. 6.24). Конечно, редактировать трехмерные слои приходится, ориентируясь на их обычное плоское представление, однако, набравшись опыта, вы без труда научитесь работать в трехмерном пространстве.

Рис. 6.24. При наведении инструмента Selection или Rotation на ось, возле него появляется название оси (коллаж)

Представление системы координат и стиль пространственной правки слоев могут быть различными. Текущее состояние можно поменять при помощи трех кнопок переключения трехмерного вида, расположенных у правой границы палитры Tools (Инструментарий) (рис. 6.25).

Рис. 6.25. Выбор режима трехмерного вида (коллаж)

Перечислим основные приемы редактирования трехмерных слоев, учитывая, что все операции проводятся теми же инструментами, что использовались для обычных слоев.

1. Выберите инструмент Selection (Выбор) и отрегулируйте им положение слоя, перетаскивая слой в пространстве. Также возможно перемещать слой в том или ином направлении оси, перетаскивая саму ось (рис. 6.26).

Рис. 6.26. Смещение слоя в нужном направлении производится перетаскиванием соответствующей оси инструментом Selection

2. Масштабируйте слой инструментом Selection (Выбор), перетаскивая маркеры его обрамления в нужном направлении (рис. 6.27).

Рис. 6.27. Масштабирование трехмерного слоя осуществляется при помощи перетаскивания маркеров обрамления инструментом Selection

3. Перед поворотом слоя выберите в палитре Tools (Инструментарий) инструмент Rotation (Вращение), а также определите опцию трехмерного поворота: Orientation (Ориентация) или Rotation (Вращение).

4. Наведите инструмент Rotation (Вращение) на нужную ось, либо на границу слоя и, при помощи техники перетаскивания, поверните слой в желаемую сторону (рис. 6.28).

Рис. 6.28. Для поворота трехмерного слоя в пространстве используется инструмент Rotation

5. Выберите Pan Behind (Панорама) и используйте его для изменения расположения точки привязки (рис. 6.29).

Рис. 6.29. Положение точки привязки в трехмерном пространстве регулируется при помощи инструмента Pan Behind

Примечание

Если при редактировании трехмерных слоев работа компьютера начинает существенно замедляться, то выключите на панели инструментов окна Timeline (Монтаж) режим динамического просмотра трехмерного редактирования. В этом случае операции, производимые в окне Composition (Композиция), будут символически представляться при помощи контуров (рис. 6.30).

Рис. 6.30. Если выключить режим динамического просмотра трехмерного редактирования в окне Timeline, то обновление кадра в окне Composition будет происходить быстрее

Важно заметить, что при работе с трехмерными слоями имеется возможность их просмотра с различных точек, расположенных в пространстве с разных сторон этого слоя. В частности, можно просматривать слой сверху, снизу, сбоку, либо посредством специального средства After Effects, называемого камерой (camera), которое позволяет имитировать просмотр слоя через фото- или видеокамеру с заданными характеристиками (фокусным расстоянием объектива и т. п.) с определенной точки в пространстве. Соответственно, направление, с которого слой просматривается в окне Composition (Композиция), будет использовано и при рендеринге композиции, и именно в таком виде войдет в окончательный фильм.

Для того чтобы изменить направление просмотра слоя:

1. Раскройте в окне Composition (Композиция) кнопку вызова меню 3D View (Трехмерный вид) (рис. 6.31).

2. Выберите в появившемся всплывающем меню желаемое направление просмотра слоя.

Рис. 6.31. Для выбора направления просмотра слоя используйте список 3D View


6.4. Резюме

Редактирование слоев в окне Composition (Композиция) осуществляется визуальным способом при помощи соответствующих инструментов. На этом уроке мы освоили следующие инструменты и операции, которые ими проводятся над обычными и трехмерными слоями:

  • Selection (Выбор) — выделение, перемещение и масштабирование слоев;
  • Rotation (Вращение) — повороты слоев;
  • Pan Behind (Панорама) — управление точкой привязки относительно слоя.


Урок 7. Работа с файлами

  • На этом уроке...
  • 7.1. Управление проектами
    • 7.1.1. Создание нового проекта
    • 7.1.2. Открытие проекта
    • 7.1.3. Отключенные файлы
    • 7.1.4. Сохранение проекта
    • 7.1.5. Закрытие проекта
  • 7.2. Экспорт композиций
    • 7.2.1. Форматы файлов
    • 7.2.2. Экспорт QuickTime
    • 7.2.3. Экспорт при помощи Render Queue
    • 7.2.4. Рендеринг фильмов Adobe Premiere


На этом уроке...

Рассмотрим на этом уроке, как в Adobe After Effects организовано управление файлами проектов. Сразу оговоримся, что практически все операции, описанные в этой главе, являются общепринятыми для приложений ОС Windows и Mac OS, и читатели, имеющие определенный опыт работы с другими программами, могут практически без потерь пропустить первый раздел данного урока, т. к. большинство сведений опытный пользователь может освоить интуитивно, по мере работы с After Effects. Вторая половина урока посвящена чрезвычайно важным вопросам рендеринга и экспорта фильмов, поэтому мы адресуем ее всем читателям.

  • Чего мы хотим:

  • научиться создавать новые проекты в After Effects, а также открывать, сохранять и закрывать существующие;
  • научиться экспортировать композиции во внешние файлы.

  • Нам потребуется:

  • файл с любым проектом, называющийся start.aep.


7.1.1. Создание нового проекта

Как мы уже говорили, проект в After Effects является, с одной стороны, удобной оболочкой, позволяющей пользователю легко ориентироваться в исходных клипах и создаваемых композициях, а с другой стороны — хранилищем информации обо всех файлах и изменениях, внесенных пользователем при редактировании фильма. Поэтому можно сразу сказать, какие файлы задействованы в проекте, и каковы их основные атрибуты.

Для того чтобы создать новый проект выберите в верхнем меню команду File>New>New Project (Файл>Создать>Проект).

В результате откроется окно Project (Проект) с пустым списком клипов. После этого вы можете приступать к редактированию нового проекта. Напомним, что, пока вы не сохраните его в первый раз под каким-либо именем, он условно называется Untitled Project.aep (см. рис. 3.1, 3.7).

Рис. 7.1. Для создания нового проекта выберите в верхнем меню File>New>New Project


7.1.2. Открытие проекта

Сохраненный ранее проект можно открыть двумя способами:

  • File>Open Recent Project (Файл>Открыть недавний проект) — открывает один из нескольких проектов, которые редактировались в последнее время. Имя нужного проекта следует выбрать из всплывающего подменю (рис. 7.2);
  • File>Open Project (Файл>Открыть проект) — открывает проект через стандартное для ОС Windows и Mac OS диалоговое окно Open File (Открытие файла), в котором следует найти и выделить в списке файл на диске компьютера и затем нажать кнопку ОК (рис. 7.3).

Рис. 7.2. Проекты, которые редактировались последними, можно открыть при помощи команды File>Open Recent Project

Рис. 7.3. Открытие файла с проектом start.aep

Совет

Первым способом пользоваться намного удобнее, если только вы не хотите открыть какой-либо старый проект.

Попробуем открыть созданный нами ранее (см. урок 3) проект start.aep. Для этого:

1. Выберите File>Open Project (Файл>Открыть проект).

2. В открывшемся диалоге перейдите к папке, содержащей файл start.aep, и выделите его в списке щелчком мыши (см. рис. 7.3).

3. Нажмите в диалоге кнопку ОК — проект загрузится в After Effects (рис. 7.4).

Рис. 7.4. Проект start.aep открыт для редактирования в After Effects

Закроем теперь данный проект, а затем вновь откроем его, пользуясь пунктом меню, позволяющим открыть недавно редактированные файлы.

1. Закройте текущий проект нажатием кнопки Close (Закрыть) окна Project (Проект).

2. Разверните выпадающее меню File (Файл).

3. Наведите в нем указатель мыши на пункт Open Recent Project (Открыть недавний проект).

4. В появившемся подменю щелкните на имени желаемого проекта, т. е. start.aep (см. рис. 7.2).

В результате проект start.aep вновь будет открыт в After Effects.

Примечание

Обратите внимание на количество и взаимное расположение окон, появляющихся в пределах главного окна After Effects при открытии проектов. Поэкспериментируйте с проектами, открывая и закрывая их, а также перетаскивая окна с места на место и изменяя их размер. Убедитесь в том, что программа After Effects "помнит" о большинстве из ваших установок, открывая проекты в том же самом виде, в котором они были ранее закрыты.


7.1.3. Отключенные файлы

Файлы с проектами After Effects не содержат никакой мультимедийной информации, а являются записью действий пользователя по редактированию видео и звука, хранящихся во внешних файлах соответствующих типов. Поэтому при открытии проектов After Effects важно помнить, что клипы, которые содержатся в проекте, — это всего лишь ссылки на медиа-файлы, находящиеся на вашем компьютере. Если ссылка в открываемом проекте на какой-либо медиа-файл указывает на неправильное место на диске (например, если файл был перемещен или удален), то нормального открытия проекта не произойдет. Вместо этого появляется информационное окно с предупреждением и сведениями о количестве отсутствующих файлов (рис. 7.5).

Рис. 7.5. Если при открытии проекта After Effects не может найти какой-либо файл, выводится окно с предупреждением и информацией о количестве отсутствующих файлов

Помните о том, что проекты After Effects — это не самодостаточные файлы, как например, текстовые документы или графические файлы. Если вы переносите файл с проектом в другое место на вашем диске, по локальной сети или на другой компьютер, позаботьтесь о том, чтобы все файлы, импортированные в проект в виде клипов, были также перенесены на новое место. При этом по возможности сохраняйте иерархию хранения файлов (например, храните все медиа-файлы проекта в одной папке).

Если вы столкнулись с подобной ситуацией, отчаиваться не стоит. Проанализируйте, почему After Effects не может найти нужный файл, и выберите одно из трех решений:

  • считать его безвозвратно утерянным и полностью удалить из всех композиций;
  • попытаться найти его в другом месте на диске;
  • отложить процесс поиска "на потом", сконцентрировавшись на других задачах и оставляя упоминания о клипе в фильме в качестве "белых пятен".

Именно последний вариант предлагается по умолчанию.

Попробуем сами на конкретном примере разобраться, как происходит поиск потерянных файлов. Для этого используем тот же проект start.aep, который содержит несколько клипов.

1. Закройте проект start.aep.

2. Перейдите из окна After Effects к содержимому папки, в которой находятся файлы с исходным материалом.

3. Переместите один из файлов в какую-либо другую папку (для этого можно использовать новую папку, вложенную в текущую), либо просто измените название файла.

4. Любым из способов, описанных в данном разделе, откройте проект start.aep.

5. Закройте нажатием кнопки ОК окно с предупреждением и информацией о количестве потерянных файлов (см. рис. 7.5).

В открывшемся окне Project (Проект) обратите внимание на курсивное отображение имени потерянного файла (рис. 7.6).

Рис. 7.6. Отключенный файл в окне Project

Такие файлы называются отключенными (offline) и не могут быть загружены в проект After Effects, однако все атрибуты и изменения, которые вы осуществляли в прежние сессии работы в After Effects, полностью сохраняются (рис. 7.7). Отключенные файлы отображаются в окне Timeline (Монтаж) в обычном виде, а в окне Composition (Композиция) их изображение символически заменяется настроечной таблицей (рис. 7.7). Впоследствии можно заменить отключенный файл прежним и таким образом вернуть всю программу действий, назначенную ему в окне Timeline (Монтаж). Это означает, что в будущем, когда нужный файл найдется, ваша работа по его монтажу в композиции и настройке различных спецэффектов сохранится.

Рис. 7.7. Отключенный файл в окне Timeline и Composition

Разберемся, как можно провести поиск отключенных файлов.

1. Выберите в верхнем меню File>Replace Footage>File (Файл>3аменить клип>Файл).

2. В открывшемся диалоге Replace Footage File (Заменить исходный файл) отыщите расположение нужного файла (рис. 7.8).

Рис. 7.8. Замена отключенного файла

В результате найденный файл заменяет отключенный файл как в окне Project (Проект), так и везде в окне Timeline (Монтаж). При этом содержимое обнаруженного файла используется для формирования кадра композиции (рис. 7.9).

Рис. 7.9. Найденный файл заменяет в проекте отключенный файл

Примечание

Заменить отключенный (и, вообще говоря, любой импортированный в проект) файл можно любым подходящим файлом, вовсе не обязательно тем же самым, что использовался в проекте раньше. В частности, для повышения быстроты работы в After Effects сначала можно осуществить монтаж с предварительно заготовленным черновым файлом, а затем заменить его настоящим. На самом деле, в After Effects предусмотрено специальное средство для осуществления редактирования такого типа, называемое Proxy (Черновик). Поскольку применяется оно не очень часто, мы оставили соответствующую информацию за пределами нашей книги, ограничившись лишь упоминанием о нем.


7.1.4. Сохранение проекта

Несколько команд пункта верхнего меню File (Файл) позволяют осуществить операции по сохранению проекта (рис. 7.10):

Рис. 7.10. Сохранение проекта

  • File>Save (Файл>Сохранить) — сохраняет проект под текущим именем (если вновь созданный проект сохраняется впервые, то, как и в случае команды Save As, выводится диалог, в котором следует определить имя сохраняемого файла);
  • File>Save As (Файл>Сохранить как) — сохраняет проект под новым именем (рис. 7.11);
  • File>Save a Copy (Файл>Сохранить копию) — сохраняет проект под другим именем, но открытым оставляет прежний проект (рис. 7.12);
  • Revert (Вернуться) — возвращается к последнему сохраненному варианту проекта.

Рис. 7.11. Сохранение проекта под новым именем

Рис. 7.12. Сохранение копии проекта

Совет

Командой Save a Copy очень удобно пользоваться для создания резервных копий проекта After Effects, над которым вы работаете. В определенные моменты редактирования фильма полезно "про запас" сохранять промежуточные результаты работы, с тем, чтобы к ним легко было вернуться потом, если результат последующих действий по монтажу основного проекта вам по каким-либо причинам разонравится.

Если проект находится в только что сохраненном состоянии, то пункт меню File>Save (Файл>Сохранить) недоступен, а в противном случае тот факт, что проект был изменен, подчеркивается наличием звездочки (*) в заголовке окна Project (Проект).

Последняя из перечисленных команд, Revert (Вернуться), закрывает проект в его текущем состоянии и открывает последний его сохраненный вариант. Перед этим выводится соответствующее диалоговое окно с предупреждением о потере всех действий по редактированию в промежуток времени, начиная с последнего сохранения проекта (рис. 7.13). Пользуйтесь данной командой, если вам хочется отменить целую серию действий по редактированию проекта, но вы затрудняетесь отменить каждое из действий по отдельности.

Рис. 7.13. Предупреждение о потере всех действий при возвращении к сохраненному прежде варианту проекта

Примечание

Отменить последнее совершенное действие можно командой верхнего меню Edit>Undo (Правка>Отменить). Если вы хотите отменить сразу несколько последних действий, то введите команду Edit>History (Правка>Журнал) и затем в открывшемся диалоге определите, какие конкретно из последних операций требуется аннулировать.


7.1.5. Закрытие проекта

Для того чтобы завершить работу над текущим проектом, достаточно закрыть окно Project (Проект) с помощью кнопки Close (Закрыть) управления окном (рис. 7.14).

Рис. 7.14. Для закрытия проекта нажмите кнопку управления окном Close

Также закрывает проект команда File>Close (Файл>Закрыть). После закрытия проекта можно либо создать новый проект, либо открыть из файла уже существующий.

Для завершения всего сеанса работы в After Effects следует закрыть его основное окно либо выбрать в верхнем меню команду File>Exit (Файл> Выход).


7.2. Экспорт композиций

Одна из самых важных операций в After Effects — это экспорт композиций. При экспорте After Effects вначале производит все необходимые расчеты, обрабатывая изображение каждого кадра композиции в соответствии с редактированием, записанным в окне Timeline (Монтаж). Этот процесс, как вы помните, называется рендерингом. Затем на диск компьютера сохраняется соответствующий медиа-файл, который является результатом вашей работы по монтажу композиции.

Для того чтобы произвести экспорт композиции, есть несколько возможностей:

  • воспользоваться рендерингом приложения QuickTime (либо другой подходящей программы, если она присутствует на вашем компьютере) при помощи команды File>Export (Файл>Экспорт) (для этого приложение QuickTime должно быть установлено на вашем компьютере);
  • осуществить экспорт композиции с текущими установками при помощи команды Composition>Make Movie (Композиция>Создать видео);
  • воспользоваться специальным программным модулем Render Queue (Список рендеринга, или, дословно, очередь на рендеринг), позволяющим управлять максимумом опций экспорта и вызываемым командой Window>Render Queue (Окно>Список рендеринга),


7.2.1. Форматы файлов

При экспорте композиций необходимо иметь в виду два чрезвычайно важных обстоятельства. Во-первых, следует хорошо представлять себе, с какими установками вы собираетесь осуществлять экспорт. Надо иметь в виду, что установки экспорта (т. е. свойства получаемого медиа-файла), вообще говоря, могут отличаться от тех установок, которые назначены композиции (см. урок 4) и которые применяются при просмотре кадра в окне Composition (Композиция). Желательно, конечно, чтобы установки композиции и экспорта совпадали, однако это не является обязательным (например, в случае экспорта пробных вариантов вы можете установить гораздо худшее качество ради экономии времени рендеринга).

Во-вторых, необходимо знать заранее, в файл какого формата вы собираетесь осуществить экспорт. От формата файла (который во многом определяет алгоритм сжатия видео) во многом зависит качество окончательного результата и физический размер файла. Также вы обязаны учитывать, для каких целей вы монтируете фильм и файлы каких форматов вам нужны.

В табл. 7.1 приведен список форматов файлов, поддерживаемых After Effects.

Таблица 7.1. Форматы файлов, поддерживаемых After Effects 6.0

Формат | Windows | Mac OS
Adobe Illustrator (.ai, .ai4, .ai5, .eps, .ps) | + | +
Adobe PDF (.pdf) | Только 1 -я страница | Только 1 -я страница
Adobe Photoshop (.psd) | 16bpc | 16bрс
Adobe Premiere 6.0 (.ppj) | + | +
Adobe Premiere 7.0 (.prproj) | + | -
Animated GIF (.gif) | + (при наличии QuickTimeе 5.0 и выше)
AU (.au) | + (при наличии QuickTimrе 5.0 и выше)
Audio Interchange File Format AIFF (.aiff) | + (при наличии QuickTimе 5.0 и выше)
Bitmap (.bmp) | ++ | ++
Bitmap (.rle) | + | +
Cineon (.cin) | + (конвертация в формат В или 16 bрсс в в завимости от установок проекта)
DirectShow (.grf) | + | -
Discreet RLA/RPF (.rla, .rpf) | 16bрс |
Electriclmage (.img, .eiz) | + | +
EPS (.eps | + | +
Filmstrip (.flm) | + | +
FLC (.flc) | + | +
FLI (.fli) | + | +
JPEG (.jpg, jpe) | + | +
Macromedia Flash (.swf) | + (при наличии QuickTimе 5.0 и выше)
Maya camera data | Только версия Professonal
Maya IFF (.iff) | 16bpc | 16 bрс
МРЗ (.трЗ) | + (при наличии QuickTime 5.0 и выше)
MPEG-1 (.mpg) | + | + (при наличии QuickTime 5.0 и выше)
PCX (.pcx) | ++ | ++
Pict (.pet, .pic) | + | +
Pixar (.pxr) | ++ | ++
Portable Network Graphics (.png) | 16 bit | 16 bit
QuickTime (.mov) | 16 bpc, при наличии QuickTime 5.0 и выше
SGI (.sgi, .rgb) | 16 bрс | 16 bрс
Softimage (.pic) | + | +
Targa (.tga, .vda, .icb, .vst) | + | +
TIFF (.tif) | + | +
Video for Windows (.avi, .wav) | + | + (при наличии QuickTime 5.0 и выше)
Windows Media File (.wmv) | + | -

Примечание

В таблице использованы следующие обозначения: ++ (формат поддерживается, эффекты Adobe Photoshop действуют); + (формат поддерживается, но без работы эффектов Adobe Photoshop); - (формат не поддерживается); 16 bрс (поддержка 16 бит/канал — только для After Effects Pro).


7.2.2. Экспорт QuickTime

Если на вашем компьютере установлена какая-либо программа, позволяющая осуществлять рендеринг видео (например, приложение QuickTime компании Apple), то можно воспользоваться ей для экспорта композиций.

1. Выделите композицию.

2. В верхнем меню File (Файл) наведите указатель мыши на пункт Export (Экспорт) и выберите в появившемся подменю желаемый формат файла (рис. 7.15).

Рис. 7.15. Для экспорта при помощи стороннего приложения выберите желаемый формат файла из подменю File>Export

3. В открывшемся диалоговом окне просмотрите установки видео (на верхней панели) и звука (на нижней). При необходимости снимите флажки проверки Video (Видео) или Sound (Звук), если вы собираетесь экспортировать только звук или только видео соответственно (рис. 7.16).

Рис. 7.16. В диалоговых окнах задайте установки экспорта композиции

4. Если вы хотите отредактировать установки экспорта, то нажатием одной из кнопок Settings (Установки) вызовите соответствующее диалоговое окно для изменения параметров видео или звука (рис. 7.16). Для видео в диалоге Compression Settings (Установки) имеется возможность выбрать тип компрессора (в самом верхнем выпадающем списке), глубину пиксела, качество сжатия, а также частоту кадров и частоту ключевых кадров и ограничение на размер файла (выражающееся в значении потока информации в секунду). Для параметров аудио можно также выбрать тип компрессора, глубину кодировки звука, частоту дискретизации и формат (моно или стерео).

Примечание

Не путайте ключевые кадры, которые используются программой-кодеком (см. урок 1), с ключевыми кадрами анимации (см. урок 10).

5. Закройте диалоги с установками нажатием кнопки ОК и дождитесь, пока экспорт завершится (рис. 7.17). Прервать процесс экспорта можно нажатием кнопки Stop (Стоп).

Рис. 7.17. Остановить процесс экспорта можно нажатием кнопки Stop

6. После завершения экспорта файл, сохраненный на диске, можно просмотреть, импортировав его в проект обычным способом (рис. 7.18).

Рис. 7.18. Файл, в который был произведен экспорт, можно открыть при помощи команды Import


7.2.3. Экспорт при помощи Render Queue

Использование Render Queue (Список рендеринга) связано с применением в качестве установок экспорта текущих установок композиции. Для этого:

1. Сохраните проект.

2. Сделайте активным окно Timeline (Монтаж) с желаемой композицией.

3. Выберите в верхнем меню Composition>Make Movie (Композиция>Создать видео).

4. В появившемся диалоговом окне Render Queue (Список рендеринга) просмотрите при желании установки экспорта композиции, раскрывая для этого соответствующий выпадающий список, и нажмите кнопку Render (Начать рендеринг) (рис. 7.19).

Рис. 7.19. После ввода команды Composition>Make Movie появляется диалог Render Queue

5. Понаблюдайте за процессом рендеринга в том же диалоге (ориентируясь на индикатор в его верхней части) и дождитесь завершения экспорта (рис. 7.20).

Рис. 7.20. Понаблюдайте за процессом рендеринга в диалоговом окне Render Queue

После завершения экспорта строка с именем композиции остается в окне Render Queue (Список рендеринга), поэтому вы в любой момент можете просмотреть установки экспортированного файла (рис. 7.21), а также отредактировать их, щелкнув на активной надписи Current Settings (Текущие установки) и поменяв соответствующие параметры в открывающемся диалоге. Кроме того, можно из области той же надписи вызвать контестное меню и задать другой набор установок, имеющийся в After Effects, например, вместо пункта Current Settings (Текущие установки) выбрать Draft Settings (Черновые установки) или т. п.

Рис. 7.21. Просмотреть установки экспорта можно, раскрывая соответствующий выпадающий список с параметрами рендеринга в окне Render Queue

Вызвать диалоговое окно Render Queue (Список рендеринга) можно в любой момент работы при помощи команды Window>Render Queue (Окно>Список рендеринга). При помощи этого диалога можно очень гибко управлять процессом рендеринга. В частности, допускается создавать очередь на экспорт из нескольких композиций. Рендеринг будет проводиться в том порядке, в котором композиции будут перечисляться в окне Render Queue (Список рендеринга).

Для того чтобы включить ту или иную композицию в очередь на рендеринг, достаточно просто перетащить ее (хватаясь за название композиции) в окно Render Queue (Список рендеринга). В этом случае имя композиции возникает в списке очереди на рендеринг, что. подчеркивается флажком проверки слева от него (рис. 7.22). Чтобы выключить текущую композицию из очереди на экспорт (не аннулируя ее позиции вовсе), достаточно просто снять данный флажок проверки.

Рис. 7.22. Добавлять композиции для экспорта можно перетаскивая их в окно Render Queue, формируя тем самым очередь на рендеринг

Запустить процесс рендеринга группы композиций можно, как мы уже говорили, нажатием кнопки Render (Начать рендеринг). Приостановить его можно нажатием кнопки Pause (Приостановить). Как несложно сообразить, обработка изображения видео требует привлечения серьезных ресурсов компьютера, поэтому его работа в процессе рендеринга может существенно замедляться. Имея это в виду, разумно, по возможности, отложить экспорт на свободное время, когда компьютер будет свободен от других задач.


7.2.4. Рендеринг фильмов Adobe Premiere

Очень часто работа над фильмом в After Effects является вторым этапом после его монтажа в приложении Adobe Premiere. Как правило, линейный монтаж (если он не совсем тривиален) проводится в Premiere, а сложные спецэффекты настраиваются уже в After Effects. Для такой схемы работы вовсе не обязательно осуществлять промежуточный экспорт смонтированного фильма в Premiere, a затем импортировать его как исходный файл в After Effects. Имеется возможность сразу загрузить нескомпилированный проект Premiere (т. е. файл с расширением ppj или ppropj, в зависимости от версии программы) в After Effects, осуществить его редактирование, а затем уже провести рендеринг и экспорт.

Рассмотрим, как осуществляется совместная работа в Adobe Premiere и After Effects.

1. Смонтируйте фильм в программе Adobe Premiere и сохраните вашу работу в виде проекта Premiere, не экспортируя медиа-файл.

2. Импортируйте файл проекта Premiere в проект After Effects таким же способом, как и импорт исходных медиа-файлов. В результате импорта каждый смонтированный фильм проекта Premiere станет композицией After Effects и появится в окне Project (Проект). Исходные клипы проекта Premiere будут помещены в отдельные папки, которые также окажутся в проекте After Effects (рис. 7.23).

Рис. 7.23. Проекты Adobe Premiere импортируются в After Effects в форме обычных композиций

3. Откройте композицию, полученную из проекта Premiere, в окне Timeline (Монтаж) и отредактируйте ее стандартными способами, как вы редактируете обычные композиции After Effects.

4. Выполните экспорт композиции.

Совет

Чтобы работать с фильмом, смонтированным в Premiere, как с единым целым, удобно использовать его в качестве композиции, вложенной в другую композицию.

Таким образом, при совместной работе с After Effects и Premiere рендеринг и экспорт фильма осуществляются всего один раз.


Урок 8. Рисование

  • На этом уроке...
  • 8.1. Основы рисования
  • 8.2. Опции рисования
  • 8.3. Клонирование и стирание линий
    • 8.3.1. Клонирование
    • 8.3.2. Стирание
  • 8.4. Резюме


На этом уроке...

Разобравшись с особенностями инструментария After Effects, перейдем к изложению основных возможностей этой программы по редактированию фильмов. Посвятим данный урок вопросам рисования на кадрах композиций графических примитивов, подобно тому, как создаются статические рисунки в обычных графических редакторах (типа Microsoft Paint или Adobe Photoshop).

  • Чего мы хотим:

  • научиться рисовать "от руки" графические объекты слоев композиции;
  • "дорисовать" на некотором анимационном ролике (из внешнего файла) дополнительную картинку, для чего нам придется создать новую композицию из двух составных частей: исходного видеоролика и собственно добавленной нами графики (см. разд. 8.1)',
  • нарисовать "с чистого листа" некоторую картинку, которая будет динамически появляться во время фильма (см. разд. 8.2).

  • Нам потребуется:

  • любой видеофайл.

  • Что полезно вспомнить:

  • как создаются новые композиции на основе установок исходных файлов (см. разд. 4.1) и какие инструменты существуют для редактирования слоев (см. урок 6).


8.1. Основы рисования

Начнем с создания нового проекта, который будет содержать исходное видео и новую композицию, представляющую собой модифицированный видеоролик.

1. Создайте новый проект командой File>New>New Project (Файл>Создать> Новый проект) и сохраните его под именем lessonS.aep.

2. Импортируйте в проект исходный видеоклип (в нашем случае он называется footage.avi), пользуясь, например, командой File>Import>File (Файл> Импорт>Файл).

3. Создайте на основе установок данного видеоклипа новую композицию, для чего перетащите его название на кнопку New Composition (Создать композицию) панели инструментов окна Project (Проект) (рис. 8.1).

Рис. 8.1. Создайте новую композицию на основе исходного видеофайла

В результате (рис. 8.2) будет создана новая композиция footage Comp l, состоящая пока из единственного слоя с видеоклипом footage.avi и обладающая всеми его установками. Именно это нам требовалось на начальном этапе редактирования, поскольку нашей основной задачей является "дорисовать" на кадрах ролика некоторую картинку, а именно, нарисуем "от руки" большую стрелку, которая будет указывать на определенное место ролика.

Рис. 8.2. Новая композиция пока содержит только исходный файл

Разберемся теперь, как осуществляется в After Effects рисование на слоях. Для этого можно использовать два пути: либо создать новый слой над слоем footage.avi и разместить на нем желаемую графику (настроив соответствующим образом режим прозрачности), либо рисовать непосредственно на изображении слоя footage.avi. Мы выберем второй способ и не станем создавать новые слои, а добавим графику на имеющийся в композиции слой.

Выполните следующие операции:

1. Дважды щелкните на имени слоя в окне Timeline (Монтаж), на котором вы собираетесь рисовать. После этого изображение данного слоя откроется в окне Layer (Слой) (на рис. 8.3 оно совмещено с кадром редактируемой композиции посредством соответствующих закладок).

Рис. 8.3. Перейдите к окну с изображением кадра слоя, на котором вы хотите рисовать, и выберите инструмент Brush

Рисование линий, таким образом, производится не на кадрах композиции, а на кадрах формирующих ее отдельных слоев.

2. Перейдите к тому кадру слоя, на котором вы собираетесь рисовать, к примеру, к кадру 0:00:09:21. Созданная вами графика будет назначена данному слою композиции от текущего кадра, на котором вы начнете рисование, до конца композиции. О том, как еще на стадии начала рисования можно определить длительность показа этого рисунка в фильме, скажем чуть позднее (см. разд. 8.2).

3. Выберите в палитре Tools (Инструментарий) инструмент Brush (Кисть) (рис. 8.3).

4. При необходимости выберите атрибуты кисти в палитрах Paint (Кисть) и Brush Tips (Опции рисования, или, дословно, наконечники кисти).

5. Переведите указатель мыши на окно Layer (Слой) (рис. 8.4), обращая внимание на изменение его внешнего вида, говорящее о возможности начать рисование линии "от руки" на кадре слоя.

Рис. 8.4. Рисование линий на слое композиции осуществляется инструментом Brush

6. Нажмите левую кнопку мыши над желаемым местом изображения кадра и, удерживая ее, начните рисование линии (рис. 8.4). Отпустите кнопку мыши в тот момент, когда захотите оборвать рисование линии.

7. Таким же образом дорисуйте остальные части изображения строки (рис. 8.5).

Рис. 8.5. Процесс рисования "от руки" на слое картинки в виде стрелки

Каждая линия (в нашем примере для создания рисунка-стрелки мы нарисовали три линии) добавляется в композицию в виде независимого элемента, который впоследствии можно отредактировать, в частности, изменить атрибуты линии, назначить спецэффект или настроить для него анимацию.

Совет
Если в процессе рисования вы ошиблись на каком-либо шаге, то отменить последнее действие (без ущерба для прочих настроек композиции) можно нажав сочетание клавиш <Ctrl>+<Z> или выбрав в верхнем меню Edit>Undo (Правка> Отменить). Кроме того, удобно пользоваться командой Edit>History (Правка> Журнал), которая позволяет быстро отменить любую последовательность действий (рис. 8.6).

Рис. 8.6. Отмена последних действий по рисованию линий при помощи подменю History

Теперь самое время разобраться, каким образом After Effects добавляет на слои композиции рисунки, выполненные инструментом Brush (Кисть). Для этого проделаем несколько несложных опытов.

1. Просмотрите несколько кадров, расположенных перед тем кадром, на котором производилось рисование (рис. 8.7). Вы видите, что рисунка на них нет.

Рис. 8.7. Предыдущие кадры не содержат нарисованных линий

2. Теперь просмотрите кадры композиции после кадра, на котором мы рисовали. Вы можете видеть, что рисунок в виде стрелки присутствует на всех этих кадрах (рис. 8.8).

Рис. 8.8. Нарисованная стрелка появилась на всех кадрах слоя, начиная с текущего и заканчивая последним кадром слоя

Таким образом, рисование выполнилось для текущего кадра и всех последующих кадров, вплоть до конца слоя.

Разумеется, в After Effects нарисованные объекты можно впоследствии отредактировать, причем делается это очень похоже на редактирование самих слоев композиции.

1. Перейдите к окну Timeline (Монтаж) и раскройте вложенный список атрибутов слоя footage.avi. Затем последовательно раскройте выпадающие списки атрибутов этого слоя, относящиеся к нарисованным объектам, т. е. Effects (Эффект) и Paint (Рисование). Вы увидите (рис. 8.9), что список Paint (Рисование) содержит три элемента, обозначающие нарисованные на слое линии, т. е. — Brush 1, Brush 2 и Brush 3. Каждый из этих элементов в окне Timeline (Монтаж) сопровождается прямоугольной пиктограммой под шкалой времени, которая обозначает моменты начала (входные точки, или In-point) и конца (выходные точки, или Out-point) демонстрации соответствующей линии в композиции.

Редактирование длительности нарисованной графики производится точно так же, как подгонка слоев (см. разд. 5.2).

2. Выделите в окне Timeline (Монтаж) одну из линий, например — Brush 1. Для этого достаточно щелкнуть либо на ее названии в раскрытом списке Paint (Рисование), либо на соответствующей ей пиктограмме во временной области окна Timeline (Монтаж). В результате вы увидите, что эта линия станет выделенной на изображении кадра в окне Layer (Слой), что крупным планом показано на рис. 8.9.

Рис. 8.9. Линия Brush 1 выделена в окнах Timeline и Layer

Поскольку эта линия была нарисована первой, то 1-й номер был ей присвоен автоматически. Выделив подобным образом любой из элементов слоя, можно начать его редактирование.

3. Раскройте вложенный список какой-нибудь линии в окне Timeline (Монтаж), например, Brush 1. Обратите внимание на то, что каждая из линий сопровождается перечнем атрибутов, которые можно вызвать на экран, раскрывая соответствующий вложенный список в окне Timeline (Монтаж). К примеру, раскройте список Stroke Options (Опции линии), который содержит параметры линии, описывающие ее динамику с течением времени, такие, как положение в кадре, цвет, толщину и т. д.

Рис. 8.10. Вложенный список атрибутов линии Brush 1 позволяет регулировать все ее основные свойства

Выделить линию можно не только при помощи окна Timeline (Монтаж), но и визуальным способом, на изображении кадра слоя в окне Layer (Слой).

1. Сделайте активным инструмент Selection (Выбор), нажав соответствующую кнопку палитры Tools (Инструментарий) (рис. 8.11).

2. Выделите в окне Layer (Слой) все три линии, образующие стрелку (рис. 8.11). Для этого можно протащить указатель (при удерживаемой кнопке мыши) через нарисованные на кадре линии, либо выделить каждую из них щелчком при нажатой клавише <Shift>. Обратите внимание, что выделение приобретут соответствующие элементы Brush 1, Brush 2 и Brush 3 в окне Timeline (Монтаж). На рис. 8.11 выделение элементов слоя подчеркивается врезкой.

В завершение разговора об основах рисования в After Effects скажем о том, как перенести какую-либо нарисованную линию на другой кадр композиции. Например, сделаем так, чтобы наш рисунок возникал в два приема: сначала появлялась вертикальная линия стрелки, а потом, через несколько секунд, — ее крылья.

Рис. 8.11. Выделить нарисованные элементы слоя можно при помощи инструмента Selection в окне Layer

Для этого в окне Timeline (Монтаж) передвиньте входную точку линии Brush 1 на несколько секунд влево вдоль шкалы времени (рис. 8.12).

После произведенных нами действий по рисованию линий на клипе можно осуществить экспорт созданной композиции и получить в результате тот же самый ролик, на котором в определенные нами моменты будет появляться добавленная нами графика.

Рис. 8.12. Место нарисованных объектов в фильме можно определить, перемещая их входную и выходную точки в окне Timeline


8.2. Опции рисования

Обратимся теперь к настройке режима рисования линий (такой, как выбор цвета, толщины, прозрачности и т. д.), для чего опять создадим новую композицию.

1. Создайте новую композицию и определите в ней новый слой, пользуясь командой New>Solid (Создать>Сплошной) верхнего меню Layer (Слой) или контекстного меню.

2. В диалоге создания нового сплошного слоя выберите его желаемый фон (например — синий) и нажмите ОК.

3. Перейдите к кадру слоя в окне Layer (Слой), щелкнув дважды на имени слоя в окне Timeline (Монтаж).

4. Выберите в палитре Tools (Инструментарий) инструмент Brush (Кисть).

5. Командой Window>Paint (Окно>Рисование) вызовите палитру Paint (Кисть), которая обычно совмещена в пределах одного окна с палитрой Brush Tips (Наконечники кисти) (рис. 8.13).

Рис. 8.13. Для управления рисованием служат палитры Paint и Brush Tips

Примечание

Если перед выбором инструмента Brush (Кисть) установить в палитре Tools (Инструментарий) флажок проверки Auto Open Palettes (Автоматически открывать палитры), то палитры, относящиеся к рисованию будут открываться автоматически.

После произведенных нами подготовительных действий можно непосредственно приступить к рисованию. Рассмотрим, как можно управлять опциями рисования линий при помощи палитры Paint (Рисование). Определите в палитре Paint (Рисование) необходимые параметры линии, которую вы собираетесь создать, а потом нарисуйте эту линию желаемой формы (см. рис. 8.18).

Рис. 8.14. Выбрать текущий цвет можно при помощи диалогового окна Color

Перечислим параметры вновь создаваемых линий, которые можно настраивать в палитре Paint (Рисование).

  • Color (Цвет) — активное поле находится в правом верхнем углу палитры (рис. 8.13, 8.14) .и служит для выбора двух текущих цветов: foreground (приоритетного, которым, собственно, и осуществляется рисование) и background (фонового). Для определения этих цветов достаточно щелкнуть на соответствующем поле в палитре и затем выбрать желаемый цвет, либо численно определить его базовые RGB- или HSL-составляющие (см. разд. 1.1.4) в стандартном диалоге Color (Цвет) (рис. 8.14). Кроме того, для выбора цвета из присутствующих на изображении кадра можно использовать вспомогательный инструмент Eyedropper (Пипетка), который также присутствует в палитре Paint (Рисование).
  • Opacity (Непрозрачность) — регулятор прозрачности создаваемой линии. Совершенно прозрачной линии соответствует параметр, равный 0%, сплошной — 100%, а сделать линию очень прозрачной возможно, устанавливая для этого параметра небольшие значения (порядка единиц процентов).
  • Flow (Заливка) — регулятор интенсивности цвета заливки создаваемой линии. Выбирая значения, меньшие 100%, можно сделать оттенок цвета линии более блеклым (не меняя при этом прозрачности линии).
  • Brush Tips (Наконечники кисти) — выпадающий список, из которого можно выбрать для рисования кисть желаемой формы и размера (рис. 8.15). Размер кисти (в пикселах) указывается под пиктограммой, представляющей форму (круглую или эллиптическую) и тип каждой кисти. Кисть может быть твердой (hard), либо диффузной, или размытой (soft). Список содержит несколько предустановленных вариантов кисти, и, если вы не нашли среди них подходящего, следует определить новые типы кисти, обратившись ко второй палитре Brush Tips (Наконечники кисти).

Рис. 8.15. Тип кисти выбирается в списке Brush Tips

Примечание

Обратите внимание, что при выборе определенного типа кисти указатель мыши, если его перенести на окно Layer (Слой), будет принимать очертания профиля данной кисти, что существенно облегчает процесс рисования.

  • Mode (Режим) — выпадающий список различных режимов смешения выбранного цвета кисти и фонового цвета слоя. Несколько вариантов смешения цветов приведены на рис. 8.16. Наиболее простой режим — Normal (Обычный) — не принимает во внимание фон кадра (буква N), режим Dissolve (Размытие) связан с характерным эффектом перехода цвета на границе линии (буква D), остальные режимы реализуют различные алгоритмы смешения цветов линии и фона. Один из таких режимов, называемый Overlay (Наложение), использован на рис. 8.16 для рисования буквы О.

Рис. 8.16. Опции смешения цвета кисти и фона кадра выбираются в списке Mode

  • Channel (Канал) — выпадающий список, определяющий, на каких каналах слоя производится рисование. На соответствующем уроке (см. урок 9) мы разберемся, что эффект прозрачности настраивается при помощи дополнительного (вдобавок к RGB-цветам) изображения, называемого альфа-каналом. В связи с этим рисование линий может относиться как только к видимой цветовой составляющей изображения (элемент списка RGB), так и к альфа-каналу (элемент Alpha). По умолчанию принята опция рисования одновременно на самом изображении и альфа-канале (элемент ARGB).
  • Duration (Длительность) — список, задающий промежуток времени, в течение которого в композиции будет демонстрироваться нарисованная линия. Имеются следующие варианты: Single Frame (Только текущий кадр), Constant (До конца слоя), Write On (Анимация) и Custom (Ручная настройка). Последний тип длительности позволяет ввести длительность (в формате числа кадров) вручную, при помощи становящегося доступным регулятора параметра (рис. 8.17).

Рис. 8.17. Длительность линии можно задать вручную соответствующим регулятором при выборе пункта Custom списка Duration

Остальные два флажка проверки — Aligned (С выравниванием) и Lock Source Time (Блокировка времени источника) относятся к режимам использования другого инструмента рисования — Clone Stamp (Клонирование) и при использовании инструмента Brush (Кисть) недоступны.

После того как вы определили все опции создаваемой линии в палитре Paint (Рисование), можно ее нарисовать (рис. 8.18). Более толстая линия обрамления нарисована круглой кистью в 13 пикселов и оттенком цвета 100%, а мелкие промежуточные линии — кистью в 5 и 9 пикселов и оттенком того же цвета в 50%. В центре нарисована единственная точка, параметры которой вы видите в палитре Paint (Рисование).

Рис. 8.18. Пример использования различных наконечников кисти

В завершение разговора об опциях рисования инструментом Brush (Кисть) скажем несколько слов о палитре Brush Tips (Наконечники кисти), которая служит для определения пользовательских типов кистей. В этой палитре можно настроить варианты кисти как временно (только для текущей линии), так и добавить настроенные типы линий в качестве установок в список Brush Tips (Наконечники кисти), доступный, в том числе и в палитре Paint (Кисть).

Перечислим параметры кисти, которые можно определить с помощью соответствующих регуляторов в палитре Brush Tips (Наконечники кисти), подчеркнув, что они определяют кисть в общем случае эллиптической формы.

  • Diameter (Диаметр) — задает диаметр (т. е. основной размер) кисти;
  • Angle (Угол) — задает угол наклона главной оси эллипса кисти относительно горизонтали;
  • Roundness (Закругление) — отношение большой и малой осей эллипса;
  • Hardness (Жесткость) — задает плавность перехода цвета на границе от цвета линий до цвета фона;
  • Spacing (Расстояние) — задает расстояние между точками (в % относительно диаметра), формирующими пунктирную линию (эта опция работает только, если выставлен находящийся рядом флажок проверки).

Группа параметров Brush Dynamics (Движение кисти) по умолчанию скрыта в палитре и имеет значение только в том случае, если вы используете для ввода рисованных линий не мышь, а специальные планшетные манипуляторы, чувствительные к степени нажатия руки (например, планшет Wacom®).

Примечание

В список палитры Brush Tips (Наконечники кисти) можно добавить новые типы кистей, пользуясь стандартной кнопкой New (Создать) на ее панели инструментов, а также удалить ненужные типы при помощи кнопки Delete (Удалить).

Рис. 8.19. Палитра Brush Tips служит для определения параметров кисти

Примечание 2

Вид списка кистей можно настроить при помощи меню палитры Brush Tips (Наконечники кисти) (рис. 8.20).

Рис. 8.20. Настроить вид палитры Brush Tips можно при помощи меню палитры

Если теперь вернуться к представлению линий в окне Timeline (Монтаж) (см. рис. 8.10), то станет ясно, что параметры, сопровождающие каждую линию, появляющуюся при рисовании на слое, являются теми же самыми, что были определены в палитрах Paint (Рисование) и Brush Tips (Наконечники кисти) при рисовании линии.


8.3. Клонирование и стирание линий

В завершение урока заметим, что для редактирования рисованных в After Effects имеются еще два инструмента — Clone Stamp (Клонирование) и Eraser (Ластик).


8.3.1. Клонирование

Смысл работы инструмента Clone Stamp (Клонирование) состоит в копировании массивов пикселов одних кадров слоя на другие кадры (создание клонов). При этом образец, т. е. пикселы, которые копируются с некоторого слоя, берутся с него до применения каких-либо эффектов, а клонированные пикселы пересчитываются затем с учетом эффектов, настроенных для того слоя, на который было осуществлено клонирование.

Рис. 8.21. Клонирование позволяет исправить мелкие детали кадров (пример взят из справочной системы Adobe After Effects)

Клонирование является специальной процедурой и позволяет, главным образом, создать характерные спецэффекты или исправить мелкие детали кадров фильма, закрасив их пикселами других кадров (рис. 8.21). Таким образом, операция клонирования является, фактически, рисованием на некотором слое композиции соответствующими пикселами изображения другого кадра (того же или иного слоя), причем важным достоинством клонирования является динамический характер этой замены (клонируемые участки всех выбранных кадров образца синхронно переносятся в изображение других кадров по мере действия фильма).

Конспективно перечислим основные действия, которые необходимо совершить для клонирования пикселов.

1. Выберите в палитре Tools (Инструментарий) инструмент Clone Stamp (Клонирование) (рис. 8.22).

Рис. 8.22. Для рисования пикселами одних кадров фильма на других служит инструмент Clone Stamp

2. При желании определите форму и размер кисти в палитрах Brush Tips (Наконечники кисти) и Paint (Кисть), которые будут использованы при клонировании.

3. Используя два флажка проверки внизу палитры Paint (Кисть), определите тип выравнивания клонированных линий, а также длительность клонирования (только текущий кадр, либо все кадры, на протяжении которых существуют клонированные линии).

4. В окне Layer (Слой) переместите индикатор текущего кадра на тот кадр слоя, с которого вы собираетесь осуществить клонирование (образец). При нажатой клавише <Alt> щелкните на кадре слоя, чтобы определить точку привязки образца. Именно окрестность этой точки и будет затем скопирована на другой кадр фильма.

5. Переместите индикатор текущего кадра на тот кадр в окне Layer (Слой), куда собираетесь осуществить клонирование. Если это не тот же, а другой слой композиции, то окно с его кадром необходимо предварительно открыть при помощи двойного щелчка на имени этого слоя.

6. Установите указатель мыши, имеющий вид инструмента Clone Stamp (Клонирование), в желаемое место кадра в окне Layer (Слой) и затем при нажатой кнопке мыши осуществите "рисование" клонированных пикселов (т. е. протаскивание указателя мыши через кадр). При этом можно использовать технику "закрашивания", т. е. по мере рисования инструментом Clone Stamp (Клонирование) на кадре будут появляться участки изображения образца, причем ограниченные тем контуром, который был вами предварительно выбран в палитрах Brush Tips (Наконечники кисти) и Paint (Кисть). Можно также применять одиночные щелчки на изображении кадра при выбранном контуре клонирования желаемой формы и размера (рис. 8.23).

Рис. 8.23. Клонирование пикселов слоя-образца на другом кадре слоя аналогично процессу рисования

7. При необходимости настройте параметры клона в окне Timeline (Монтаж) (рис. 8.24).

Рис. 8.24. Линии-клоны появляются в окне Timeline


8.3.2. Стирание

Процедура стирания служит для полного удаления участков изображения слоя и, соответственно, образования на нем прозрачных линий (своего рода "дыр" в изображении).

Стирание очень похоже на процесс рисования, но осуществляется оно специальным инструментом Eraser (Ластик).

1. Выберите инструмент Eraser (Ластик) (рис. 8.25).

Рис. 8.25. Для рисования прозрачных участков слоя служит инструмент Eraser

2. Задайте форму и размер ластика в палитрах Brush Tips (Наконечники кисти) и Paint (Кисть). Кроме того, можно задать и параметры Opacity (Непрозрачность) и Flow (Заливка), которые также будут учитываться при стирании.

3. В окне Layer (Слой) выберите желаемый кадр и сотрите со слоя желаемые фрагменты изображения (рис. 8.26).

Рис. 8.26. Стертые ластиком фрагменты изображения выделены и в окне Layer, и в окне Timeline

4. При необходимости настройте параметры эффекта "ластик" в окне Timeline (Монтаж) (см. рис. 8.26).


8.4. Резюме

Для рисования "от руки" на слоях композиций After Effects используются три инструмента:

  • Brush (Кисть) — служит для обычного рисования цветными линиями;
  • Clone Stamp (Клонирование) — служит для рисования кадрами другого изображения (слоя-образца);
  • Eraser (Ластик) — служит для стирания фрагментов изображения слоя и замены их прозрачными участками.

Следует также подчеркнуть, что все варианты рисования осуществляются в окне Layer (Слой), а запись информации о них (с возможностью последующей настройки эффектов) производится в окне Timeline (Монтаж).


Урок 9. Прозрачность

  • На этом уроке...
  • 9.1. О принципах настройки прозрачности
  • 9.2. Маски
    • 9.2.1. Прямоугольные и эллиптические маски
    • 9.2.2. Выделение и редактирование масок
    • 9.2.3. Режимы взаимодействия масок
    • 9.2.4. Прозрачность и расширение масок
    • 9.2.5. Удаление масок
  • 9.3. Маски Безье
    • 9.3.1. Рисование масок Безье
    • 9.3.2. Редактирование масок Безье
    • 9.3.3. О других способах создания масок
  • 9.4. Слои-маски
    • 9.4.1. Маскировка слоя другим слоем
    • 9.4.2. О прозрачных наложениях
  • 9.5. Резюме


На этом уроке...

На этом уроке мы познакомимся с принципами настройки прозрачности слоев в After Effects и особенностями наложения слоев друг на друга.

  • Чего мы хотим:

  • научиться настраивать прозрачность слоев композиции и их взаимное наложение;
  • смонтировать композицию, состоящую из нескольких слоев, накладывающихся друг на друга в соответствии с различными опциями задания прозрачности.

  • Нам потребуется:

  • проект, содержащий два слоя, — видеоролик, импортированный из внешнего файла, и сплошной (solid) слой над ним.

  • Что полезно вспомнить:

  • как осуществляется рисование линий при помощи соответствующих инструментов (см. урок 8).


9.1. О принципах настройки прозрачности

Прежде, чем перейти к особенностям настройки прозрачности слоев в After Effects, коротко остановимся на принципах взаимного наложения слоев и дадим обзор типов прозрачности.

Как мы уже говорили, в окне Timeline (Монтаж) слои накладываются на фон композиции, который можно определить в диалоговом окне Background Color (Цвет фона), которое можно вызвать одноименной командой верхнего меню Composition (Композиция). На фон накладывается изображение нижнего слоя композиции, затем осуществляется наложение следующего слоя и т. д. (рис. 9.1, 9.2).

Рис. 9.1. Слои композиции накладываются друг на друга в порядке их следования в окне Timeline, снизу вверх

Для того чтобы в кадре композиции присутствовали фрагменты изображений нижних слоев или фона:

  • кадр верхнего слоя должен быть по размеру меньше кадра композиции;
  • для верхних слоев должен быть соответствующим образом настроен режим прозрачности.

Рассмотрим более подробно пример композиции, приведенный на рис. 9.1, 9.2, 9.3, состоящей из двух слоев, представленных статическими изображениями в формате Adobe Photoshop (эти слои открыты в окнах Layer (Слой) справа на рис. 9.2).

Рис. 9.2. Расположение слоев, показанных на рис. 9.1, в окне Timeline

Самым нижним слоем (см. рис. 9.1), который не отображается в окне Timeline (Монтаж), но имеется по умолчанию в любой композиции, является ее фон. Как видно из рис. 9.2, начало фильма (до его 2-й секунды) не содержит кадров ни одного слоя. Поэтому композиция содержит только свой фон, что иллюстрируется окном Composition (Композиция) на рис. 9.3 (текущим, как вы можете заметить, является кадр 0:00:01:07). Следующие две секунды фильма его кадр состоит из изображения нижнего слоя Clouds.psd в центре и фона по краям (т. к. размер кадра слоя Clouds.psd масштабирован таким образом, чтобы быть меньше, нежели размер кадра композиции).

Рис. 9.3. Фон композиции и два ее слоя, открытые в окнах Layer

Наконец, на 5-й секунде фильма осуществляется наложение обоих слоев. При этом верхний слой Porthole.psd (точнее, сам исходный файл) не является сплошным, а содержит прозрачные области, разметка которых приведена на рис. 9.4. В результате кадр фильма компонуется с учетом этих прозрачных участков. В центре кадра мы видим фрагмент нижнего слоя, а по краям — фон композиции.

Рис. 9.4. Альфа-канал верхнего слоя композиции

Вообще говоря, прозрачность видео или графики принято описывать дополнительным, помимо RGB, каналом изображения, который называется альфа-каналом. Альфа-канал является, по сути, невидимым дополнительным изображением того же размера и показывает, насколько прозрачными следует считать те или иные пикселы изображения. Черные участки альфа-канала говорят о том, что в этих местах изображение абсолютно прозрачно, белые участки — абсолютно непрозрачно (сплошное). Серые участки альфа-канала означают частичную прозрачность, пропорциональную интенсивности черного цвета. Таким образом, альфа-канал изображения Porthole.psd, показанный на рис. 9.4, содержит только черные (прозрачные) или белые (непрозрачные) участки.

Примечание 1

Подчеркнем, что далеко не каждый рисунок или видеофайл имеет альфа-канал (многие форматы файлов для хранения графики или видео даже не предусматривают возможности включения информации об альфа-канале). При обычных условиях альфа-канал скрыт, а видимым является только стандартное изображение (сформированное RGB-каналами). Однако когда такой рисунок или видеофайл подвергается обработке специальными программами (такими, как Adobe Photoshop, After Effects или Premiere), то информация о прозрачности изображения начинает играть очень важную роль, поскольку именно она задает характер наложения слоев друг на друга.

Примечание 2

Некоторые форматы файлов предусматривают то, что описание прозрачности целиком заключено в альфа-канале, а некоторые (о них мы почти не будем говорить в пределах данной книги) формируют итоговое изображение с учетом взаимодействия его альфа-канала с цветовыми каналами. Это нужно, к примеру, для того, чтобы сделать более прозрачными участки изображения определенного цвета, а другие цвета, напротив, представлять в сплошном виде.

Приведенный пример задания прозрачности слоя относится к использованию альфа-канала, существовавшего в самом исходном файле. Однако при настройке наложений слоев в After Effects такая возможность является далеко не единственной. Существуют следующие типы определения прозрачности слоев:

  • настройка для слоя композиции After Effects своего собственного альфа-канала. Она производится путем создания дополнительных изображений, задающих прозрачность участков слоя, называемых альфа-маскам и, или просто маской (mask), которые подобны рис. 9.4. Для каждого слоя может быть назначено несколько различных альфа-масок, которые, складываясь, задают альфа-канал этого слоя. Редактирование альфа-масок может производиться средствами After Effects;
  • определение в качестве канала прозрачности для некоторого слоя не его альфа-маски, а какого-либо другого слоя композиции (или, иногда, самого этого слоя, либо его отдельных цветовых каналов). Слой, задающий прозрачность, называется слоем-маской (matte). В некоторых случаях такой путь определения прозрачности бывает удобнее для пользователя, нежели рисование альфа-канала;
  • выбор и настройка прозрачного наложения (key) — специального алгоритма вычисления степени прозрачности пикселов изображения, в зависимости от сочетания их цветов. Например, можно задать такой тип прозрачного наложения (key type), чтобы сделать прозрачными участки кадра какого-то определенного цвета или некоторого диапазона похожих цветов (например, оттенков красного) или т. п. After Effects имеет целый арсенал встроенных типов прозрачных наложений, которые позволяют пользователю реализовать самые различные задачи по совмещению изображений слоев;
  • использование альфа-канала самого исходного клипа, который импортируется из внешнего файла наряду с цветовыми каналами. В данном случае нет необходимости рисовать альфа-канал в After Effects или применять в качестве масок другие слои композиции (если только вы не хотите изменить прозрачность исходного клипа). Это именно тот тип прозрачности, который мы рассматривали на рис. 9.1, 9.2, 9.3, 9.4;
  • нельзя не сказать о самом простом типе задания прозрачности: постоянной для всех пикселов изображения слоя. Для этого достаточно определить для данного слоя параметр Opacity (Непрозрачность) группы Transform (Преобразования) в окне Timeline (Монтаж).

Перечисленные типы прозрачности подразумевают, что различные маски могут быть двух типов:

  • статическими (неизменными на всем протяжении слоя);
  • динамическими (т. е. изменяться во времени, от кадра к кадру, делая прозрачными или полупрозрачными различные участки слоя), причем динамика масок определяется аналогично стандартной анимации (см. урок 10 и разд. 9.4).

В следующих разделах данного урока мы на конкретных примерах покажем, как производится разметка прозрачности слоев и осуществляется управление их наложением в композиции.


9.2. Маски

Любой из слоев композиции может иметь неограниченное число альфа-масок. Маски можно редактировать и просматривать как в виде графики в окне Layer (Слой), так и в символическом представлении в окне Timeline (Монтаж). Накладываясь друг на друга (если их несколько), альфа-маски формируют альфа-канал разметки прозрачности слоя.

Примечание

Следует оговориться, что альфа-маски могут быть как статическими, так и динамическими. Анимация альфа-масок настраивается, как и любая другая в After Effects, при помощи техники ключевых кадров (см. урок 10).


9.2.1. Прямоугольные и эллиптические маски

Рассмотрим теперь приемы настройки прозрачности на примере композиции, состоящей из двух слоев: нижнего — видеоклипа, импортированного из внешнего файла, и верхнего — сплошного слоя светло-серого цвета (рис. 9.5).

Рис. 9.5. Пока композиция включает в себя два сплошных слоя

Сама композиция имеет черный фон, однако поскольку режим прозрачности ни для одного слоя не определен, кадр композиции формируется исключительно кадром сплошного серого слоя. Определим для верхнего слоя прямоугольную или эллиптическую альфа-маску, чтобы в кадре композиции частично присутствовало изображение с нижнего слоя.

Будем рисовать альфа-маску от руки, пользуясь соответствующим инструментом из палитры Tools (Инструментарий).

1. Выделите в окне Timeline (Монтаж) желаемый слой, в нашем примере Light Gray Solid 1.

Примечание

Можно также открыть слой в его собственном окне Layer (Слой) (для этого, как вы помните, достаточно дважды щелкнуть на его имени в окне Timeline) и рисовать альфа-маску непосредственно на изображении слоя. Однако в отличие от рисования линий (см. урок 8), которое возможно только в окне Layer (Слой), маски можно рисовать и непосредственно на кадре фильма, в окне Composition (Композиция).

Рис. 9.6. Для создания прямоугольной маски выберите инструмент Rectangular Mask

2. В зависимости от желаемой формы маски выберите инструмент Rectangular Mask (Прямоугольная маска) или Elliptical Mask (Эллиптическая маска) (рис. 9.6, 9.7). Учтите, что оба инструмента совмещены в одной и той же кнопке палитры Tools (Инструментарий), и для вызова скрытой кнопки следует нажать совмещенную кнопку и удерживать ее в нажатом состоянии некоторое время. После этого появляется подменю доступных инструментов (рис. 9.7), из которого можно выбрать нужный вам инструмент.

Рис. 9.7. Для создания эллиптической или круглой маски выберите инструмент Elliptical Mask

3. Перейдите в окно Composition (Композиция) или Layer (Слой) (если вы открыли слой в собственном окне).

4. Нарисуйте альфа-маску при помощи техники протаскивания указателя (рис. 9.8, 9.9). Если в процессе рисования удерживать клавишу <Shift>, то форма маски получится правильной (квадратной вместо прямоугольной и круглой вместо эллиптической).

Рис. 9.8. Начните рисование маски подходящим инструментом

Рис. 9.9. Маска нарисована

5. При необходимости инвертируйте прозрачные и сплошные участки командой Layer>Mask>Inverse (Слой>Маска>Инверсная) (рис. 9.10).

Рис. 9.10. Результат инвертирования прозрачных и сплошных участков

Когда вы совершаете подобные действия с существующей маской, т. е. пользуетесь подменю Mask (Маска) верхнего меню Layer (Слой), следите за тем, чтобы в кадре была выделена именно та маска, которую вы собираетесь изменить. Как вы можете заметить, After Effects выделяет маску стандартным способом — при помощи маркеров и линий обрамления (рис. 9.10).

6. После того как один участок альфа-маски нарисован, можно добавить другие маски (повторяя пункты 2—5). На рис. 9.11 показано взаимодействие двух масок. Результирующий альфа-канал слоя получается путем наложения масок друг на друга.

Рис. 9.11. Вторая маска (круглой формы) нарисована при нажатой клавише <Shift>


9.2.2. Выделение и редактирование масок

После того как вы нарисовали маски, их можно изменить, отредактировав форму, размер и степень прозрачности, а также настроив их анимацию и алгоритм взаимодействия между собой. Начнем с того, что подчеркнем появление записи о назначенных слоям масках в окне Timeline (Монтаж) и научимся выделять созданные маски.

1. После того как две маски были добавлены к слою Light Gray Solid 1, откройте вложенный список данного слоя в окне Timeline (Монтаж), чтобы убедиться, что обе маски добавлены к атрибутам слоя (рис. 9.12).

Рис. 9.12. Нарисованные альфа-маски добавляются к атрибутам слоя композиции в виде вложенных списков (выделена маска Mask 1)

2. Выделите по очереди сначала одну, потом другую, а затем обе маски в окне Timeline (Монтаж), используя либо щелчки на именах масок при нажатой клавише <Shift>, либо протаскивая указатель через имена масок.

3. Перейдите теперь к окну Composition (Композиция) и обратите внимание, что по мере выделения имен масок в окне Timeline (Монтаж) они выделяются и в кадре фильма в окне Composition (Композиция) посредством прямоугольных маркеров и линий (или сегментов) обрамления (рис. 9.13).

Рис. 9.13. Выделенные маски отмечаются маркерами и сегментами обрамления в окне Composition, если включена кнопка Toggle View Masks (выделена маска Mask 1)

4. Нажмите кнопку Toggle View Masks (Переключатель отображения масок) (см. рис. 9.13). Кнопка перейдет в выключенное состояние, а маски в окне Composition (Композиция), соответственно, отображаться не будут (такая опция бывает полезна для облегчения работы с окном Composition). В любом случае маски можно всегда выделять и редактировать в окне Layer (Слой).

5. Щелкните инструментом Selection (Выбор) сначала в любом месте кадра композиции за пределами линий обрамления масок. Выделение с них будет снято.

6. Нажмите и удерживайте на клавиатуре к клавишу <Alt>, а затем щелкните по обрамлению любой из масок. Маска приобретет выделение такого же типа, что и при выборе ее в окне Timeline (Монтаж) (рис. 9.14). Такой тип выделения позволяет редактировать маску как единое целое, например, перемещать ее с одного места кадра на другое (для этого следует схватиться за обрамление и перетащить ее указателем на новое место) или масштабировать (путем перетаскивания соответствующего маркера обрамления). В окне Composition (Композиция) можно выделить и несколько масок одновременно (именно этот случай и иллюстрируют рис. 9.13, 9.14, 9.15). Чтобы выделить еще одну маску, вдобавок к выделенным, при щелчке на ней надо удерживать клавишу <Shift>. Таким образом, для выделения нескольких масок целиком необходимо одновременно держать нажатыми две клавиши — <Shift> и <Alt>.

Рис. 9.14. Чтобы выделить маску целиком, необходимо удерживать при щелчке на обрамлении маски клавишу <Alt>

7. Выделите теперь щелчком одну из границ обрамления на каждой маске. В этом случае (рис. 9.15) дальнейшие действия по редактированию масок будут относиться к данной границе.

Рис. 9.15. Простым щелчком на границе маски выделяется только данная линия обрамления

8. Щелчком на одном из маркеров обрамления масок выделите его (рис. 9.16). Это еще один тип выделения масок, который позволяет отсчитывать действия над ними от выделенного маркера. В частности, хватаясь и перетаскивая маркер, можно менять форму маски (прямоугольную маску можно превратить в параллелограмм или ромб, а эллиптическую — в плавный контур неправильной формы).

Примечание

Изменение формы масок при выделении их отдельных маркеров или границ обрамления может производиться методом рисования масок Безье при помощи инструмента Реn (Перо).

Рис. 9.16. Выделение отдельных маркеров обрамления позволяет редактировать форму масок


9.2.3. Режимы взаимодействия масок

Разберемся теперь с режимами рисования масок с точки зрения типа их взаимного наложения друг на друга, а также взаимодействия с нижним слоем. Как мы уже выяснили, одним из способов управления масками является возможность их инвертирования (т. е. переключения прозрачных областей на сплошные и наоборот) при помощи команды Layer>Mask>Inverse (Слой> Macка>Инверсная). Дополнительной и очень важной опцией масок является их режим (mode).

1. Выделите эллиптическую маску целиком и переместите ее вправо в кадре композиции (рис. 9.17). Возможно, то, что вы будете наблюдать на экране своего компьютера, будет отличаться от рис. 9.17, поскольку у вас, скорее всего, будет выбран иной режим рисования маски.

Рис. 9.17. Две маски с различным режимом их рисования позволяют сформировать альфа-канал с двумя прозрачными фрагментами

2. Командой Layer>Mask>Mode (Слой>Маска>Режим) вызовите подменю режимов рисования выделенной маски (рис. 9.18).

Рис. 9.18. Выбор режима рисования маски

3. Измените режим с типа Add (Сложение) на тип Subsract (Вычитание), а затем командой Layer>Mask>Inverse (Слой>Маска>Инверсная) инвертируйте маску. Вы увидите, что взаимодействие маски и слоя изменится на состояние, приведенное на рис. 9.17.

4. Вновь совместите маски на кадре так, чтобы они частично перекрывались. Поэкспериментируйте с режимами рисования каждой из масок и посмотрите, как они влияют на настройку наложения слоев друг на друга.


9.2.4. Прозрачность и расширение масок

До сих пор мы рисовали исключительно прозрачные маски, т. е. с их помощью задавали разметку прозрачности слоя в градации абсолютно прозрачный — абсолютно непрозрачный (сплошной). Разумеется, для любой маски можно установить и промежуточную степень прозрачности, которая измеряется в процентах (от 0% — совершенно прозрачной маски, до 100% — совершенно сплошной).

1. Выделите одну из масок.

2. Командой Layer>Mask>Mask Opacity (Слой>Маска>Непрозрачность маски) вызовите диалоговое окно для определения степени прозрачности (рис. 9.19).

3. Выберите желаемое значение прозрачности и нажмите в диалоге кнопку ОК

Рис. 9.19. Настройка прозрачности маски

Не забывайте о том, что параметр измеряется в процентах непрозрачности маски, т. е. описывает, насколько сплошным должен быть маскируемый слой.

Примечание

Кроме возможности задавать прозрачность маски численно в диалоговом окне, имеется возможность настроить ее визуально, при помощи вложенного параметра Mask Opacity (Непрозрачность маски) в окне Timeline (Монтаж).

Помимо возможности назначения того или иного процента прозрачности, маски могут быть продолжены за пределы их границ с применением одного из двух спецэффектов, которые называются расширением (expansion) и "оперением"(feather). Покажем, как это делается:

1. Выделите нужную маску в окне Timeline (Монтаж).

2. В верхнем меню выберите Layer>Mask>Mask Expansion (Слой>Маска> Расширение маски) и в появившемся диалоговом окне задайте (в пикселах) ширину дополнительной области расширения маски за границы своего обрамления (рис. 9.20).

Рис. 9.20. Эффект расширения маски

3. Для задания эффекта "оперения" выберите в верхнем меню Layer> Mask>Mask Feather (Слой>Маска>Оперение маски), и в открывшемся диалоге введите (в пикселах) размеры "оперения", т. е. характерного градиентного перехода маски за свои границы по вертикали и по горизонтали (рис. 9.21).

Рис. 9.21. Эффект "оперения" маски


9.2.5. Удаление масок

Маска слоя в After Effects удаляется точно так же, как и сам слой (или любой другой элемент слоя). Для того чтобы удалить маску (или несколько масок):

1. Выделите нужную маску или несколько масок.

2. Нажмите клавишу <BackSpace>.

Можно действовать и через меню, выбирая, соответственно, для удаления выделенной маски пункт Layer>Mask>Remove Mask (Слой>Маска>Удалить маску), или для моментального удаления всех масок Layer>Mask>Remove All Masks (Слой>Маска>Удалить все маски).


9.3. Маски Безье

Пока мы говорили о рисовании на слоях альфа-масок правильной формы для задания режима их прозрачности. Однако очень часто требуется определить маску произвольной формы, которая будет содержать и прямые, и кривые плавные линии. Для создания масок неправильной формы в After Effects применяются специальные средства рисования сложных фигур, называемые фигурами Безье. Фигуры Безье состоят из вершин, или узлов (vertex), которые отмечаются на изображении кадра маркерами, и соединяющих их прямых или плавных линий (называемых сегментами). Фигуры Безье характеризуются возможностью гибкого изменения своей формы в зависимости от действий пользователя не только относительно перетаскивания узлов и сегментов, но также и дополнительных управляющих линий, которыми снабжены узлы.

Фигуры Безье рассчитываются, исходя из перемещения пользователем их маркеров и управляющих линий, по весьма сложным математическим алгоритмам (предложенным в свое время Безье — сотрудником одного из французских автомобильных концернов). При работе с фигурами Безье гораздо важнее представлять (хотя бы на интуитивном уровне), как действия пользователя будут влиять на форму этих фигур, нежели разбираться в сложных аспектах их расчетов. Поэтому мы настоятельно советуем читателю поэкспериментировать с созданием нескольких кривых Безье в качестве тестов, чтобы обучиться их свойствам.

Для рисования масок Безье следует использовать серию инструментов Реn (Перо), сгруппированных в одной кнопке палитры Tools (Инструментарий) (рис. 9.22). Она включает в себя:

  • Реn (Перо) — предназначен как для рисования новой фигуры Безье, так и для редактирования существующей;
  • Add vertex (Добавить вершину) — добавляет новую вершину на существующую фигуру Безье;
  • Delete vertex (Удалить вершину) — удаляет одну из существующих вершин с фигуры Безье (при щелчке на этой вершине);
  • Convert vertex (Преобразовать вершину) — предназначен для преобразования типа вершины (угла пересечения прямых или плавных линий).

Рис. 9.22. Выбор инструмента для рисования маски Безье


9.3.1. Рисование масок Безье

Рассмотрим основные приемы рисования масок произвольной формы на основе алгоритма Безье.

1. Выберите инструмент Реn (Перо) (см. рис. 9.22).

2. Щелкните в том месте кадра слоя, в котором вы собираетесь создать первую вершину маски. В результате эта вершина, отмеченная маркером выделения, возникнет в данном месте. Она будет снабжена управляющей линией, которая, в свою очередь имеет два собственных, более мелких, маркера.

3. Для рисования отрезка прямой линии маски Безье достаточно добавить еще одну вершину в желаемой точке кадра. Для этого щелкните в нужном месте инструментом Реn (Перо). Каждый новый щелчок вне уже существующих линий маски Безье добавляет новую вершину, соединенную с предыдущей вершиной отрезком прямой (рис. 9.23).

Рис. 9.23. Рисование отрезков прямых линий на маске Безье производится при помощи добавления вершин инструментом Реn

4. Для того чтобы нарисовать сглаженную кривую в качестве следующего сегмента маски Безье следует вначале нажать кнопку мыши, когда перо находится в том месте кадра, где вы хотите добавить вершину, а затем применить технику протаскивания инструмента Реп. Нарисуйте таким образом следующий участок маски Безье, отпуская кнопку мыши в том месте, где вы хотите закончить плавный сегмент и создать новую вершину (рис. 9.24).

Рис. 9.24. Рисование плавных кривых участков масок Безье производится с помощью протаскивания инструмента Реп по соответствующей траектории

5. Чтобы создать замкнутую маску Безье, необходимо щелкнуть инструментом Реn (Перо) в подходящем месте уже существующего сегмента маски Безье. О том, что маску Безье можно замкнуть, After Effects сигнализирует появлением маленькой окружности возле инструмента Реn (Перо) (рис. 9.25).

Рис. 9.25. Замыкание маски Безье


9.3.2. Редактирование масок Безье

Маски, созданные инструментом Реn (Перо), редактируются при помощи этого же инструмента, либо инструмента Selection (Выбор). При этом пользователю предлагаются следующие возможности:

  • если выделить маску Безье инструментом Selection (Выбор) при нажатой клавише <Alt>, то затем ее можно перетаскивать вдоль слоя как единое целое так же, как мы это делали с масками обычной формы (см. разд. 9.2);
  • перетаскивая инструментом Selection (Выбор) маркеры вершин и сегменты маски Безье, можно менять их положение, т. е. менять форму маски (рис. 9.26). Этот тип редактирования фигур Безье аналогичен редактированию обычных примитивов в стандартных графических программах;

Рис. 9.26. Передвигать на новое место сегменты и вершины существующей маски Безье следует инструментом Selection

  • добавить новые маркеры (т. е. вершины) маски Безье можно либо при помощи стандартного инструмента Реn (Перо), либо инструмента Add vertex (Добавить вершину). При наведении инструмента Реn (Перо) на любое место контура маски Безье он автоматически изменяется на инструмент Add vertex (Добавить вершину) (рис. 9.27). Последующий щелчок в этом месте маски создаст на ней новую вершину;

Рис. 9.27. Создание дополнительной вершины существующей маски Безье производится инструментом Реn

  • если навести инструмент Реn (Перо) на любую из вершин маски Безье, то он поменяет свою форму на пиктограмму Delete vertex (Удалить вершину), и эту вершину можно будет удалить из маски Безье (рис. 9.28, 9.29). То же самое действие можно выполнить и специально предназначенным для этого инструментом Delete vertex (Удалить вершину);

Рис. 9.28. Удалить существующие вершины маски Безье можно инструментом Реn

Рис. 9.29. Результат удаления вершины маски

  • изменить характер вершины маски Безье (поменяв прямые линии на плавные, и наоборот) можно инструментом Convert vertex (Преобразовать вершину) (рис. 9.30, 9.31);

Рис. 9.30. Для преобразования типа вершины необходим инструмент Convert vertex

Рис. 9.31. Результат преобразования типа вершины маски

  • подгонять желаемую форму сегментов маски Безье можно при помощи перетаскивания управляющих линий (рис. 9.32). Для этого используется как инструмент Pen (Перо), так и инструмент Selection (Выбор). Поэкспериментируйте с перемещением маркеров управляющих линий, и вы сразу почувствуете, как они влияют на форму и размер масок Безье.

Рис. 9.32. Редактирование формы маски Безье при помощи перетаскивания управляющих линий


9.3.3. О других способах создания масок

Мы рассказали о способах рисования альфа-масок от руки при помощи специальных инструментов. Однако существуют и другие способы определения масок, на которых мы не станем останавливаться, но все-таки упомянем, надеясь, что, в случае надобности, читатель сам найдет соответствующую ссылку в справочном руководстве. Вот некоторые способы:

  • создание новой прямоугольной маски, размер которой будет совпадать с размером кадра композиции, посредством команды меню Layer>Mask> New Mask (Слой>Маска>Создать маску);
  • задание типа и размера маски численно в специальном диалоговом окне Mask Shape (Форма маски), которое можно вызвать командой Layer>Mask>Mask Shape (Слой>Маска>Форма маски) (рис. 9.33);
  • копирование контура маски с другого слоя или из другого приложения, например, Adobe Illustrator или Adobe Photoshop;
  • конвертация альфа-канала исходного клипа (подобно рассмотренному в разд. 9.1) при помощи команды Layer>Auto-trace (Слой>Авто-трассировка);
  • конвертация текстового слоя в маску посредством команды Layer>Create Outlines (Слой>Создать разметку).

Рис. 9.33. Параметры маски можно задать в диалоге Mask Shape


9.4. Слои-маски

Наиболее часто для настройки прозрачности используются альфа-маски, рассмотренные в двух предыдущих разделах. Однако иногда достичь финальной цели монтажа композиции бывает удобнее при помощи других средств реализации прозрачных наложений.


9.4.1. Маскировка слоя другим слоем

Произвести разметку прозрачности слоя можно не только назначая ему определенную альфа-маску, но и используя другой слой композиции в качестве шаблона прозрачности. Повторимся, что слой, определяющий прозрачность другого слоя, называется маскирующим слоем или слоем-маской.

Разберем технику маскировки одного слоя другим на конкретном примере. Будем использовать в качестве маскирующего слоя предварительно заготовленный видеоклип mask.mov, коллаж из трех кадров которого показан на рис. 9.34 (на черном фоне происходит уменьшение в размерах светло-серого круга).

Рис. 9.34. Модельный видеоклип mask.mov мы будем использовать в качестве слоя-маски для другого клипа (коллаж трех кадров клипа)

Примечание

Исходный видеофайл mask.mov был создан средствами After Effects. Принцип монтажа такой композиции, полученной путем анимации альфа-маски серого слоя, будет рассмотрен нами в следующих главах (см. урок 10).

Взаимодействие нижнего слоя со слоем-маской организовано в After Effects на основе двух возможных свойств последнего:

  • в качестве канала прозрачности используется альфа-канал слоя-маски (если он имеется);
  • разметка прозрачности слоя-маски производится в соответствии с его яркостью (т. е. более светлые пикселы делаются более прозрачными, а темные — менее прозрачными, или наоборот).

Будем считать, что наш исходный файл mask.mov не содержит альфа-канала, поэтому используем распределение его яркости по пространству кадра. Сделаем светлые круговые участки клипа более прозрачными, а черные — сплошными (см. рис. 9.34).

Покажем, как производится маскировка одного слоя другим. В нашем примере частично прозрачным будет клип mask.mov, а нижним слоем будет видеоклип tolstoi.mov.

1. Расположите в окне Timeline (Монтаж) слой-маску непосредственно над тем слоем, который вы собираетесь маскировать (рис. 9.35).

2. Нажмите в окне Timeline (Монтаж) кнопку Switches/Modes (Переключатели/Режимы). Если эта кнопка скрыта, то вызвать ее на экран (вместе с одноименным столбцом) можно нажатием кнопки, на которую наведен указатель мыши на рис. 9.35.

3. В выпадающем списке TrkMat (Слои-маски) выберите пункт Luma Matte (Маска яркости).

Рис. 9.35. Начните настройку слоя-маски с его размещения непосредственно над маскируемым слоем

После этого верхний слой будет распознаваться After Effects не в качестве обычного слоя (как это было на рис. 9.36), а в качестве маски прозрачности для слоя, находящегося под ним. Об этом будут говорить соответствующие пиктограммы слева от названия слоя в окне Timeline (Монтаж) (рис. 9.37, 9.38). Обратите внимание на то, что изображение слоя-маски автоматически выключается (пиктограмма в виде глаза для этого слоя отсутствует).

Рис. 9.36. Вместо типа No Track Matte выберите желаемый тип слоя-маски

Рис. 9.37. After Effects автоматически преобразует верхний слой в канал прозрачности слоя, для которого вы определили его как слой-маску

Рис. 9.38. Один из последующих кадров композиции показывает взаимодействие маскируемого нижнего слоя с верхним слоем-маской

Вообще говоря, имеется несколько опций настройки прозрачности маскирующего слоя, которые можно выбрать в выпадающем списке TrkMat (Слои-маски):

  • No Track Matte (Без маски) — режим прозрачности выключен; слой сверху является обычным слоем;
  • Alpha Matte (Альфа-маска) — сплошные участки маскируемого слоя будут совпадать с пикселами слоя-маски, где значение его альфа-канала составляет 100%;
  • Alpha Inverted Matte (Инверсная альфа-маска) — сплошная, где альфа-канал слоя-маски составляет 0%;
  • Luma Matte (Маска яркости) — сплошная при 100%-й яркости слоя-маски;
  • Luma Inverted Matte (Инверсная маска яркости) — сплошная при нулевой яркости слоя-маски

Совет

Используя в качестве слоя-маски подходящие видеоклипы, можно осуществить довольно необычные эффекты совмещения в кадре композиции двух видеороликов.


9.4.2. О прозрачных наложениях

Последний тип настройки прозрачности, о котором мы хотели сказать, — это так называемые прозрачные наложения (key) и режимы прозрачности (mode). Этот тип прозрачности позволяет, в зависимости от определенных свойств изображения слоя, назначить тем или иным пикселам определенный процент прозрачности. В частности, можно сделать более прозрачными пикселы определенного цвета или цветового диапазона, яркости или диапазона яркости или т. п.

Рассмотрим наиболее простой способ настройки смешения изображения слоев, задаваемый с помощью режима прозрачности, который определяет алгоритм смешения изображения данного слоя с нижними слоями. В качестве примера будем использовать композицию, составленную из двух слоев, расположенных один над другим (рис. 9.39). Назначив соответствующий режим верхнему слою, настроим их наложение.

Рис. 9.39. Пример двух слоев с отключенным режимом прозрачности

1. Вызовите на экран столбец Modes (Режимы) окна Timeline (Монтаж). Если эта кнопка скрыта, то вызвать ее на экран (вместе с одноименным столбцом) можно нажатием кнопки Switches/Modes (Переключатели/ Режимы), либо, если такой кнопки нет, то можно воспользоваться подменю Columns (Столбцы) в окне Timeline (Монтаж).

2. В выпадающем списке Mode (Режим) выберите желаемый режим прозрачности (рис. 9.40, 9.41).

Рис. 9.40. Режим прозрачности слоя назначается при помощи выпадающего списка Mode

Рис. 9.41. Для слоя plane.bmp выбран режим Multiply

Как вы видите из рис. 9.41, режим Multiply (Умножение) позволяет достичь желаемого результата: белый фон верхнего слоя plane.bmp становится прозрачным.

В After Effects прозрачные наложения настраиваются как стандартные эффекты (effects), поэтому будем иметь в виду, что управление ими аналогично управлению другими эффектами слоев (см. урок 11). Тем не менее, несколько забегая вперед, конспективно покажем, как можно определить прозрачность слоя при помощи эффекта группы Keying (Прозрачное наложение). Не забудьте перед тем, как применять эффект, вернуть обычный режим прозрачности Normal (Обычный).

1. Выделите желаемый слой в окне Timeline (Монтаж) (в нашем случае, верхний слой plane.bmp).

2. Вызовите на экран палитру Effects (Эффекты) при помощи верхнего меню Window (Окно).

3. В палитре Effects (Эффекты) раскройте папку Keying (Прозрачные наложения) (рис. 9.42).

Рис. 9.42. Для настройки прозрачного наложения воспользуйтесь эффектами типа Keying из палитры Effects

4. Дважды щелкните на нужном вам эффекте наложения, например, на подходящем в нашем случае эффекте Color Key (Прозрачность цвета), который делает прозрачным некоторый диапазон цветов слоя.

5. Отрегулируйте параметры эффекта при помощи появившейся палитры Effect Controls (Управление эффектом) (рис. 9.43), в частности, определив желаемый прозрачный цвет (в нашем случае — белый цвет).

Рис. 9.43. После назначения эффекта прозрачного наложения отрегулируйте его параметры в палитре Effect Controls


9.5. Резюме

Редактирование прозрачности слоев и редактирование их наложений осуществляются несколькими способами:

  • регулировка параметра Opacity (Непрозрачность) в окне Timeline (Монтаж) для определения степени прозрачности слоя, как единого целого;
  • настройка для слоя композиции After Effects своего собственного альфа-канала при помощи рисования масок слоев соответствующими инструментами;
  • определение в качестве канала прозрачности слоя другого слоя композиции, называемого маскирующим;
  • выбор режима прозрачности слоя при помощи столбца Modes (Режимы) окна Timeline (Монтаж);
  • настройка одного из эффектов прозрачного наложения;
  • использование альфа-канала самого исходного файла.


Урок 10. Анимация

  • На этом уроке...
  • 10.1. Создание ключевых кадров анимации
    • 10.1.1. Создание первого ключевого кадра
    • 10.1.2. Создание последующих ключевых кадров
  • 10.2. Редактирование ключевых кадров анимации
    • 10.2.1. Выделение ключевых кадров
    • 10.2.2. Переходы между ключевыми кадрами
    • 10.2.3. Удаление ключевого кадра
    • 10.2.4. Регулировка параметров слоя на ключевых кадрах
    • 10.2.5. Смещение ключевого кадра во времени
    • 10.2.6. О тонкой регулировке анимации
  • 10.3. Основные типы анимации
    • 10.3.1. Параметры группы Transform
    • 10.3.2. Настройка движения слоя
    • 10.3.3. Анимация масштабирования и вращения слоя
    • 10.3.4. Анимация других параметров
  • 10.4. Настройка скорости анимации
  • 10.5. Резюме


На этом уроке...

На этом уроке мы расскажем о том, как в After Effects осуществляется анимация слоев. При помощи встроенных средств этой программы можно задавать как движение слоев по кадрам композиции, так и динамическое изменение самых разных параметров слоя (таких, как его размер, прозрачность и т. д.).

  • Чего мы хотим:

  • научиться настраивать анимацию слоев при помощи техники ключевых кадров;
  • создать композицию, которая будет содержать динамически изменяющийся в размерах и перемещающийся по экрану кадр некоторого клипа (т. е. слоя композиции).

  • Нам потребуется:

  • один видеофайл и один или два графических файла.

  • Что полезно вспомнить:

  • как устроена иерархия слоев и их параметров в окне Timeline (Монтаж) и как работают специфические элементы интерфейса — выпадающие списки (см. урок 4).


10.1. Создание ключевых кадров анимации

Переходя к теме создания эффектов анимации, первое, о чем стоит сказать, это приложение анимации к определенным слоям. Иными словами, слой — это тот объект, которому назначается определенный эффект анимации, и для каждого отдельного слоя анимация настраивается отдельно от других слоев.

В After Effects, как и в большинстве других видеоредакторов, настройка анимации организована посредством технологии ключевых кадров (keyframes). Она подразумевает выделение из всего множества кадров фильма определенных кадров, называемых ключевыми, для которых пользователь явно определяет значения некоторых параметров композиции, изменение которых во времени и создает эффект анимации. Следует оговориться, что ключевыми кадры являются по отношению к тем параметрам слоя, для которых назначены изменения. Для других параметров те же кадры являются совершенно обычными.

В промежутках между ключевыми кадрами программа осуществляет автоматическую интерполяцию меняющегося параметра (по заложенному в нее алгоритму), обеспечивая плавность изменения при переходе от одного ключевого кадра к другому и, соответственно, качество эффекта анимации.

Чтобы принцип анимации на основе ключевых кадров был более понятным, сразу обратимся к конкретному примеру и создадим композицию, которая будет содержать некоторый видеоклип, размер которого изменяется, начиная с полного размера кадра и заканчивая маленьким прямоугольником (рис. 10.1).

Рис. 10.1. Пример анимации (коллаж трех кадров композиции)

Клип возьмем из исходного видеофайла, а размер кадра композиции выберем таким же, что и размер кадра видеоклипа (рис. 10.2).

Рис. 10.2. Начинайте настройку анимации с раскрытия вложенного списка слоя, содержащего желаемый параметр

Попробуем настроить композицию таким образом, чтобы, начиная с ее 3-й секунды, размер кадра слоя tolstoi.mov начинал плавно уменьшаться и достиг своего минимального размера на последнем кадре композиции. Для этого нам потребуется определить два ключевых кадра: один на 3-й секунде, т. е. 0:00:02:00, а второй — в конце слоя. После того как мы это сделаем, динамика изменения размера слоя на всех остальных кадрах будет добавлена автоматически.


10.1.1. Создание первого ключевого кадра

Мы начнем настраивать анимацию с последнего кадра композиции.

1. Установите линию редактирования на кадр, который вы собираетесь сделать ключевым, в нашем случае — последний кадр слоя.

2. В окне Timeline (Монтаж) раскройте вложенный список атрибутов слоя и отыщите в нем нужный параметр, на основе которого вы собираетесь назначить слою анимацию. В нашем случае это параметр Scale (Масштаб), позволяющий уменьшить или увеличить размер изображения слоя (рис. 10.2).

Как вы могли заметить, каждый параметр снабжен (слева от имени) маленькой пиктограммой в виде секундомера. Если секундомер и, вместе с ним, стрелка вложенного списка параметра неактивны, то это означает, что к данному параметру анимация не привязана, и его значение не изменяется на протяжении всей композиции. На рис. 10.2 все параметры имеют неактивные секундомеры, поскольку мы пока не назначали ни одному из них никаких эффектов анимации. Если для какого-либо параметра создать хотя бы один ключевой кадр, то секундомер становится активным, говоря о примененном эффекте анимации.

1. Щелкните на пиктограмме, изображающей секундомер, слева от параметра Scale (Масштаб) (рис. 10.3).

Рис. 10.3. Чтобы создать первый ключевой кадр, щелкните на секундомере нужного параметра слоя

2. После того как кнопка-стрелка параметра Scale (Масштаб) стала доступной, нажмите ее, т. е. раскройте содержимое этого параметра (рис. 10.3, 10.4).

Рис. 10.4. Вложенный список параметра слоя содержит графики изменения значения этого параметра, а также скорости изменения со временем

Вероятно, вы обратили внимание, что, во-первых, после щелчка на секундомере и сам секундомер, и стрелка выпадающего списка слева от него станут активными (рис. 10.3). Во-вторых, пересечение линии редактирования и строки параметра Scale (Масштаб) будет отмечено характерным ромбом, говорящим о том, что данный кадр является ключевым. И, наконец, в-третьих, в строке параметра Scale (Масштаб) в левой части окна Timeline (Монтаж) появится новый элемент интерфейса, называемый навигатором ключевых кадров. При создании первого ключевого кадра навигатор содержит только один флажок проверки, активное состояние которого как раз и говорит о том, что текущий кадр является ключевым. Если ключевых кадров будет больше, чем один, то навигатор будет содержать также дополнительные кнопки, позволяющие переходить к предыдущему или следующему ключевому кадру в композиции.

Раскрытый список параметра включает в себя график его изменения на протяжении композиции, относительно шкалы времени. Пока мы не изменяли значение параметра, данный график представляет собой горизонтальную, прямую линию, говорящую о том, что значение параметра остается постоянным от начала до конца слоя. Под графиком зависимости самого параметра от времени приводится дополнительный график скорости его изменения, дающий вспомогательную информацию, которая позволяет лучше ориентироваться в настройке анимации. Пока значение скорости на нижнем графике также является постоянным и равным нулю (поскольку сам параметр не меняется, скорость его изменения, очевидно, нулевая).

Исключительно важным является тот факт, что значение параметра на графике задается в относительном виде и отсчитывается от того значения, которое было ему присвоено при его возникновении. Поскольку при создании слоя мы определили его размер равным размеру кадра композиции, то именно это значение и берется в качестве начального отсчета. Теперь следует поменять значение параметра на данном ключевом кадре.

Определите для данного ключевого кадра относительное изменение параметра, для чего схватитесь за появившийся маркер значения параметра Scale (Масштаб) под временной шкалой (на рис. 10.4 на него наведен указатель мыши) и перетащите его вверх или вниз (соответственно, для увеличения или уменьшения значения параметра). В нашем случае следует перетаскивать маркер вниз.

После этого вы увидите, что, во-первых, размер кадра слоя в окне Composition (Композиция) будет масштабирован и, во-вторых, график значения параметра Scale (Масштаб) опустится вниз, в соответствии с уменьшенным значением параметра на ключевом кадре (рис. 10.5).

Рис. 10.5. Результат масштабирования слоя на ключевом кадре


10.1.2. Создание последующих ключевых кадров

Подобным способом теперь следует определить остальные ключевые кадры, задав для них желаемые значения параметра. В нашем случае это означает переход к кадру 0:00:02:00, пометка его в качестве ключевого кадра и задание уровня параметра 100%, т. е. определение полного размера кадра. Поскольку добавлять ключевой кадр мы собираемся параметру, для которого уже настраивалась анимация, то действовать следует несколько иначе.

1. Установите линию редактирования на желаемый кадр, т. е. 0:00:02:00.

2. Выставьте флажок проверки на навигаторе ключевых кадров. Это сразу сделает обычный кадр ключевым, о чем можно будет судить по появившейся пиктограмме в виде ромба.

3. Перетаскиванием появившегося маркера значения параметра Scale (Масштаб) выберите желаемый размер кадра слоя (рис. 10.6).

Рис. 10.6. Для каждого ключевого кадра выберите относительное значение параметра

4. Просмотрите кадры композиции, оценив качество анимации (см. рис. 10.1), и при желании отредактируйте ключевые кадры и/или настройте анимацию для других параметров.

Примечание

Можно было действовать иначе, определив сначала этот первый ключевой кадр, не меняя значения параметра размера, а затем уже определить второй ключевой кадр, задав для него уменьшенное значение этого параметра. Так мы бы слегка сократили объем работы по настройке анимации.

Таким образом, After Effects автоматически вычислит значения параметров на всех промежуточных кадрах, чтобы обеспечить его плавное изменение до заданного значения ключевого кадра. График изменения параметра Scale (Масштаб) вы можете видеть в окне Timeline (Монтаж), когда вложенный список данного параметра раскрыт.

Отметим, что если вы назначаете анимацию не для одного, а одновременно для нескольких параметров, то рендеринг кадров композиции будет осуществляться программой с учетом всех имеющихся анимаций. Конечно, на расчет изображений кадров композиции будет затрачиваться дополнительное время.


10.2. Редактирование ключевых кадров анимации

Рассмотрим теперь, как осуществляется редактирование анимации, т. е. какими способами можно управлять уже созданными ключевыми кадрами.


10.2.1. Выделение ключевых кадров

Для того чтобы что-то сделать с имеющимися ключевыми кадрами, их необходимо предварительно выделить. Последующее редактирование, как правило, затрагивает все выделенные ключевые кадры.

Чтобы выделить отдельный ключевой кадр, необходимо выполнить следующие действия.

1. Если слой выделен, снимите выделение со строки параметра слоя (щелчком за его пределами).

2. Щелкните на ромбовидной пиктограмме ключевого кадра. В результате ромб приобретет характерное выделение (рис. 10.7).

Рис. 10.7. Левый ключевой кадр выделен

Чтобы выделить несколько ключевых кадров одновременно, используйте при щелчках на последующих маркерах удержание клавиши <Shift>, как и в остальных случаях при выделении нескольких объектов. Если выделить несколько ключевых кадров, то дальнейшие действия по их редактированию будут производиться синхронно над всеми этими кадрами (например, перемещение маркеров ключевых кадров влево или вправо по композиции).

Для выделения всех ключевых кадров достаточно выделить сам параметр, т. е. в нашем случае строку Scale (Масштаб) в окне Timeline (Монтаж) (рис. 10.8).

Рис. 10.8. Выделены все ключевые кадры параметра Scale


10.2.2. Переходы между ключевыми кадрами

Работу по настройке анимации очень сильно облегчает возможность навигации по ключевым кадрам. Когда графики того или иного параметра развернуты, слева от их названий отображается несколько элементов управления (флажок проверки и треугольные кнопки по бокам от него), которые называются навигатором ключевых кадров (рис. 10.9).

Примечание

Если в окне Timeline (Монтаж) присутствует столбец Keys (Ключевые кадры), то навигатор ключевых кадров располагается в этом столбце.

Для того чтобы быстро перейти к следующему (или предыдущему) ключевому кадру в окне Timeline (Монтаж), достаточно просто щелкнуть на правой (или, соответственно, левой) кнопке навигатора. По состоянию флажка проверки легко судить, является ли текущий кадр ключевым (что неочевидно для кадров, находящихся в малой окрестности ключевого кадра). Так, на рис. 10.9 линия редактирования находится на ключевом кадре параметра Scale (Масштаб) и на обычном кадре параметра Rotation (Вращение).

Рис. 10.9. Навигатор ключевых кадров позволяет быстро "листать" ключевые кадры


10.2.3. Удаление ключевого кадра

Для удаления ключевого кадра достаточно выделить его и либо нажать затем клавишу <BackSpace>, либо снять флажок проверки на навигаторе ключевых кадров.

Щелчок на пиктограмме-секундомере параметра с ранее настроенной анимацией удалит ее безвозвратно (конечно, можно только отменить удаление как последнее действие при помощи сочетания клавиш <Ctrl>+<Z>). Таким образом, для удаления всех ключевых кадров достаточно щелкнуть на секундомере слева от имени нужного параметра.


10.2.4. Регулировка параметров слоя на ключевых кадрах

Для регулировки параметра громкости на уже созданном ранее маркере ключевого кадра есть несколько способов:

  • просто подведите к маркеру на графике указатель мыши и перетащите его вверх или вниз (как при создании ключевого кадра);

Примечание

Если начать изменение параметра регулятором на обычном (не ключевом) кадре слоя, то этот кадр автоматически становится ключевым. Таким образом, это еще один способ добавить ключевые кадры слоя.

  • для более точного определения значений параметров слоя на ключевых кадрах можно использовать соответствующие числовые регуляторы параметра, находящиеся в столбце Switches (Переключатели) окна Timeline (Монтаж). Как и в других регуляторах, можно при помощи перетаскивания линии подчеркивания влево или вправо уменьшать и увеличивать значение параметра на текущем ключевом кадре (рис. 10.10);

Рис. 10.10. Менять значение параметра на ключевых кадрах можно при помощи соответствующего регулятора в окне Timeline

Примечание 1

Еще два регулятора, присутствующие под строкой с именем каждого параметра (на уровне графика) задают масштаб представления и начальный отсчет этого графика (рис. 10.11). Устанавливая верхний и нижний регуляторы в новое значение, вы не меняете сам параметр, а подбираете удобный масштаб графика и значение параметра его нижней границы соответственно. То же самое касается и графика скорости параметра (два регулятора слева от него задают масштаб скорости и ее начальный отсчет).

Рис. 10.11. Два регулятора слева от каждого графика задают его масштаб (верхний регулятор) и начальный отсчет (нижний)

Примечание 2

Многие параметры, в частности, рассматриваемое свойство слоя Scale (Масштаб), допускают регулировку двух характерных величин одновременно. Для свойства Scale (Масштаб) это горизонтальный и вертикальный размеры кадра. Значок синхронизации (он есть на рис. 10.10, 10.11, а на рис. 10.12 он снят) говорит о сохранении пропорций изменяемых характеристик (в данном случае — размеров кадра). Если снять значок синхронизации, то их можно изменять раздельно, и, соответственно, оперировать с двумя графиками: масштабом кадра по горизонтали и по вертикали.

Рис. 10.12. Многие параметры допускают раздельную регулировку разных характеристик

  • задать параметр можно и численно, вводя его с клавиатуры. Для этого предварительно следует вызвать командой контекстного меню Edit Value (Редактировать значение) соответствующий диалог (рис. 10.13). Замечательно то, что в данном диалоге можно определить не только относительное значение параметра (в процентах), но и его абсолютную величину (для параметра Scale (Масштаб) — в пикселах);

Рис. 10.13. В диалоге редактирования величины параметра можно определить как его относительное, так и абсолютное значение

  • чтобы, на промежутке между некоторыми ключевыми кадрами, "заморозить" значение определенного параметра, следует выделить левый ключевой кадр и выбрать команду верхнего меню Animation>Toggle Hold Keyframe (Анимация>Удержание ключевого кадра). Тогда будет включена опция удержания постоянного значения параметра текущего ключевого кадра до следующего ключевого кадра. Важно отметить то, что повторный ввод данной команды выключает удержание значения параметра ключевого кадра и возвращает его к прежним установкам;
  • наконец, помимо возможности настройки анимации в окне Timeline (Монтаж), определенные значения параметров на ключевых кадрах можно задать и в окне Composition (Композиция). В нашем случае (рис. 10.14) достаточно осуществить инструментом Selection (Выбор) масштабирование изображения слоя в окне Composition (Композиция) на ключевом кадре (для его редактирования) или на обычном кадре (для его превращения в ключевой). Для регулировки других параметров, например, угла поворота слоя на ключевом кадре, следует вращать его инструментом Rotation (Вращение).

Рис. 10.14. Редактировать ключевые кадры можно и в окне Composition


10.2.5. Смещение ключевого кадра во времени

Для того чтобы перенести ключевой кадр анимации с одного кадра композиции на другой (влево или вправо вдоль шкалы времени) просто перетащите его указателем мыши (влево или вправо соответственно).


10.2.6.О тонкой регулировке анимации

Помимо описанных приемов настройки анимации при помощи ключевых кадров, имеется возможность осуществлять тонкую регулировку, например, такую, как выбор алгоритма интерполяции между ключевыми кадрами, прецизионное задание динамики скорости изменения параметра и др. Некоторые из этих опций будут рассмотрены ниже (см. разд. 10.4), а с большинством из них (учитывая то, что они адресованы профессиональным пользователям) читатель может ознакомиться в справочном руководстве After Effects.


10.3. Основные типы анимации

В предыдущих разделах мы познакомились с техникой анимации на основе ключевых кадров и выяснили, что главным ее принципом является регулировка доступных параметров слоев относительно шкалы времени. Остановимся кратко на основных параметрах, определяющих состояние слоя, и, соответственно, использующихся в настройке анимации. Напомним, что просмотреть текущее значение каждого параметра можно в столбце Switches/Modes (Переключатели/Режимы) окна Timeline (Монтаж) (рис. 10.15) либо в специальных диалоговых окнах (см. рис. 10.13), которые открываются при помощи контекстного меню, вызываемого на имени параметра в окне Timeline (Монтаж) посредством команды Edit Value (Редактировать значение).

Рис. 10.15. Параметры группы Transform (указатель наведен на точку привязки в окне Composition)


10.3.1. Параметры группы Transform

Перечислим параметры, которые размещаются в группе Transform (Преобразование):

  • Anchor point (Точка привязки) — задает выделенную невидимую точку (см. разд. 6.2) на слое, которая имеет ключевое значение при некоторых операциях (например, при повороте слоя точка привязки является центром вращения). Таким образом, передвижение точки привязки не влияет на внешний вид самого слоя, но играет определяющую роль при многих других действиях. Как и многие другие параметры, точка привязки характеризуется двумя числами — координатами по горизонтали и по вертикали. По умолчанию точка привязки помещается в центр изображения слоя, но ее можно перенести в любую другую точку (рис. 10.16);

Рис. 10.16. Анимация точки привязки

  • Position (Расположение) — параметр, определяющий положение слоя относительно кадра композиции и содержащий две координаты (горизонтальную и вертикальную). С помощью задания ключевых кадров этого параметра можно осуществить перемещение кадров слоя по кадру композиции. Если для некоторого слоя настроено его перемещение по композиции, то линия, по которой он будет перемещаться в кадре фильма, называемая траекторией, или путем его движения (motion path) показывается пунктиром в окне Composition (Композиция) (рис. 10.17);

Рис. 10.17. Анимация расположения слоя (коллаж двух кадров в окне Composition). Траектория движения слоя показана пунктиром

  • Scale (Масштаб) — задает увеличение или уменьшение размера кадра слоя. На рис. 10.18 изображены два кадра композиции, соответствующие одновременной анимации при помощи параметров расположения и масштабирования;

Рис. 10.18. Анимация масштабирования и перемещения слоя

  • Rotation (Вращение) — определяет поворот слоя вокруг точки привязки (рис. 10.19). Параметр задается в следующем формате — число переворотов на траектории, помноженное на угол поворота;

Рис. 10.19. Одновременная анимация вращения, масштабирования и перемещения слоя

  • Opacity (Непрозрачность) — задает динамическую прозрачность слоя (рис. 10.20).

Рис. 10.20. Анимация прозрачности слоя

Перечисленные параметры можно регулировать не только в окне Timeline (Монтаж), но также и визуальным способом на кадре композиции в окне Composition (Композиция). Приведем некоторые сведения о том, как редактируются в окне Composition (Композиция) данные параметры, на примере настройки анимации с рис. 10.16. Для этого вам предварительно следует расположить на двух слоях композиции два файла (в нашем примере это два графических файла — на нижнем слое Rockies.tif, а на верхнем — ufo.bmp). Верхний слой представляет собой статический клип уменьшенного (по сравнению с кадром композиции) размера с рисунком летающей тарелки. Кроме того, для него назначена соответствующая маска, скрывающая части изображения за пределами тарелки (рис. 10.21).

Рис. 10.21. Для параметров маски слоя можно настроить анимацию аналогичным образом

Примечание

Параметры маски, которые находятся во вложенном списке Mask 1, также годятся для настройки анимации. Для любого из них можно создать ключевые кадры способом, описанным выше, и настроить анимацию. Например, можно настроить эффекты расширения или "оперения" маски (рис. 10.22).

Рис. 10.22. Анимация "оперения" маски


10.3.2. Настройка движения слоя

Создадим несколько ключевых кадров анимации слоя ufo.bmp для композиции, изображенной на рис. 10.22, так, чтобы результат нашей работы походил на рис. 10.19, т. е. использовал бы вращение, масштабирование и перемещение этого слоя.

1. Раскройте вложенный список Transform (Преобразование) параметров слоя ufo.bmp в окне Timeline (Монтаж). Обратите внимание, что весь слой приобретет выделение, в том числе и в окне Composition (Композиция).

2. Поместите линию редактирования на первый кадр композиции и щелкните на секундомере около параметра Position (Расположение). В результате первый кадр слоя станет ключевым (но значение параметра не изменится).

3. Перейдите на другой кадр слоя, который вы хотите сделать ключевым для создания движения слоя как единого целого.

4. Перетащите слой в окне Composition (Композиция) в его следующее положение. After Effects при этом отобразит траекторию движения слоя по кадру композиции в виде пунктира (рис. 10.23).

Рис. 10.23. Анимация перемещения слоя (в кадре отображается его траектория, соединяющая маркеры ключевых кадров)

5. При желании, если вы хотите определить траекторию движения слоя, состоящую из нескольких участков, повторите п. 3 и п. 4 для задания желаемого количества ключевых кадров.

После того как вы определили ключевые кадры для задания траектории перемещения слоя, их, во-первых, можно отредактировать перечисленными ранее способами (см. разд. 10.2), либо, во-вторых, изменить визуальным методом в окне Composition (Композиция). Чтобы продемонстрировать эти возможности, осуществим несколько действий по редактированию отрезка пути движения слоя ufo.bmp.

Примечание

Помните, что все действия по редактированию слоев, в том числе, по настройке их анимации, необходимо проводить, когда данный слой выделен. Самый надежный способ выделить нужный слой — щелкнуть на его имени в окне Timeline (Монтаж).

1. Чтобы изменить положение слоя на некотором ключевом кадре, сделайте этот кадр текущим и, схватившись инструментом Selection (Выбор) за выделенный слой, перетащите его на новое место в окне Composition (Композиция). Кроме того, можно просто перетаскивать маркеры, отмечающие ключевые кадры в окне Composition (Композиция), не теряя времени на установку на них линии редактирования.

2. Для того чтобы изменить форму траектории слоя, воспользуйтесь приемами редактирования кривых Безье (см. разд. 9.3). По умолчанию After Effects добавляет участки пути в виде отрезков прямых линий. Чтобы сделать их более плавными, воспользуйтесь управляющими линиями, которые появляются при выделении ключевого кадра (рис. 10.24).

Рис. 10.24. Чтобы придать траектории слоя желаемую форму, воспользуйтесь редактированием ее участков как кривых Безье

3. Выберите инструмент Реn (Перо) и добавьте маркеры ключевых кадров в желаемых местах траектории (рис. 10.25). В этом случае траектория автоматически будет нарисована кривыми Безье, и ее сразу при рисовании можно редактировать инструментом Реn (Перо).

Рис. 10.25. Траекторию слоя можно редактировать инструментом Реn


10.3.3. Анимация масштабирования и вращения слоя

Теперь обратимся к определению анимации на основе масштабирования слоя и его поворотов.

1. Сделайте текущим первый ключевой кадр и выделите для слоя параметр Scale (Масштаб) в окне Timeline (Монтаж). Создайте ключевой кадр в желаемом месте середины слоя, не меняя параметра Scale (Масштаб), установив для этого флажок проверки на навигаторе ключевых кадров.

2. Схватившись и перетащив маркер обрамления слоя в окне Composition (Композиция) инструментом Selection (Выбор), уменьшите его размер (рис. 10.26). Для того чтобы пропорции слоя были при масштабировании сохранены, удерживайте при этом нажатой клавишу <Shift>. Если вы хотите изменять размер изображения слоя малыми шагами (для его точной регулировки), держите нажатой при масштабировании слоя клавишу <Alt>.

Рис. 10.26. Масштабирование слоя на ключевом кадре

3. Если вы хотите задать и отражение слоя, перетащите один из маркеров его выделения, который соответствует направлению отражения, за точку привязки этого слоя (рис. 10.27). Помните, что отражение осуществляется относительно точки привязки, поэтому ее положение имеет значение (в частности, если она находится за пределами слоя, то в промежутке между ключевыми кадрами слой будет перемещаться по кадру композиции).

Рис. 10.27. Для настройки анимации с отражением слоя перетащите маркер выделения за точку привязки

4. Для того чтобы задать теперь вращение слоя, выделите в окне Timeline (Монтаж) параметр Rotation (Вращение), создайте, не меняя параметра, ключевой кадр на первом кадре слоя, а затем перейдите к желаемому кадру в середине слоя.

5. Выберите инструмент Rotation (Вращение) и перенесите указатель мыши на выделенное изображение слоя в окне Composition (Композиция).

6. Поверните изображение слоя в окне Composition (Композиция) на желаемый угол (рис. 10.28).

7. Если вы хотите, чтобы в промежутке между ключевыми кадрами слой совершал несколько переворотов (соотвественно, чтобы вращение стало более быстрым), установите желаемое значение числа оборотов на ключевом кадре в окне Timeline (Монтаж).

Рис. 10.28. Анимация поворота слоя настраивается при помощи инструмента Rotation


10.3.4. Анимация других параметров

Выше мы рассмотрели анимацию слоев при помощи параметров группы Transform (Преобразование). Как вы понимаете, это не единственная возможность создания эффекта анимации. Помимо данной группы параметров, можно использовать практически любой из параметров, которые появляются в окне Timeline (Монтаж) по мере монтажа композиций в After Effects, например, нарисованные линии или спецэффекты (рис. 10.29).

Рис. 10.29. Анимация масок и рисованных линий

В любом случае, техника настройки анимации остается той же. Во-первых, на заданных пользователем ключевых кадрах вводятся значения параметра, а, во-вторых, уже сама программа After Effects, осуществляя соответствующую интерполяцию на промежутках между ключевыми кадрами, создает эффект непрерывной и плавной анимации для всей продолжительности композиции.


10.4. Настройка скорости анимации

Помимо разобранных в предыдущих разделах этого урока принципов анимации, в After Effects имеется возможность прецизионного управления параметрами анимации. Рассмотрим некоторые из приемов тонкой настройки на примере анимации движения и масштабирования слоя (см. рис. 10.26).

Прежде всего, заметим, что до сих пор принцип расчета изображения слоя на промежутках между ключевыми кадрами был основан на (скрытой от глаз пользователя) линейной интерполяции значения того или иного параметра. Иными словами, на графике в окне Timeline (Монтаж) ключевые кадры соединялись между собой прямыми линиями. Соответственно, при добавлении новых ключевых кадров скорость изменения параметров назначалась постоянной.

Иногда этих обычных линейных настроек анимации бывает недостаточно, и возникает необходимость "подправить" график изменения параметра (и его скорости), чтобы анимация в более полной мере отвечала желаниям пользователя. В частности, если обратиться к настройке движения слоя (детально рассмотренной в предыдущем разделе), то может потребоваться, чтобы движение (между отдельными ключевыми кадрами) было не равномерным, а на одних промежутках ускоренным, а на других — замедленным. Таким образом, тип интерполяции практически эквивалентен алгоритму вычисления ее скорости.

Например, изменим динамику скорости перемещения слоя (летающей тарелки) с рис. 10.22 таким образом, чтобы в самом начале движения (пока изображение слоя очень маленькое) слой двигался медленно, но по мере перемещения и укрупнения до центрального ключевого кадра его скорость возрастала до максимума, а затем опять уменьшалась.

Для того чтобы изменить скорость, следует пользоваться графиком в окне Timeline (Монтаж).

1. Раскройте вложенный список параметра, для которого вы настраиваете анимацию в окне Timeline (Монтаж), чтобы появились графики его изменения. Если список уже раскрыт, убедитесь в том, что параметр выделен. Обратите внимание, что на графике скорости присутствуют управляющие линии, позволяющие редактировать их как кривые Безье.

2. Путем перетаскивания управляющих линий Безье на маркерах ключевых кадров отрегулируйте желаемым образом график зависимости скорости параметра от времени (на рис. 10.30 показан пример регулировки скорости перемещения слоя ufo.bmp). Обратите внимание на разное представление маркеров ключевых кадров, скорость которых задана линейным законом (как для параметра Scale (Масштаб)) или "нарисована от руки" кривыми Безье (параметр Position (Расположение)).

Рис. 10.30. Для регулировки скорости изменения параметра используйте управляющие линии кривых Безье

3. Так же отрегулируйте скорость изменения других параметров (например, параметра Scale (Масштаб)). Обратите внимание на то, что после регулировки скорости на графике изменения самого параметра также начинают отображаться управляющие линии кривых Безье, т. е. осуществлять подгонку интерполяции параметра между ключевыми кадрами можно уже при помощи любого из графиков (рис. 10.31).

Рис. 10.31. Закон интерполяции можно регулировать как на графике скорости, так и на графике изменения самого параметра

Помимо визуального задания графика изменения параметра между ключевыми кадрами, для опытных пользователей разработчиками After Effects предусмотрена возможность задания числовых значений интерполяционных коэффициентов.

Для каждого ключевого кадра имеется возможность, как выбрать закон интерполяции (линейный, Безье или другой), так и определить численно соответствующие характеристики, описывающие кривую интерполяции параметра. Проведем короткую экскурсию по этим опциям, чтобы продвинутые читатели смогли ими воспользоваться.

1. Выделите в окне Timeline (Монтаж) желаемый ключевой кадр параметра слоя.

2. Выберите в верхнем меню Animation>Keyframe Interpolation (Анимация> Интерполяция ключевого кадра).

3. В появившемся диалоговом окне Keyframe Interpolation (Интерполяция ключевого кадра) задайте алгоритм интерполяции. Обратите внимание, что для параметра расположения (рис. 10.32) имеется возможность задания как алгоритма интерполяции самой траектории на изображении кадра (верхний выпадающий список), так и алгоритма интерполяции скорости вдоль этой траектории (нижний список). Иными словами, можно выбрать линейную траекторию и плавное (в соответствии с алгоритмом Безье) изменение скорости вдоль этой траектории. Для других параметров выбор алгоритма относится только к закону их интерполяции между ключевыми кадрами.

Рис. 10.32. В диалоге Keyframe Interpolation можно задать алгоритм интерполяции

4. Командой верхнего меню Animation>Keyframe Velocity (Анимация>Скорость на ключевом кадре) вызовите одноименный диалог (рис. 10.33) и определите в нем числовые характеристики интерполяционной кривой слева (в левой части диалога) и справа (в его правой части) от ключевого кадра.

Рис. 10.33. Диалоговое окно Keyframe Velocity предназначено для выбора числовых характеристик интерполяции для выделенного ключевого кадра


10.5. Резюме

Анимация слоев настраивается в After Effects при помощи стандартной техники ключевых кадров. Принцип анимации заключается в задании пользователем значений тех или иных параметров на ключевых кадрах и в последующей интерполяции остальных значений параметра в промежутках между ключевыми кадрами программными средствами. В результате создается эффект непрерывной и плавной анимации слоев для всей продолжительности композиции.


Урок 11. Эффекты

  • На этом уроке...
  • 11.1. Об эффектах
    • 11.1.1 Создание эффектов
    • 11.1.2. Палитра Effects
    • 11.1.3. Палитра Effect Controls
  • 11.2. Редактирование эффектов
    • 11.2.1. Назначение эффекта клипу
    • 11.2.2. Изменение последовательности эффектов
    • 11.2.3. Временное выключение эффекта
    • 11.2.4. Удаление эффекта
    • 11.2.5. Настройка эффектов
    • 11.2.6. Регулировочный слой
    • 11.2.7. Типы эффектов
  • 11.3. Динамические эффекты
  • 11.4. Пространственные эффекты
    • 11.4.1. Назначение эффекта трехмерному слою
    • 11.4.2. Эффект Camera
    • 11.4.3. Эффект Light
  • 11.5. Резюме


На этом уроке...

Урок посвящен вопросам создания спецэффектов, изменяющих исходное изображение слоев и, во многом, составляющих основное достоинство обработки видео в After Effects.

  • Чего мы хотим:

  • научиться применять эффекты слоям композиции.

  • Нам потребуется:

  • любой видеофайл.

  • Что полезно вспомнить:

  • как осуществляется анимация слоев в окне Timeline (Монтаж) (см. урок 10);
  • что такое трехмерные слои (см. урок 6).


11.1. Об эффектах

В After Effects и Premiere эффектами называются самые разнообразные спецэффекты, которые изменяют (в соответствии с заложенными алгоритмами) изображение или звук. Эффекты, как и большинство действий в After Effects, применяются по отношению к слою композиции, поэтому вы можете составлять финальный кадр фильма путем наложения различных слоев, каждому из которых назначена своя группа эффектов.

Эффекты характерны тем, что большинству из них позволено регулировать не один, а несколько параметров, управляющих интенсивностью и свойствами эффекта. Это создает, вместе с многообразием эффектов, практически неограниченные возможности для манипулирования изображением фильма в соответствии с замыслами пользователя.

Эффекты After Effects можно разделить на несколько типов:

  • статические — одинаково действующие на все кадры слоя;
  • динамические — меняющиеся от кадра к кадру слоя с течением времени;
  • трехмерные (3D) — применяемые для трехмерных слоев, в том числе эффекты съемки камерой и подсветки.

After Effects содержит большое количество встроенных эффектов, с примерами использования которых можно познакомиться при помощи соответствующей справочной системы "Эффекты". В рамках данной книги мы не будем давать подробное описание эффектов, адресуя читателя к соответствующим страницам справочного руководства After Effects, которые можно просмотреть при помощи команды Help>Effects Help (Справка> Справка по эффектам) (рис. 11.1). Даже если вы плохо знаете английский язык, данная справочная система будет для вас неплохим путеводителем по имеющимся эффектам.

Рис. 11.1. Справка по эффектам


11.1.1 Создание эффектов

Эффекты настраиваются при помощи палитры Effects (Эффекты) (рис. 11.2), а динамика им придается при помощи стандартных способов анимации (см. урок 10). Чтобы вызвать на экран палитру Effects (Эффекты), воспользуйтесь командой меню Window>Effects (Окно>Эффекты).

Рис. 11.2. Для настройки спецэффектов вызовите палитру Effects

Чтобы назначить определенный эффект для слоя: 1. Выделите слой в окне Timeline (Монтаж).

2. Отыщите нужный эффект в списке эффектов в палитре Effects (Эффекты). Например, назначим слою tolstoi.avi эффект Brightness & Contrast (Яркость и контраст), предназначенный для изменения яркости или контраста слоя (рис. 11.3).

Рис. 11.3. Выделите слой и перетащите на него желаемый эффект из палитры Effects

3. Щелкните дважды на желаемом эффекте или перетащите его из палитры на название слоя в окно Timeline (Монтаж), либо на кадр в окне Composition (Композиция) с выделенным изображением слоя (рис. 11.3). В результате клипу будет назначен соответствующий спецэффект, о чем будет свидетельствовать появившийся элемент во вложенном списке Effects (Эффекты), который появляется в слое tolstoi.avi в окне Timeline (Монтаж). Кроме того, в появившейся палитре Effect Controls (Управление эффектом) откроется панель с названием эффекта (рис. 11.4).

Рис. 11.4. В появившейся палитре Effect Controls конкретного эффекта определите его параметры, ориентируясь на просмотр кадра в реальном времени в окне Composition

4. Отрегулируйте параметры эффекта при помощи панели эффекта в палитре Effect Controls (Управление эффектом) (см. рис. 11.4), либо непосредственно в окне Timeline (Монтаж).

5. Если вы намерены назначить слою какой-либо дополнительный эффект, повторите для этого эффекта действия п. 2—4.

Примечание 1

Если слою назначено несколько эффектов, то их применение к изображению производится в том порядке, в котором эффекты располагаются в палитре Effect Controls (или в окне Timeline). В некоторых случаях порядок применения эффектов играет существенную роль в формировании изображения композиции. Изменить порядок следования эффектов в палитре можно простым перетаскиванием.

Примечание 2

Альтернативным способом применения эффектов вместо палитры Effects (Эффекты), является использование меню Effects (Эффекты), содержание которого полностью эквивалентно палитре.

После назначения эффекта клипу его можно отредактировать при помощи палитры Effect Controls (Управление эффектом) (см. разд. 11.2), т. е. изменить настройки эффекта, а также удалить эффект или назначить клипу дополнительные эффекты.


11.1.2. Палитра Effects

При редактировании спецэффектов применяются, в основном, две специальные палитры. Палитра Effects (Эффекты) представляет собой библиотеку видео- и звуковых эффектов и служит для вставки того или иного спецэффекта в фильм. Другая палитра — Effect Controls (Управление эффектом) — применяется для просмотра эффектов, назначенных выделенному в окне Timeline (Монтаж) слою, и регулировки их параметров.

Палитра Effects (Эффекты) (см. рис. 11.2) является типичным представителем специального элемента интерфейса — палитр программы After Effects. Приведем наиболее общие рекомендации по ее применению, имея в виду, что большинство из них годятся и при работе с другими палитрами:

  • эффекты в палитре разложены по папкам, для раскрытия содержимого которых следует щелкнуть на треугольной кнопке слева от имени папки;
  • сворачивание развернутой папки производится также щелчком на ее треугольной кнопке;
  • порядок следования папок в палитре и эффектов в папках изменяется простым перетаскиванием;
  • найти эффект по названию можно, начав ввод ключевого слова в поле Contains (Найти) в верхней части палитры. По мере ввода слова в режиме реального времени будет осуществляться вывод найденных эффектов, которые содержат введенный фрагмент;
  • для задания дополнительных опций (в частности, порядка представления элементов списка в палитре) служит меню палитры.


11.1.3. Палитра Effect Controls

Палитра Effect Controls (Управление эффектом) (см. рис. 11.4) очень удобна для назначения и последующего редактирования эффектов для каждого слоя. Если палитра скрыта, то вызвать ее можно двойным щелчком на имени любого из назначенных эффектов в окне Timeline (Монтаж). При назначении первого эффекта палитра Effect Controls (Управление эффектом) появляется автоматически.

В любой момент времени палитра Effect Controls (Управление эффектом) отображает информацию обо всех эффектах, назначенных определенному слою композиции. Для переключения между слоями в палитре достаточно щелкнуть на закладке с именем нужного слоя (рис. 11.5).

Рис. 11.5. Для переключения между слоями в палитре Effect Controls щелкните на закладке с именем нужного слоя

Основную часть палитры занимает область со списком спецэффектов, назначенных клипу. Они расположены в порядке применения эффектов слою при осуществлении расчетов для компиляции фильма или создания предварительного просмотра в окне Composition (Композиция). В ситуации, изображенной на рис. 11.6, слою tolstoi.avi назначены три различных эффекта.

Рис. 11.6. Примененные эффекты, подобно стандартным вложенным спискам, удобно сворачивать и разворачивать

Треугольная кнопка, расположенная, слева от имени эффекта, разворачивает или сворачивает эффект. Развернутый эффект позволяет регулировать его параметры непосредственно в палитре Effect Controls (Управление эффектом). Свернутый эффект занимает в палитре меньше места и дает возможность одновременно увидеть установки большего числа эффектов (рис. 11.6).

В пределах панели каждого эффекта в палитре Effect Controls (Управление эффектом) помещается один или несколько вложенных списков, которые группируют текущие параметры данного эффекта. Их также можно сворачивать и разворачивать, руководствуясь соображениями удобства, в зависимости от того, какую работу вы проводите в данный момент. Техника настройки эффектов описана в разд. 11.2.

Слева от названия каждого эффекта находится кнопка Enable Effect (Включить эффект). Если она нажата (что символизируется буквой /внутри кнопки), то эффект применяется к клипу. Если кнопка не нажата, то эффект временно выключен (см. рис. 11.7), однако в любой момент его влияние можно восстановить.

Все типы эффектов имеют на своей панели элемент интерфейса — ссылку Reset (Сброс), позволяющую восстановить значения параметров по умолчанию, с которыми эффект был впервые применен к слою.

Примечание

Практически такое же строение, как и палитра Effect Controls (Управление эффектом), имеет группа параметров Effects (Эффекты), назначенных слою в окне Timeline (Монтаж). Таким образом, настройку эффекта можно с равным успехом проводить при помощи палитры или при помощи окна Timeline (Монтаж), руководствуясь только конкретной задачей и вашими привычками.


11.2. Редактирование эффектов

Коротко рассмотрим основные приемы редактирования эффектов при помощи палитры Effect Controls (Управление эффектом).


11.2.1. Назначение эффекта клипу

Повторимся, что для того, чтобы добавить новый эффект слою, необходимо перетащить желаемый эффект из палитры Effect Controls (Управление эффектом) на нужный слой в окно Timeline (Монтаж). При необходимости отрегулируйте параметры эффекта.

Примечание

Вновь назначенный эффект добавляется последним к списку имеющихся эффектов.


11.2.2. Изменение последовательности эффектов

Последовательность применения спецэффектов в ряде случае имеет ключевое значение. Чтобы изменить порядок следования эффектов в палитре Effect Controls (Управление эффектом), следует, зацепив указателем мыши, перетащить нужный эффект на новое место.


11.2.3. Временное выключение эффекта

Чтобы временно выключить эффект, не удаляя его, достаточно отжать щелчком мыши кнопку Enable Effect (Включить эффект) слева от его названия (на эту кнопку наведен указатель на рис. 11.7). Пиктограмма в виде буквы/внутри кнопки пропадет, и эффект не будет приниматься во внимание при расчете кадра фильма. При этом все настройки эффекта сохраняются, и повторное нажатие кнопки Enable Effect (Включить эффект) заново включает эффект. На рис. 11.7 включен лишь один из трех эффектов — Mirror (Зеркало).

Рис. 11.7. Включен только эффект Mirror


11.2.4. Удаление эффекта

Для того чтобы безвозвратно удалить эффект для выделенного в окне Timeline (Монтаж) клипа, выберите эффект в палитре Effect Controls (Управление эффектом) или в окне Timeline (Монтаж) и нажмите клавишу <Del> или <BackSpace>.

Примечание

Для того чтобы безвозвратно удалить сразу все эффекты, назначенные слою, вызовите из области имени эффекта контекстное меню и выберите в нем команду Remove All (Удалить все).


11.2.5. Настройка эффектов

Настройку эффектов можно проводить непосредственно на панели эффекта в палитре Effect Controls (Управление эффектом) либо в окне Timeline (Монтаж). Для настройки параметров эффекта в палитре Effect Controls (Управление эффектом) следует предварительно развернуть эффект нажатием треугольной кнопки слева от названия. Однако некоторые эффекты не имеют никаких параметров для регулировки.

Параметры различного типа редактируются по-разному, причем для их регулировки предусмотрено несколько альтернативных способов, что обусловлено стремлением разработчиков удовлетворить вкусы различных пользователей. Рассмотрим основные:

  • настройка посредством числового регулятора параметра;
  • настройка при помощи аналогового регулятора (такого, как ползунковый регулятор или т. п.);
  • настройка визуальным способом в окне Composition (Композиция), т. е. непосредственно на кадре фильма при помощи соответствующих маркеров.

Некоторые параметры определенных эффектов имеют дополнительные уровни регулировки (например, установки цвета, допускающие использование пипетки или диалоговых окон определения цвета и т. п.).

Приведем несколько характерных примеров настройки параметров эффектов. Наиболее типичным средством для определения значения параметра является ползунковый регулятор (рис. 11.8). Перемещение ползунка влево или вправо позволяет уменьшить или увеличить текущее значение параметра соответственно.

Рис. 11.8. Настройка параметра эффектов при помощи ползун кового регулятора

Некоторые параметры по своей сути являются векторными, т. е. задают определенное направление эффекта на плоскости кадра. Например, эффект Mirror (Зеркало) создает в заданной части кадра отражение существующего изображения слоя. Соответственно, одним из его параметров является свойство Reflection Angle (Угол отражения), задающее угол (в градусах), под которым должно происходить отражение от воображаемого зеркала. Для определения таких параметров в After Effects существуют специальные круговые регуляторы, позволяющие пользователю визуально определить угол, не путаясь в возможных числовых значениях (в данном случае, от 0 до 360°), которые может принимать параметр (рис. 11.9).

Рис. 11.9. Настройка параметра при помощи кругового регулятора

Как правило, практически все параметры допускают быстрое редактирование при помощи активных надписей, которые можно использовать как путем перетаскивания влево и вправо (рис. 11. 10), так и вводя абсолютное числовое значение с клавиатуры после щелчка на параметре (рис. 11.11).

Рис. 11.10. Относительное изменение параметра эффекта осуществляется при помощи техники перетаскивания активной надписи

Рис. 11.11. Ввод абсолютного значения параметра эффекта с клавиатуры

Примечание

Напомним еще раз, что настройка параметров может производиться как в палитре Effect Controls (Управление эффектом), так и в окне Timeline (Монтаж).

Наконец, скажем несколько слов еще об одной довольно обширной группе параметров, допускающих наглядную визуализацию в кадре композиции. Эти параметры, как правило, касаются настройки геометрии соответствующих эффектов. Такие параметры можно настраивать не только при помощи числовых или аналоговых регуляторов, но и непосредственно в окнах Composition (Композиция) или Layer (Слой).

Некоторые параметры, такие как, например, свойство Reflection Center (Центр отражения) того же эффекта Mirror (Зеркало), требуют задания на кадре одной определенной точки — центра отражения. Ее можно определить непосредственно в окне Composition (Композиция), нажав предварительно кнопку вызова параметра в палитре Effect Controls (Управление эффектом) (рис. 11.12).

Рис. 11.12. Визуальное задание точечного параметра в окне Composition

Рис. 11.13. Визуальное задание пространственного параметра в окне Composition (на примере применения эффекта текстовому слою)

Другие параметры предусматривают определение не одной точки, а целой области на кадре, которая имеет ту или иную геометрию. Обычно при начале регулировки такого параметра в палитре Effect Controls (Управление эффектом) в кадре в окне Composition (Композиция) возникает соответствующая фигура, снабженная маркерами обрамления. Перетаскивая маркеры можно наглядно подобрать желаемый размер фигуры, т. е. определить нужное значение соответствующего параметра или сочетания параметров. Изменения в кадре происходят в режиме реального времени, по мере регулировки. Пример таких действий изображен на рис. 11.13.


11.2.6. Регулировочный слой

Как мы уже сказали, эффекты применяются к отдельным слоям. Однако иногда возникает ситуация, когда вам необходимо настроить один и тот же эффект для нескольких слоев композиции. В этом случае полезным оказывается специальный служебный слой, называемый регулировочным (adjustment layer). Создать его можно командой Layer>New>Adjustment layer (Слой> Создать>Регулировочный слой), после чего новый регулировочный слой появляется в окне Timeline (Монтаж).

Особенность невидимого регулировочного слоя заключается в том, что эффекты, примененные к этому слою, автоматически применяются и ко всем слоям, находящимся под ним. Таким образом, чтобы назначить группе слоев одинаковый эффект — создайте новый регулировочный слой, разместите его над этими слоями и настройте для него соответствующий эффект.

Примечание

Регулировочный слой допускается редактировать всеми способами, применимыми к обычному слою. Это означает, что его можно масштабировать, повернуть и т. д. Настроенные для него эффекты будут применены к нижним слоям в областях их перекрытия с регулировочным слоем.


11.2.7. Типы эффектов

Коротко перечислим названия папок с эффектами, находящимися в палитре Effects (Эффекты) (см. рис. 11.2), и скажем несколько слов об их специфике.

  • 3D Channel (Трехмерный канал) — группа преобразований для настройки пространственных эффектов трехмерных слоев;
  • Adjust (Регулировка) — очень важная с практической точки зрения группа спецэффектов, позволяющих регулировать типовые параметры изображения. Сходные эффекты помещены в папку Image Control (Управление изображением). С помощью эффектов этих двух папок можно изменить яркость (brightness), контрастность (contrast) изображения, цветовой баланс, т. е. относительное содержание красного (red), зеленого (green) и синего (blue) цветов в изображении. За эти функции ответственны эффекты Brightness & Contrast (Яркость и контраст) и Color Balance (Цветовой баланс) соответственно. Кроме традиционной RGB-регулировки цветового баланса (red-green-blue), в более сложных эффектах возможна регулировка "оттенок-яркость-насыщенность" (hue-lightness-saturation) и применение интегральных сдвигов спектра изображения в основных цветах;
  • Audio (Аудио) — различные звуковые эффекты, преобразующие звук слоев;
  • Blur & Sharpen (Размытие и резкость) — спецэффекты размытия изображения и повышения его резкости. Некоторые из эффектов имитируют различные устройства или направление размытия, а другие повышают резкость, отыскивая те места в кадре клипа, в которых происходят изменения цвета изображения, и увеличивают степень перехода цвета;
  • Channel (Канал) — эффекты, позволяющие проводить действия с RGB-каналами изображения. Эффект Invert (Обращение) заменяет один или несколько (по выбору пользователя) цветов клипа во всех пикселах дополнительным цветом, т. е. инвертирует изображение;
  • Distort (Искажение) — разнообразные эффекты, деформирующие изображение клипа вдоль различных направлений с разными параметрами. Как правило, эти эффекты имитируют те или иные действия или устройства, например — отражение и т. п.;
  • Expression Control (Управление выражениями) — служебные эффекты, предназначенные для использования их в выражениях;
  • Image Control (Управление изображением) — различные эффекты для регулировки параметров яркости, цветового баланса изображения клипов (см. описание группы эффектов Adjust);
  • Keying (Прозрачные наложения) — группа очень важных эффектов, при помощи которых можно настроить прозрачность слоя определенным образом и настроить его наложение на нижние слои;
  • Paint (Рисование) — вспомогательные эффекты для процесса рисования на слоях;
  • Perspective (Перспектива) — группа эффектов, добавляющая трехмерные эффекты клипам, например, такие как поворот плоскости кадра клипа, добавление тени, а также растяжения, сжатия или перевороты в различных направлениях;
  • Render (Растр) — эффекты, имитирующие различные оптические устройства, например, эффект Lense Flare (Блик линзы) позволяет создать характерный световой блик, подобно отсвету в объективе камеры;
  • Stylize (Стилизация) — еще одна группа эффектов для имитации разнообразных оптических явлений. Изображение изменяется по довольно сложным алгоритмам, которые создают эффект мозаики (Mosaic), рельефности (Emboss) и т. п.;
  • Time (Динамика) — группа эффектов, достигающих своеобразного размытия изображения клипа во времени. Отдельные последовательные кадры клипа смешиваются друг с другом в определенной пропорции, подчеркивая динамику движущихся объектов на сцене и создавая тем самым эффект размытия, иногда делая его гротескным;
  • Transition (Переход) — эффекты перехода, которые применяются, главным образом, для повышения эффектности смены одного действия другим.

Формат нашей книги, с одной стороны, и огромное число параметров разнообразных эффектов, имеющихся в After Effects, с другой стороны, не позволяют детально разобрать каждый из эффектов. Однако большинство из них реализовано разработчиками на довольно простом и даже интуитивном уровне, поэтому мы надеемся, что разобраться с особенностями нужного эффекта для вас не составит труда.

Примечание

Напомним также читателю, что с галереей имеющихся эффектов можно познакомиться в специальном справочном руководстве по эффектам, которое вызывается командой верхнего меню Help>Effects Help (Справка>Справка по эффектам). Подчеркнем, что, по сути, это самостоятельное справочное пособие, обособленное от основной справочной системы After Effects.


11.3. Динамические эффекты

Пока мы говорили о способах создания эффектов, действие которых на слой постоянно, т. е. не зависит от времени. Между тем, многие спецэффекты можно сделать динамическими, т. е. изменяющими свои параметры во времени. Например, можно создать эффект, который в начале слоя не действует, а к концу слоя достигает максимальной интенсивности. Разумеется, можно задавать и более сложные зависимости параметров эффектов от времени.

На рис. 11.14 приведен пример динамического изменения эффекта Block Dissolve (Растворение блоками). Интенсивность эффекта вначале нулевая, затем возрастает до максимального значения (этот момент приурочен к смене планов исходного слоя), а затем вновь падает до нуля. При помощи эффектов такого типа особенно удобно создавать спецэффекты, называемые переходами (transition).

Рис. 11.14. Пример динамического эффекта (коллаж)

Настройка динамических эффектов абсолютно идентична настройке стандартной анимации, поэтому, в принципе, можно было бы ничего не говорить здесь более того, что динамические эффекты, по сути, являются анимацией их параметров на основе техники ключевых кадров. Объяснение создания динамического эффекта с рис. 11.14 приведено на рис. 11.15. Тем не менее, разберем конкретный пример создания динамического эффекта, ограничившись минимальными замечаниями.

Рис. 11.15. Реализация динамического эффекта (см. рис. 11.14)

Настроим динамический эффект, который будет изменять яркость слоя некоторой композиции, делая его первые кадры более темными, а последующие более светлыми.

1. Выделите нужный слой в окне Timeline (Монтаж) и поместите линию редактирования на первый кадр композиции, который вы собираетесь сделать ключевым. В нашем случае это один из первых кадров слоя war.mov.

2. Двойным щелчком на желаемом эффекте, в нашем случае Brightness & Contrast (Яркость и контраст) в палитре Effects (Эффекты), примените эффект к слою, затем в открывшемся окне палитры Effect Controls (Управление эффектом) отредактируйте параметры эффекта, например, сделайте слой более темным (рис. 11.16).

Рис. 11.16. Начните настройку с применения обычного эффекта при помощи палитры Effects

Примечание

В окне Timeline откройте группу параметров Effects (Эффекты), чтобы сравнивать дальнейшие действия в палитре Effect Controls (Управление эффектом) с состоянием окна Timeline. Обратите внимание, что пока эффект применен ко всему слою и является статическим (значение параметра Brightness (Яркость) одинаково для всех кадров слоя).

3. Щелкните на секундомере слева от параметра Brightness (Яркость) для создания первого ключевого кадра. После щелчка слева от названия эффекта появится навигатор ключевых кадров с выставленным флажком проверки, говорящим о том, что текущий кадр стал ключевым.

4. Переместите линию редактирования на следующий кадр клипа, который вы собираетесь сделать ключевым, и отрегулируйте параметры эффекта в палитре Effect Controls (Управление эффектом) (рис. 11.17).

Рис. 11.17. Создайте ключевые кадры для параметра эффекта и отрегулируйте его параметры на каждом ключевом кадре

5. Поочередно установите линию редактирования на нужные кадры клипа, которые вы желаете сделать ключевыми, и отрегулируйте настройки эффекта в палитре Effect Controls (Управление эффектом) для каждого из кадров.

6. При необходимости разверните вложенный список параметра Brightness (Яркость) и отредактируйте как его значения на ключевых кадрах, так и тип интерполяции, при помощи графиков самого параметра и скорости его изменения (рис. 11.18).

Рис. 11.18. Отредактируйте динамический эффект, пользуясь графиками изменения параметра и его скорости

Изменить настройки динамического эффекта можно в любой момент либо с помощью добавления новых ключевых кадров, либо изменением настроек эффекта на существующих ключевых кадрах, либо удалением имеющихся ключевых кадров. Пользоваться при этом следует стандартными методами редактирования анимации (см. урок 10). Особенно удобен навигатор ключевых кадров (keyframe navigator), с помощью кнопок которого слева и справа можно переходить к предыдущему или следующему ключевому кадру слоя. Флажок проверки в центре навигатора отображает информацию о том, является ли текущий кадр фильма ключевым кадром выделенного слоя.

Для удаления текущего ключевого кадра достаточно щелкнуть на флажке проверки навигатора. После этого анимация эффекта перестроится с учетом оставшихся ключевых кадров. Временное отключение динамического эффекта в композиции осуществляется так же, как и в случае статического — нажатием кнопки Enable Effect (Включить эффект), нажатое состояние которой символизируется буквой f внутри кнопки. Для удаления динамики эффекта просто выключите кнопку с секундомером слева от его названия, и в результате этого все ключевые кадры будут удалены, а эффект останется статическим.


11.4. Пространственные эффекты

Пока мы рассматривали, как применяются обычные двумерные (2D) эффекты к стандартным двумерным слоям, т. е. слоям с плоским изображением кадра. Между тем, в After Effects имеется тип слоев со специальными свойствами, который позволяет достичь реалистичного трехмерного эффекта. Конечно, изображение, получаемое при помощи этих слоев, также является плоским, однако и стиль редактирования, и его результат позволяют с полным правом назвать эти слои трехмерными (3D) (см. урок 6).

Для реализации иллюзии пространственной протяженности слоев в After Effects имеется несколько дополнительных типов эффектов:

  • Camera (Камера);
  • Light (Свет).

Эти спецэффекты, предназначенные для применения к трехмерным слоям, настраиваются иначе, нежели стандартные эффекты, и, фактически, сами являются слоями композиции.


11.4.1. Назначение эффекта трехмерному слою

Любой из двумерных эффектов, о которых шла речь в предыдущих разделах этого урока, может быть применен к трехмерному слою (за исключением слоев специального вида — камеры и света). Как вы помните (см. разд. 6.3), для того, чтобы определить любой слой композиции в качестве трехмерного слоя, достаточно в окне Timeline (Монтаж) выставить соответствующий переключатель режима (в примере на рис. 11.19 переключатель признака трехмерности выставлен для текстового слоя 1945 и снят для видеослоя war.mov).

Рис. 11.19. Создание трехмерного слоя

Для того чтобы применить эффект к трехмерному слою, следует действовать обычным образом, т. е. выделить этот слой, дважды щелкнуть на названии желаемого эффекта в палитре Effects (Эффекты) и затем отрегулировать его параметры в палитре Effect Controls (Управление эффектом) или непосредственно в окне Timeline (Монтаж). На рис. 11.20 вы видите пример применения эффекта Glow (Сияние) к текстовому слою 1945 из предыдущего рисунка.

Рис. 11.20. Обычные эффекты назначаются трехмерному слою стандартным образом


11.4.2. Эффект Camera

Спецэффект Camera (Камера) изменяет особым образом изображение слоя, имитируя его просмотр через видео- или телекамеры с различных расстояний под различными углами. Применим этот спецэффект слою war.mov (рис. 11.20), предварительно определив его в качестве трехмерного слоя.

1. Создайте и отредактируйте в окне Timeline (Монтаж) трехмерные слои, к которым вы хотите применить эффект камеры.

2. Создайте новый трехмерный слой специального типа — "камера", для чего выберите в верхнем меню Layer>New>Camera (Слой>Создать> Камера).

3. Определите в открывшемся диалоге Camera Settings (Установки камеры) параметры спецэффекта, соответствующие техническим характеристикам камеры (рис. 11.21).

Рис. 11.21. Диалоговое окно с настройками камеры

4. Отредактируйте вид композиции, используя инструменты работы со светом камерой (рис. 11.22). Инструмент Orbit camera (Орбитальная камера) предназначен для вращения текущего трехмерного вида, а инструменты Track XY camera (XY-слежение) и Track Z camera (Z-слежение) — для регулировки трехмерного вида вдоль вертикали и горизонтали, а также вдоль третьей пространственной оси.

Рис. 11.22. Редактируйте вид камеры при помощи набора инструментов Camera

Примечание

При просмотре кадра композиции через камеру убедитесь в том, что в окне Composition (Композиция) выбран соответствующий трехмерный вид, например, Active Camera (Активная камера).

Обратите внимание, что эффект камеры применяется к композиции особым способом: при помощи добавления нового служебного слоя камеры, который появляется в окне Timeline (Монтаж) (см. рис. 11.22).

Параметры камеры можно определить (и настроить анимацию) при помощи соответствующих вложенных списков в окне Timeline (Монтаж). Двойной щелчок на названии камеры вызывает то же самое диалоговое окно Camera Settings (Установки камеры), в котором можно также поменять характеристики камеры, определенные при ее создании.


11.4.3. Эффект Light

Эффект Light (Свет) предназначен для создания характерной подсветки изображения слоя.

1. Создайте и отредактируйте в окне Timeline (Монтаж) трехмерные слои, для которых вы собираетесь настроить подсветку.

2. Создайте новый трехмерный слой специального типа — "свет", для чего выберите в верхнем меню Layer>New>Light (Слой>Создать>Свет).

3. Определите в открывшемся диалоге Light Settings (Установки подсветки) настройки подсветки (рис. 11.23).

Рис. 11.23. Назначение трехмерному слою подсветки

4. При необходимости отредактируйте настройки света (такие, как положение источника и направление подсветки) в окне Composition (Композиция) (рис. 11.24).

Рис. 11.24. Настройку подсветки можно проводить визуальным способом в окне Composition

5. Определите для тех слоев, которые вы подсвечиваете, сочетание параметров Material options (Материал) (рис. 11.25). Они задают, каким образом взаимодействует свет, падающий на слой, с этим слоем (имитируя различные отражающие или рассеивающие материалы).

Рис. 11.25. Важными параметрами, влияющими на вид подсветки, являются материал трехмерного слоя и местоположение источника света

Заметим, что как эффект камеры, так и эффект света используют в качестве настроек особые точки привязки (point of interest) к трехмерному слою. Для камеры эта точка определяет ее расположение (т. е. место, откуда камера "смотрит" на трехмерные слои), а для подсветки слоев — расположение источника света. Перемещая точки привязки по кадру при помощи инструмента Selection (Выбор), вы определяете самый главный параметр этих спецэффектов.


11.5. Резюме

На этом уроке мы познакомились с принципами настройки статических и динамических эффектов слоям композиций, а также конспективно рассказали, какие специальные эффекты предназначены для трехмерных слоев. Эффекты добавляются слоям при помощи палитры Effects (Эффекты) и настраиваются при помощи другой палитры Effect Controls (Управление эффектом) или непосредственно в окне Timeline (Монтаж). Принцип настройки динамических эффектов тот же самый, что и принцип анимации слоев (определение ключевых кадров и регулировка на них параметра эффекта).


Урок 12. Титры

  • На этом уроке...
  • 12.1. Создание титров
    • 12.1.1. Создание одной строки текста
    • 12.1.2. Создание текста, разбитого на абзацы
  • 12.2. Редактирование титров
    • 12.2.1. Выделение, перемещение и масштабирование титров
    • 12.2.2. Форматирование титров
  • 12.3. Анимация титров
    • 12.3.1. Стандартный способ анимации
    • 12.3.2. Анимация исходного текста
    • 12.3.3. Параметры группы Animator
  • 12.4. Резюме


На этом уроке...

Этот урок посвящен созданию, форматированию и анимации текста в кадре композиции, которые, по аналогии с Premiere, будем называть титрами.

  • Чего мы хотим:

  • научиться вставлять и форматировать текстовые блоки в композиции, а также назначать анимацию тексту.

  • Нам потребуется:

  • любой видеофайл или файл со статической графикой.

  • Что полезно вспомнить:

  • как производится редактирование слоев (см. урок 6) и настройка анимации слоев (см. урок 10).


12.1. Создание титров

Прежде всего, заметим, что добавление титров в композиции производится при помощи создания соответствующих текстовых слоев (text layer). Каждый текстовый слой может содержать некоторый фрагмент текста, который будет форматироваться и настраиваться (при помощи эффектов, анимации, масок и т. д.) независимо от других слоев. Далее мы будем называть титры просто текстом, текстовым слоем или текстовым блоком, не делая особенного различия в этих терминах.

В After Effects принято различать два типа титров, которые при редактировании ведут себя по-разному:

  • строчный текст (point text) — короткое слово или несколько слов, умещающихся в одну строку (рис. 12.1);
  • абзацный текст (paragraph text) — текст большего размера, включающий несколько строк, разделенных между собой символами абзаца, т. е. перевода строки.

Рис. 12.1. Строчный текст (слева — вертикальный, справа — горизонтальный)

Для создания и редактирования титров в After Effects следует использовать один из инструментов Text (Текст) палитры Tools (Инструментарий) — для горизонтальных или вертикальных титров (рис. 12.1, 12.2).

Рис. 12.2. Инструмент Text используется для создания и редактирования титров


12.1.1. Создание одной строки текста

Для создания строчного текста можно использовать либо инструмент Text (Текст), либо команду меню Layer>New>Text (Слой>Создать>Текст). Удобнее применять первый способ.

1. Выберите один из инструментов Text (Текст), в зависимости от того, горизонтальные или вертикальные титры вы хотите создать.

2. Установите линию редактирования на тот кадр, в момент которого в фильме должен появляться текст титров.

3. Щелкните в желаемом месте кадра в окне Composition (Композиция). В результате в этом месте появится курсор ввода текста (рис. 12.3).

Рис. 12.3. Ввод текста осуществляется в позицию курсора ввода

4. Задайте желаемые атрибуты текста, такие как тип, размер шрифта, начертание и т. д. (см. разд. 12.2).

5. Введите текст.

6. По завершении ввода нажмите клавишу <Enter> или просто щелкните за пределами созданного текстового слоя (рис. 12.4).

Рис. 12.4. Введенный текстовый слой появляется и в окне Timeline

Обратите внимание, что сразу после щелчка инструментом Text (Текст) в кадре композиции в окне Timeline (Монтаж) появляется новый текстовый слой с временным условным названием. После завершения ввода текста этому слою присваивается имя по принципу первых символов этого слоя (рис. 12.4). Впоследствии созданный текстовый слой можно изменить, удаляя или добавляя фрагменты, или форматируя его атрибуты.


12.1.2. Создание текста, разбитого на абзацы

Для создания строчного текста можно использовать либо инструмент Text (Текст), либо команду меню Layer>New>Text (Слой>Создать>Текст). Удобнее применять первый способ.

1. Установите линию редактирования на желаемый кадр и выберите один из инструментов Text (Текст).

2. Протаскиванием указателя мыши через определенный фрагмент кадра в окне Composition (Композиция) определите местоположение и размер текстового слоя. В результате в этом месте появится новый текстовый слой, выделенный маркерами и содержащий курсор ввода текста (рис. 12.5).

Рис. 12.5. Абзацный текст (нижний из титров) может содержать символы перевода строки

3. Задайте желаемые атрибуты текста — тип и размер шрифта, начертание и т. д. (см. разд. 12.2).

4. Введите желаемый текст титров (рис. 12.5). При вводе можно использовать символы нового абзаца, т. е. нажимать клавишу <Enter>. Для каждого из абзацев можно устанавливать свои атрибуты (выравнивание, отступы и т. п.).

5. По завершении ввода щелкните за пределами созданного текстового слоя в окне Timeline (Монтаж).

Если при вводе текста он выходит за границы созданного блока, то сигнал об этом будет выдан при помощи соответствующей пиктограммы переполнения текста (рис. 12.6). Чтобы весь текст поместился в кадре композиции, необходимо либо переформатировать его (например, уменьшив размер шрифта), либо увеличить размер текстового слоя. Для изменения размера слоя достаточно перетащить соответствующим образом один из его маркеров обрамления.

Рис. 12.6. При переполнении слоя текстом выводится соответствующая пиктограмма (угловой маркер с крестом)

Результат действий по созданию двух текстовых слоев — одного строчного, а другого абзацного — изображен на рис. 12.7.

Рис. 12.7. Выделяйте титры как целый слой в окнах Composition и Timeline при помощи инструмента Selection


12.2. Редактирование титров

Рассмотрим основные операции, которые можно производить над созданными титрами.


12.2.1. Выделение, перемещение и масштабирование титров

Выделить титры можно несколькими способами, и, в зависимости от способа выделения, действия над титрами будут приводить к различным результатам.

1. При помощи инструмента Selection (Выбор) на нижнем тексте в окне Composition (Композиция), либо на имени слоя с титрами в окне Timeline (Монтаж) выделите весь текстовый слой (рис. 12.7). В результате слой приобретет выделение, характерное для всех остальных слоев в After Effects.

2. Перетаскивая один из маркеров обрамления нижнего слоя титров в окне Composition (Композиция), масштабируйте его изображение (рис. 12.8). В результате текст уменьшится или увеличится в соответствии с уменьшением (как на рис. 12.8) или увеличением всего слоя.

Рис. 12.8. Масштабирование абзацных титров инструментом Selection

3. Повторите операцию выделения и последующего масштабирования для верхнего строчного слоя (рис. 12.9), чтобы убедиться, что слои обоих типов ведут себя одинаково.

Рис. 12.9. Масштабирование строчных титров инструментом Selection

4. При помощи того же инструмента Selection (Выбор), используя технику перетаскивания, передвиньте слой в окне Timeline (Монтаж) на новое место (рис. 12.10).

Рис. 12.10. Перемещение титров по поверхности кадра производится также инструментом Selection

5. Теперь выделите абзацные титры инструментом Text (Текст) в окне Composition (Композиция) (рис. 12.11). Если у вас возникают трудности с таким выделением, воспользуйтесь сначала инструментом Selection (Выбор), для выделения слоя целиком (выделить слой можно в окне Timeline).

Рис. 12.11. Выделение абзацных титров инструментом Text позволяет затем изменять размер текстового блока без масштабирования в нем текста

6. Перетаскивая один из маркеров обрамления нижнего слоя титров (которые, в случае выделения инструментом Text (Текст), отображаются маркерами без заливки) в окне Composition (Композиция), измените размер текстового блока. Масштабирования текста при этом не произойдет (рис. 12.12).

Рис. 12.12. Изменение размера текстового блока при помощи инструмента Text

7. При помощи того же инструмента Text (Текст) выделите какой-либо фрагмент текста в пределах слоя титров, применяя протаскивание указателя мыши через этот фрагмент (рис. 12.13).

Рис. 12.13. Выделение фрагмента текста производится при помощи инструмента Text

При дальнейшей работе с титрами следует принимать во внимание следующие простые правила их выделения:

  • если выделен фрагмент титров, то форматирование будет относиться только к этому фрагменту;
  • если выделен весь слой, то любая правка будет применена ко всему тексту титров.


12.2.2. Форматирование титров

After Effects позволяет устанавливать стандартные опции форматирования шрифта, принятого в большинстве типичных текстовых редакторов. Форматирование текста в After Effects осуществляется при помощи двух палитр:

  • палитра Character (Символ) — применяется для форматирования атрибутов символов, таких как тип и размер шрифта, цвет текста и т. п.;
  • палитра Paragraph (Абзац) — для редактирования параметров целых абзацев (и строчных титров целиком).

Изменения параметров символов и абзацев, которые пользователь производит в палитрах, относятся к выделенному в этот момент фрагменту текста.

Рис. 12.14. Палитра Character используется для форматирования символов

Если никакой фрагмент (или слой целиком) не выделен, то регулировка параметров в палитрах будет иметь значение только для ввода нового текста. В любом случае, при вводе нового текста с клавиатуры, он появляется в композициях с текущими атрибутами, выставленными в этих двух палитрах.

Рис. 12.15. Палитра Paragraph используется для форматирования абзацев

Обратимся к обзору параметров, которые доступны для изменения в палитрах Character (Символ) и Paragraph (Абзац) и которые, соответственно, можно применять для придания титрам желаемого вида. Перечислим параметры шрифта текстовых объектов и приведем основные рекомендации по их настройке. В палитре Character (Символ) находятся следующие элементы управления (рис. 12.16, 12.17):

Рис. 12.16. Настройка цвета текста в палитре Character

Рис. 12.17. Назначение основных параметров форматирования текста в палитре Character

  • Color (Цвет) — группа параметров в правой верхней части палитры (см. рис. 12.16), с помощью которых определяются цветовые установки текста. Для отображения текста используются два цвета: цвет линии обрамления и цвет внутренней части текста. Таким образом, если добавлена линия обрамления некоторой ширины, то сочетание двух цветов позволяет добиться дополнительных эффектов оформления (см. рис. 12.19, 12.20). Инструмент Eyedropper (Пипетка) позволяет "зачерпнуть" цвет из любого места кадра композиции. После нажатия кнопки с изображением пипетки временно — до первого щелчка — включается инструмент Eyedropper (Пипетка). Помимо применения пипетки, любой из доступных текущих цветов может быть выбран при помощи диалогового окна выбора цвета, загружающегося после щелчка на поле отображения текущего цвета;
  • Font family (Тип шрифта) — выпадающий список, который задает тип шрифта текста (или, по-другому, гарнитуру);
  • Font style (Начертание) — выпадающий список выбора начертания шрифта. Как правило, имеются стандартные варианты типа Normal (Обычное), Bold (Полужирное), Italic (Курсив) или т. п. Доступны только те типы начертания, которые имеются для данного шрифта;
  • Font Size (Размер шрифта) — параметр, задающий числовое значение размера символов (или кегля). Кегль определяет (в определенной пропорции, принятой для данной гарнитуры) как вертикальный, так и горизонтальный размеры символа;
  • Horizontal Scale (Горизонтальный масштаб) — параметр, задающий дополнительное горизонтальное масштабирование шрифта. С его помощью можно сделать (для одного и того же кегля) символы более узкими или, наоборот, более широкими;
  • Vertical scale (Вертикальный масштаб) — параметр, задающий вертикальный масштаб шрифта;
  • Line Width (Толщина линии) — параметр, определяющий толщину линии обрамления текста;
  • Leading (Межстрочное расстояние) — параметр, задающий интерлиньяж (межстрочное расстояние). Он имеет значение для текста титров, располагающегося в несколько строк;
  • Kerning (Кернинг) — параметр, задающий межбуквенные интервалы в тексте (в частности, между определенными парами символов);
  • Tracking (Трекинг) — параметр, который определяет плотность текста;
  • Baseline Shift (Базовая линия) — параметр, задающий вертикальный сдвиг базовой линии (т. е. воображаемой линии ограничения снизу для большинства символов). С его помощью можно сместить текст по вертикали вверх или вниз. Оперируя данным параметром, можно установить какой-либо фрагмент текста в позицию верхнего или нижнего индекса;
  • панель Font style (Начертание) — содержит несколько кнопок, позволяющих комбинировать различные опции:

  • Bold (Полужирный) — начертание шрифтом увеличенной толщины;
  • Italic (Курсив) — начертание курсивом;
  • All Caps (Все прописные) — начертание всех символов выделенного текста в верхнем регистре (в виде прописных букв);
  • Small Caps (Малые прописные) — параметр, задающий написание текста прописными буквами уменьшенного размера;
  • Subscript (Нижний индекс) — стандартный нижний индекс;
  • Superscript (Верхний индекс) — стандартный верхний индекс.

При помощи описанных параметров можно отредактировать как текстовый объект целиком, так и изменить настройки части текста. Для этого следует выделить соответствующий фрагмент при помощи инструмента Text (Текст) и отрегулировать желаемые параметры. В последнем случае изменение параметров шрифта будет относиться только к выделенному фрагменту.

Коротко остановимся и на элементах управления палитры Paragraph (Абзац) (рис. 12.18):

  • Align (Выравнивание) — группа кнопок, позволяющая выбрать желаемый вариант выравнивания текста в абзаце;
  • Indent Left Margin (Левый отступ) — задает размер левого отступа абзаца;
  • Indent Right Margin (Правый отступ) — задает поле справа от абзаца;
  • Indent First line (Абзацный отступ) — задает абзацный отступ, т. е. "красную строку";
  • Add Space after paragraph (Отступ под абзацем) — задает размер дополнительного отступа под абзацем;
  • Add Space before paragraph (Отступ над абзацем) — задает размер дополнительного отступа над абзацем.

Рис. 12.18. Назначение основных параметров форматирования абзаца в палитре Paragraph


12.3. Анимация титров

При анимации текста следует иметь в виду, что, вдобавок к стандартным приемам анимации (см. урок 10), для титров в After Effects предусмотрены дополнительные возможности.


12.3.1. Стандартный способ анимации

Для слоя титров, как и для любого другого слоя композиции, анимацию можно настроить при помощи параметров группы Transform (Преобразование) способом, описанным в разд. 10.3. Пример анимации текста на основе динамического изменения его прозрачности приведен на рис. 12.19.


12.3.2. Анимация исходного текста

Одним из специфических вариантов анимации титров является изменение самого текста титров или его атрибутов по ходу действия фильма. Назначение такого типа анимации происходит вручную — пользователю следует надлежащим образом задать все изменения текста на ключевых кадрах.

Рис. 12.19. Настройка стандартного эффекта анимации титров для параметра прозрачности

В промежутках между ключевыми кадрами ничего происходить не будет. Если вам требуется применить интерполяцию между ключевыми кадрами, воспользуйтесь третьим вариантом анимации текста (см. разд. 12.4).

Создадим анимацию исходного текста титров композиции, изображенной на рис. 12.20.

Рис. 12.20. Начинайте ручную настройку анимации исходного текста с разворачивания параметра Source Text

1. В окне Timeline (Монтаж) раскройте вложенный список текстового слоя, а в нем раскройте список параметра Text (Текст).

2. Щелкните на секундомере Source Text (Исходный текст), чтобы создать первый ключевой кадр.

3. Перейдите к кадру композиции, который вы собираетесь сделать следующим ключевым кадром. Измените на этом кадре, в окне Composition (Композиция), текст титров и/или его форматирование (см. разд. 12.2).

4. Таким же способом (повторяя п. 3) создайте и другие ключевые кадры.

Результат настройки анимации исходного текста изображен на рис. 12.21.

Рис. 12.21. Анимация исходного текста титров


12.3.3. Параметры группы Animator

Назначить анимацию титрам можно не только для их текста как единого целого, но и его фрагменту. Особенность анимации текста заключается в возможности одновременного определения нескольких сценариев анимации для различных фрагментов текста, используя различные его параметры.

Зададим анимацию на основе изменения прозрачности для двух фрагментов текста (рис. 12.22). Для этого:

1. В окне Timeline (Монтаж) выделите текстовый слой.

2. В окне Composition (Композиция) выделите фрагмент текста, которому вы собираетесь назначить анимацию (рис. 12.22).

Рис. 12.22. Начните настройку анимации с выделения текста и вызова всплывающего меню Animate в окне Timeline

3. В окне Timeline (Монтаж) нажатием кнопки Animate (Анимация) вызовите одноименное всплывающее меню, которое состоит из списка возможных параметров анимации.

4. Выберите желаемый параметр анимации, в нашем примере Opacity (Непрозрачность). В результате в окне Composition (Композиция) выбранный до этого фрагмент приобретет характерное выделение линиями селектора (selector bars), которыми можно выделять тот или иной фрагмент текста. Кроме того, в окне Timeline (Монтаж) раскроется содержимое параметра Opacity (Непрозрачность), причем данный параметр будет вложен в появившиеся элементы Animator 1 (Аниматор 1) и Range Selector 1 (Селектор 1). Эти элементы являются идентификаторами создаваемого эффекта анимации (рис. 12.23).

Рис. 12.23. Первый выбор параметра анимации приводит к созданию нового аниматора и селектора

5. Щелкните на секундомере, сопровождающем название параметра Opacity (Непрозрачность) для создания первого ключевого кадра и определите для него значение параметра.

6. Переставляя линию редактирования на последующие кадры, определите для них соответствующие значения параметра Opacity (Непрозрачность) (рис. 12.24).

Рис. 12.24. Определите значения параметра анимации для каждого из ключевых кадров

7. Перетаскивая линии селектора Влево или вправо, выделяйте (также на ключевых кадрах) желаемый фрагмент текста, которому будет назначена анимация, т. е. селектор (рис. 12.25).

Рис. 12.25. Определите желаемый фрагмент (селектор) в окне Composition

8. При желании добавьте для имеющегося селектора Range Selector 1 (Селектор 1) другие параметры анимации, которые будут меняться для того же самого фрагмента текста вместе с параметром Opacity (Непрозрачность). Для этого вызовите всплывающее меню Add (Добавить) (рис. 12.27) и в его подменю Property (Свойство) выберите желаемый новый параметр анимации, например, параметр Scale (Масштаб).

Рис. 12.26. При желании настройте другие параметры анимации для того же селектора

9. Для того чтобы настроить одновременную анимацию и другим фрагментам текста, создайте еще один аниматор при помощи того же всплывающего меню Animate (Анимация) и настройте размеры соответствующего селектора в окне Composition (Композиция), а также ключевые кадры в окне Timeline (Монтаж).

10. При необходимости отредактируйте обычными способами (см. урок 10) положения созданных ключевых кадров и динамику изменения параметров и их скоростей.

В справочной системе After Effects вы найдете дополнительную информацию об использовании аниматоров и селекторов в текстовых слоях, а также различные примеры применения анимации титров (рис. 12.27).

Рис. 12.27. В справочной системе After Effects вы найдете несколько примеров применения анимации текста


12.4. Резюме

Титры в After Effects добавляются в композиции в виде текстовых слоев. Для создания и редактирования горизонтальных и вертикальных титров следует использовать соответствующий инструмент Text (Текст). Помните о том, что эти два инструмента совмещены в одной кнопке палитры Tools (Инструменты). Для форматирования текста титров служат еще две палитры — Character (Символ) и Paragraph (Абзац), позволяющие отрегулировать основные атрибуты текста.


Системные требования

  • Для работы в ОС Microsoft® Windows®:

  • процессор Intel® Pentium® III или 4 (рекомендуется несколько процессоров), либо соответствующие типы процессоров AMD®;
  • оперативная память: 128 Мбайт (рекомендуется 256 Мбайт и более);
  • пространство на диске: минимальное — 150 Мбайт для установки (рекомендуется не менее 500 Мбайт);
  • CD-ROM;
  • видеоадаптер с качеством цветопередачи не хуже 24 бит;
  • операционная система Microsoft® Windows® 2000 или Windows XP (рекомендуется также иметь установленное ПО — QuickTime 6.1 и Microsoft DirectX 8.1).

  • Для работы в ОС Mac OS:

  • процессор PowerPC® (рекомендуется несколько процессоров);
  • оперативная память: 128 Мбайт (рекомендуется 256 Мбайт и более);
  • пространство на диске: минимальное — 150 Мбайт для установки (рекомендуется не менее 500 Мбайт);
  • CD-ROM;
  • видеоадаптер с качеством цветопередачи не хуже 24 бит;
  • операционная система Mac OS X v. 10.2.6.


Список терминов

  • Adjustment layer (Регулировочный слой) — слой, который автоматически определяет примененные к нему эффекты для всех слоев, расположенных ниже него.
  • Anchor control (Управление привязкой) — установка композиции, задающая привязку изображения кадров при масштабировании слоев (к углу или к центру).
  • Anchor point (Точка привязки) — выделенная точка кадра композиции, жестко привязанная к слою, которая не влияет на его внешний вид, но играет определяющую роль при некоторых операциях со слоем (при вращении и отражении она является его центром и т. п.).
  • Alpha Channel (Альфа-канал) — дополнительная информация о прозрачности каждого пиксела изображения, хранящаяся в файлах соответствующих форматов наряду с информацией о цвете каждого пиксела.
  • Alpha Mask (Альфа-маска) — дополнительное изображение-маска, надеваемое на изображение слоя и показывающее, насколько прозрачным является его каждый пиксел.
  • Animation (Анимация) — прием, заключающийся в перемещении в пределах кадра фильма одних слоев на фоне других.
  • Aspect Ratio (Отношение размеров) — отношение размеров кадра по горизонтали и вертикали.
  • Audio (Аудио) — звуковой клип или слой.
  • Brush (Кисть) — инструмент для рисования графических примитивов на слоях.
  • Brush Tips (Наконечники кисти) — опция инструмента Brush (Кисть), задающая форму и размер рисованных линий.
  • Camera (Камера) — инструмент для управления спецэффектом камеры.
  • Camera (Камера) — трехмерный спецэффект, имитирующий просмотр 3D-слоя с некоторой точки пространства через камеру.
  • Capture (Оцифровка) — процесс преобразования видеосигнала с внешнего устройства, подключенного к компьютеру (например, камеры или видеомагнитофона) в медиа-файл.
  • Clone Stamp (Клонирование) — инструмент для создания масок специального вида.
  • Codec (Кодек) — программа для сжатия видеоизображения или звукозаписи.
  • Color (Выбор цвета) — диалоговые окна с палитрой цветов для определения текущего цвета в различных инструментах.
  • Composition (Композиция) — окно, которое служит для (статического или динамического) отображения определенного кадра фильма;
  • Compressor (Компрессор) — кодек (codec, по аббревиатуре compressor/ decompressor), программа для сжатия видеоизображения или звукозаписи;
  • context, pop-up menu (Контекстные или всплывающие меню ) — меню, появляющиеся при нажатии правой кнопки мыши;
  • Current-time indicator (Индикатор текущего кадра) — ползунковый регулятор на шкале времени, отмечающий на ней текущий кадр;
  • Data Rate (Поток данных) — число килобайт информации в секунду, кодирующих видеофильм.
  • Depth (Глубина пиксела) — число цветов, которыми характеризуется каждый пиксел видеоизображения.
  • Digital Video (Цифровое видео) — видеосигнал, кодируемый с помощью цифровых технологий (в отличие от традиционных аналоговых средств). В частности, можно с легкостью организовать передачу такого сигнала с компьютера на внешнее цифровое устройство (камеру или магнитофон).
  • Duration (Длительность) — общая продолжительность композиции.
  • Effect Controls (Управление эффектом) — палитра для управления всеми спецэффектами, назначенными выделенному слою.
  • Elliptical Mask (Эллиптическая маска) — инструмент для создания масок круглой и эллиптической формы.
  • Eraser (Ластик) — инструмент для стирания фрагментов на масках.
  • Extract (Сжать) — удаляет из фильма фрагмент выделенного слоя (соответствующий рабочей области композиции), сдвигая оставшуюся часть слоя вправо на промежуток времени длительности удаленного фрагмента.
  • Flow (Заливка) — параметр рисованных линий, задающий интенсивность цвета ее заливки;
  • Footage (Источник или материал) — исходный клип, фактически являющийся ссылкой на анимационные, звуковые или графические файлы.
  • Footage Window (Окно клипа) — окно для просмотра отдельных исходных клипов.
  • Frame Back (Кадр назад) — кнопка в палитре Time Controls (Управление воспроизведением), перемещает текущий кадр на один кадр назад.
  • Frame Blending (Спецэффект плавного перехода кадров) — алгоритм, улучшающий качество анимации при помощи сглаживания динамики изменений от кадра к кадру.
  • Frame Forward (Кадр вперед) — кнопка в палитре Time Controls (Управление воспроизведением), перемещает текущий кадр на один кадр вперед.
  • Frame Jog (Полоса протяжки) — средство покадрового просмотра фильма в палитре Time Controls (Управление воспроизведением).
  • Frame Rate (Частота кадров) — число кадров видео, демонстрирующихся в течение одной секунды.
  • Hand (Рука) — инструмент для визуального перемещения видимой области по кадру.
  • Help (Справка) — справочная система Adobe After Effects;
  • History (Журнал) — палитра для просмотра и возможной отмены последних действий по редактированию.
  • Image (Статическое изображение) — графический клип со статическим изображением.
  • Import (Импорт) — процедура помещения медиа-файлов в проект в виде клипов.
  • In Point (Входной маркер) — начало слоя.
  • Index (Индекс) — система выбора статьи в справке After Effects из алфавитного указателя;
  • Info (Информация) — информационная палитра, в которой отображаются некоторые сведения о выделенном объекте.
  • Key (Прозрачное наложение или Ключ прозрачности) — разновидность назначения спецэффекта прозрачности слою. Может быть назначена полная прозрачность какого-либо участка клипа, диапазон прозрачных цветов и т. п. Прозрачные наложения реализованы в виде эффектов.
  • Keyframe (Ключевой кадр) — кадр, который определяет в фильме некоторое положение, в котором происходят качественные изменения (добавляется спецэффект и т. п.).
  • Lift (Поднять) — удаляет из фильма фрагмент (соответствующий рабочей области) выделенного слоя, без изменения общей длительности фильма.
  • Loop (Цикл) — проигрывает клип или фильм циклически от входного до выходного маркера, без остановки.
  • Marker (Маркер) — отметка пользователя, выделяющая кадр фильма (маркер фильма) и служащая для упрощения поиска отдельных кадров.
  • Marker Menu (Меню маркеров) — служит для установки, навигации и удаления маркеров клипов.
  • Mask (Маска, или Альфа-маска) — вспомогательное изображение, размечающее те участки кадра клипа, которые следует сделать сплошными, прозрачными или частично прозрачными. Используется в спецэффектах прозрачности.
  • Matte (Слой-маска) — слой, изображение которого используется для разметки прозрачности другого слоя (находящегося непосредственно под ним).
  • Menu bar (Верхнее меню) — меню, находящееся под заголовком окна After Effects;
  • Mode (Режим прозрачности) — столбец окна Timeline (Монтаж), который позволяет, в зависимости от определенных свойств изображения слоя, назначить пикселам определенный процент прозрачности.
  • Motion Blur (Эффект размытия при движении) — спецэффект, размывающий контуры объектов, которым назначена анимация, что делает ее восприятие более реалистичной и похожей на просмотр стандартного кинофильма (снятого объективом со шторкой затвора).
  • Multimedia (Мультимедиа) — технология просмотра мультимедийных (т. е. видео- и звуковых файлов) на компьютере.
  • Navigator (Навигатор) — элемент управления, облегчающий перемещение по ключевым кадрам анимации.
  • NTSC — североамериканский стандарт телевещания.
  • Offline file (Отключенный файл) — клип, заменяющий отсутствующий по каким-либо причинам на прежнем месте файл;
  • Opacity (Непрозрачность) — параметр, задающий (в процентах, %) степень непрозрачности слоя.
  • Out Marker (Выходной маркер) — маркер, выделяющий последний кадр фильма.
  • PAL — европейский стандарт телевещания.
  • Palette (Палитра) — набор цветов, используемый для кодирования видеоизображения.
  • Palette (Палитра) — элемент интерфейса After Effects, представляющий собой окно небольшого размера и служащий для различных вспомогательных целей.
  • Pan Behind (Панорама) — инструмент для управления местоположением точки привязки относительно слоя.
  • Parent (Родительский, или Ведущий слой) — слой, все настройки которого (кроме прозрачности) автоматически будут применяться к дочернему слою.
  • Реn (Перо) — инструмент для рисования масок сложной формы.
  • Pixel Aspect Ratio (Пропорции пиксела) — отношение размеров пиксела изображения по горизонтали и вертикали.
  • Play (Проиграть) — равномерно проигрывает фильм от текущего кадра, при повторном нажатии останавливает фильм.
  • Presets (Предустановки) — комбинации установок композиции, имеющихся в After Effects, т. е. предопределенных для создания различных типов фильмов (для TV, мультимедиа и т. п.).
  • Project (Окно проекта) — окно, управляющее исходными клипами.
  • Project (Проект) — перечень клипов, применяемых для монтажа отдельного фильма, наряду с записью действий по его редактированию.
  • Properties (Свойства) — параметры клипа или фильма.
  • QuickTime — программный продукт компании Apple, ряд мультимедийных возможностей которого доступен для использования в After Effects;
  • RAM Preview (Предварительный просмотр) — режим просмотра композиции, при котором сначала осуществляется ее рендеринг, а затем уже композиция проигрывается в окне Composition (Композиция).
  • Rectangular Mask (Прямоугольная маска) — инструмент для создания масок прямоугольной формы.
  • Rendering (Рендеринг) — процесс построения изображения каждого кадра по его описанию в программе. Рендеринг производится для осуществления предварительного просмотра или экспорта фильма.
  • Resolution (Разрешение) — параметр установок композиций, который позволяет выбрать разрешение кадра, демонстрирующегося в окне Composition (Композиция) при редактировании и рендеринге фильма.
  • Rotation (Вращение) — инструмент, служащий для поворотов слоев.
  • Safe Margins (Безопасные зоны) — зоны в кадре композиции, за пределами которых некоторые телевизионные системы могут искажать или не показывать поле кадра.
  • Search (Поиск) — система поиска статей в справке Adobe After Effects no ключевому слову.
  • SECAM — стандарт телевещания в ряде стран (в том числе, и в России).
  • Selection (Выбор) — инструмент, служащий для выделения и масштабирования слоев и их атрибутов.
  • Settings (Установки) — комбинация свойств фильма, включая размер кадра, частоту кадров, качество звука и т. д. Различают два типа установок: одни влияют на фильм, который монтируется в рамках проекта и просматривается в окне Composition (установки композиции), а другие определяют параметры итогового фильма (установки экспорта).
  • Shortcuts (Горячие клавиши) — эффективный способ для опытных пользователей. Если вы часто применяете определенные команды, намного быстрее выполнять их нажатием сочетания клавиш на клавиатуре, чем вызовом меню или инструментов.
  • SMPTE — формат таймкода (счетчика кадров).
  • Source Name (Название источника) — столбец с названиями исходных клипов, размещенных в слоях в окне Timeline (Монтаж).
  • Stop (Стоп) — останавливает проигрывание клипа.
  • Text (Текст) — инструмент для создания текстовых титров.
  • Thumbnail (Миниатюра) — маленькое изображение кадра клипа или фильма, имеющееся в ряде окон.
  • Timecode (Таймкод) — номер кадра в фильме или слое. Формат нумерации зависит от установок;
  • Time Controls (Управление воспроизведением) — палитра, предназначенная для динамического просмотра композиций.
  • Timeline (Монтаж) — окно, в котором производится монтаж слоев относительно временной шкалы фильма.
  • Time ruler (Шкала времени) — шкала в верхней правой части окна Timeline (Монтаж), определяющая место каждого кадра для каждого слоя композиции.
  • Title (Титры) — текстовые титры.
  • Toolbar (Панель инструментов) — многочисленные панели, помещенные на окна и комбинирующие различные элементы управления.
  • Transition (Переход) — тип эффектов для создания переходов между планами композиции.
  • Video (Видео) — клип с анимацией.
  • Volume (Громкость) — громкость звука.
  • Window menu (Меню окон и палитр) — меню, специфические для After Effects, которые вызываются нажатием кнопки с треугольной стрелкой в правой верхней части окна или палитры.
  • Work area (Рабочая область) — фрагмент композиции, выделенный на шкале времени окна Timeline (Монтаж), который обрабатывается в ходе рендеринга и экспорта композиции.
  • Zoom (Масштаб) — инструмент, служащий для увеличения или уменьшения масштаба кадра.


Приложение 3. Шпаргалки

  • Интерфейс
  • Импорт и экспорт
  • Редактирование композиций
  • Слои
  • Слои в композиции


Интерфейс

Как начать что-то делать?

1. Начните новый проект (если он еще не начат) командой File>New> New Project (Файл>Создать>Новый проект).

2. Создайте новую композицию командой Composition>New Composition (Композиция>Создать композицию).

3. В диалоге Composition Settings (Установки композиции) определите установки и нажмите в диалоге кнопку ОК.

4. Монтируйте композицию в окне Timeline (Монтаж), наблюдая за текущим кадром в окне Composition (Композиция).

Как вызвать на экран палитру Tools (Инструментарий)? Выберите Window>Tools (Окно>Инструментарий).

Как проиграть композицию?

Воспользуйтесь контекстным меню, вызывая его в свободной области окна Timeline (Монтаж), либо палитрой Time Controls (Управление воспроизведением).

Как перейти к определенному кадру композиции?

1. Щелкните в нужном месте на шкале времени в окне Timeline (Монтаж).

2. Если же необходимо перейти к определенному кадру по его номеру, выберите View>Go To Time (Вид> Перейти к кадру) и задайте номер кадра в появившемся диалоге.


Импорт и экспорт

Как загрузить в проект After Effects видео (или рисунок, или звук) из внешнего файла?

1. Выберите File>Import>File (Файл>Импорт>Файл).

2. В появившемся диалоге открытия файла определите его местонахождение.

Как загрузить в проект After Effects проект Adobe Premiere?

Просто импортируйте файл с проектом Premiere в проект After Effects. Предварительный экспорт из Premiere выполнять не нужно.

Как осуществить экспорт композиции?

1. Выберите в верхнем меню Composition>Make Movie (Композиция> Создать видео).

2. В окне Render Queue (Список рендеринга) отредактируйте установки экспорта и нажмите кнопку Render (Начать рендеринг).


Редактирование композиций

Как изменить фон композиции?

1. Перейдите к окну Composition (Композиция).

2. Выберите Composition>Background Color (Композиция>Цвет фона).

3. Щелкните в появившемся одноименном диалоге на поле с образцом текущего цвета.

4. Выберите желаемый цвет из палитры.

Как сделать цветом фона кадра композиции некоторый цвет, который присутствует где-либо в изображении?

1. Перейдите к окну Composition (Композиция).

2. Выберите Composition>Background Color (Композиция>Цвет фона).

3. Щелкните на кнопке с пиктограммой в виде пипетки.

4. Щелкните пипеткой на нужном пикселе кадра в окне Composition (Композиция) и загрузите желаемый цвет.

Как изменить размер кадра фильма (т. е. существующей композиции)?

1. Выделите композицию в окне Project (Проект), Timeline (Монтаж) или Composition (Композиция).

2. Выберите Composition>Composition settings (Композиция>Установки композиции).

3. В соответствующих полях появившегося диалога измените размеры кадра композиции по вертикали и горизонтали.

Как изменить другие установки композиции?

1. Выделите композицию и выберите Compos!tion>Composition settings (Ком-позиция>Установки композиции).

2. Измените желаемые установки.

Как удалить что-либо ненужное (слой, клип и т. д.)?

Почти во всех случаях достаточно придерживаться такого простого рецепта:

1. Выделите тот элемент, который хотите удалить.

2. Нажмите клавишу <BackSpace>.

Как отменить последнее действие?

Выберите Edit>Undo (Правка>Отменить).


Слои

Как масштабировать изображение (изменить размер кадра) некоторого слоя композиции?

1. Выделите слой

2. Выберите Layer>Layer settings (Слой>Установки слоя).

3. В появившемся диалоге измените размеры кадра слоя по вертикали и горизонтали.

Как создать однотонный сплошной слой?

1. Откройте вашу композицию в окне Timeline (Монтаж) или Composition (Композиция).

2. Выберите Layer>New>Solid (Слой>Создать>Сплошной).

3. В появившемся диалоге определите цвет слоя.

4. Новый слой возникнет в окне Timeline (Монтаж), а также в окне Project (Проект).

Как создать трехмерный слой?

Нажмите кнопку 3D Layer в строке с именем слоя в окне Timeline (Монтаж), либо введите команду верхнего меню Layer>3D Layer (Слой>Трехмерный слой). После этого слой можно редактировать с учетом пространственной координаты.

Как поменять тот или иной параметр слоя?

1. Вызовите на экран столбец Switches/Modes (Переключатели/Режимы) окна Timeline (Монтаж). Если он скрыт, воспользуйтесь пунктом Columns (Столбцы) меню окна Timeline (Монтаж).

2. Раскройте выпадающий список с нужным параметром.

3. Отрегулируйте параметр, пользуясь активной надписью в столбце Switches/Modes (Переключатели/Режимы).


Слои в композиции

Как изменить порядок наложения слоев композиции?

Схватитесь за название слоя music.wav в окне Timeline (Монтаж) и перетащите его по вертикали вверх или вниз, над или под другие слои. По мере перетаскивания предполагаемое положение слоя будет показываться жирной горизонтальной линией.

Как сместить слой вдоль линейки времени ближе к началу или концу композиции, не меняя его длительности?

Перетащите слой указателем мыши влево или вправо по графической области окна Timeline (Монтаж) за его центральную часть.

Как изменить начальный или конечный кадр слоя в композиции?

Начало или конец слоя может быть смещено влево или вправо вдоль линейки времени окна Timeline (Монтаж) путем перетаскивания входной или выходной точки слоя (характерных пиктограмм, обрамляющих слой). При этом длительность слоя соответственно увеличивается или уменьшается, а первый (или последний) кадр этого слоя также изменяется.

Как скрыть слои, которые не используются в окне Timeline (Монтаж)?

1. Для слоя, который вы хотите скрыть, установите признак скрытого слоя (Shy).

2. На панели инструментов окна Timeline (Монтаж) включите опцию скрытия всех слоев с назначенным признаком скрытия.

Как выровнять размер кадра слоя по размеру кадра композиции?

1. Выделите слой.

2. Выберите Layer>Layer settings (Слой>Установки слоя).

3. В появившемся диалоге нажмите кнопку Make Comp Size (Размер композиции).


Палитра инструментов Tools

Вкратце опишем назначение и элементы палитры:

  • Selection (Выбор) — для выделения, перемещения и масштабирования слоев;
  • Rotation (Вращение) — для поворотов слоев;
  • Camera (Камера) — для управления спецэффектом камеры:

  • Orbit camera (Орбитальная камера) — для вращения текущего трехмерного вида;
  • Track XY camera (XY-слежение) — для регулировки трехмерного вида вдоль вертикали и горизонтали;
  • Track Z camera (Z-слежение) — для регулировки трехмерного вида вдоль пространственной оси;

  • Hand (Рука) — для перемещения поля зрения вдоль кадра;
  • Zoom (Масштаб) — для выбора масштаба отображения кадра;
  • Pan Behind (Панорама) — для управления местоположением точки привязки относительно слоя;
  • Brush (Кисть) — для рисования графических примитивов на слоях;
  • Clone Stamp (Клонирование) — для создания масок специального вида;
  • Eraser (Ластик) — для редактирования масок;
  • Mask (Маска) — для создания масок:

  • Rectangular Mask (Прямоугольная маска) — для создания прямоугольных масок;
  • Elliptical Mask (Эллиптическая маска) — для создания эллиптических масок;

  • Text (Текст) — для создания текстовых титров:

  • Horizontal Text (Горизонтальный текст) — для создания горизонтального текста;
  • Vertical Text (Вертикальный текст) — для создания горизонтального текста;

  • Реn (Перо) — для рисования масок сложной формы:

  • Реn (Перо) — предназначен как для рисования новой маски Безье, так и для редактирования существующей;
  • Add vertex (Добавить вершину) — добавляет новую вершину на существующую фигуру Безье;
  • Delete vertex (Удалить вершину) — удаляет одну из существующих вершин фигуры Безье;
  • Convert vertex (Преобразовать вершину) — предназначен для преобразования типа вершины (угла пересечения прямых или плавных линий).


Некоторые горячие клавиши

Команда | ОС Windows | ОС Mac OS
 | Выбор инструментов |
Инструмент Selection | <V> | <V>
Инструмент Rotation | <W> | <w>
Инструменты Camera (Orbit, Track XY или Track Z) | <С> или <Shift>+<C> (меняются циклически) | <С> или <Shift>+<C> (меняются циклически)
Инструменты Brush, Clone Stamp, Eraser | <Ctrl>+<B> (меняются циклически) | <Command>+<B> (меняются циклически)
Инструмент Hand | <Н> либо удерживать пробел | <Н> либо удерживать пробел
Инструмент Zoom | <Z> (для увеличения масштаба) <Z>+<Alt> (для уменьшения масштаба) | <Z> (для увеличения масштаба) <Z>+<Option> (для уменьшения)
Инструмент Pan Behind | <Y> | <Y>
Инструменты Mask | <Q> либо <Shift>+<Q> (меняются циклически) | <Q> либо <Shift>+<Q> (меняются циклически)
Инструменты Type | <Ctrl>+<T> (меняются циклически) | <Command>+<T> (меняются циклически)
Инструменты Pen | <G> либо <Shift>+<G> (меняются циклически) | <G> либо <Shift>+<G> (меняются циклически)
Управление окнами
Открыть последний проект | <Ctrl>+<Alt>+<Shift>+ +<Р> | <Command>+<Option>+ +<Shift>+<P>
Открыть диалог Project Settings | <Ctrl>+<Alt>+<Shift>+ +<К> | <Command>+<Option>+ +<Shift>+<K>
Открыть клип в окне Footage | <Аlt>+двойной щелчок на окне | <Оption>+двойной щелчок на окне
Сделать активной последнюю композицию | <\> | <\>
Добавить выделенный клип в последнюю композицию | <Ctrl>+</> | <Command>+</>
Заменить в композиции выделенный слой выделенным клипом | <Ctrl>+<Alt>+</> | <Command> +<Option> +</>
Удалить исходный клип без предупреждения | <Ctrl>+<Backspace> | <Command>+<Delete>
Показать или скрыть все палитры | <Tab> | <Tab>
Закрыть активное окно (или текущую закладку в активном окне) | <Ctrl>+<W> | <Command>+<W>
Закрыть активное окно (все закладки) | <Ctrl>+<Shift>+<W> | <Command> +<Shift>+<W>
Закрыть все окна, кроме окна Project | <Ctrt>+<Alt>+<W> | <Command> + <Option> + <W>
Циклически переключаться между открытыми окнами | <Ctrl>+<Tab> |
Переключиться между окнами Composition и Timeline | <\> | <\>
Показать или скрыть палитру Effect Controls для выделенных слоев | <Ctrl>+<Shift>+<T> | <Command>+<Shift>+<T>
Открыть выделенный слой в окне Layer | <Enter> | <Enter>
Управление редактированием
Установить начало рабочей области на текущий кадр | <B> | <B>
Установить конец рабочей области на текущий кадр | <N> | <N>
Установить рабочую область на выделенный слой | <Ctrl>+<Alt>+<B> | <Command> +<Option> +<B>
Перейти в начало рабочей области | <Shift>+<Home> | <Shift>+<Home>
Перейти в конец рабочей области | <Shift>+<End> | <Shift>+<End>
Перейти к маркеру окна Timeline | <0>... <9> | <0>...<9>
Перенести текущий кадр на центр окна | <D> | <D>
Перейти в начало | <Home> или <Ctrl>+<Alt>+«— > | <Home> или <Command>+<Option>+ +<<->
Перейти в конец | <End> или <Ctrl>+<Alt>+<— » | <End> или <Command>+ +<Option>+<— »
Один кадр вперед | <Page Down> или <Ctrl>+<->> | <Page Down> или <Command>+<->>
10 кадров вперед | <Shift>+<Page Down> или <Shift>+<Ctrl>+<-»> | <Shift>+<Page Down> или <Shift>+<Command>++<->>
Один кадр назад | <Page Up> или <Ctrl>+«-> | <Page Up> или <Command>+<<- >
10 кадров назад | <Shift>+<Page Up> или <Shift>+<Ctrl>+«-> | <Shift>+<Page Up> или <Command>+<Shift>+
Перейти к начешу слоя | <i> | <i>
Перейти к концу слоя | <o> | <o>
Старт (Пауза) воспроиз ведения | <Пробел> | <Пробел>
Просмотр RAM | <Shift>+<0> | <Shift>+<0>
Правка слоев
Снять выделение со всех слоев | <F2> | <F2>
Обратить направление воспроизведения слоя | <Ctrl>+<Alt>+<R> | <Command>+<Option>+ +<R>
Перенести начало слоя на текущий кадр | <[> | <[>
Перенести конец слоя на текущий кадр | <]> | <]>
Отрезать начало слоя | <Alt>+<[> | <Option>+<[>
Отрезать конец слоя | <Alt>+<]> | <Option>+<]>
Перенести начало слоя на начало композиции | <Alt>+<Home> | <Option>+<Home>
Перенести конец слоя на конец композиции | <Alt>+<End> | <Option>+<End>
Сдвинуть изображение выделенного слоя в заданном направлении на 1 пиксел | <Стрелка> | <Стрелка>
Сдвинуть слой на 1 кадр назад | <Alt>+<Page Up> | <Option>+<Page Up>
Сдвинуть слой на 1 кадр вперед | <Alt>+<Page Down> | <Option>+<Page Down>
Вращать слой на 1 градус вправо | <+> | <+>
Вращать слой на 1 градус влево | <-> | <->
Раскрытие списков
Точка привязки | <A> | <A>
Громкость звука | <L> | <L>
Audio Waveform | <LL> | <LL>
Эффекты | <E> | <E>
Выражения | <EE> | <EE>
Оперение маски | <F> | <F>
Форма маски | <М> | <М>
Прозрачность маски | <ТТ> | <ТТ>
Свойства маски | <ММ> | <ММ>
Материал (30-слои) | <АА> | <АА>
Прозрачность | <Т> | <Т>
Расположение | <Р> | <Р>
Эффекты рисования | <РР> | <РР>
Вращение | <R> | <R>
Масштабирование | <S> | <S>


Введение

  • Предисловие
  • Как устроена эта книга


Предисловие

Перед вами самоучитель, при помощи которого вы сможете самостоятельно освоить основные возможности приложения Adobe After Effects 6.0, который в дальнейшем будем называть просто — After Effects.

Изложение материала построено по принципу "от простого — к сложному". Главы, каждая из которых нацелена на решение определенной задачи, мы назвали уроками, подчеркивая тем самым, что основное назначение нашей книги — научить читателя работе с After Effects. При этом мы постарались думать о разных пользователях — как начинающих работу с компьютером вообще и пытающихся освоить After Effects "с нуля", так и продвинутых, знакомых с приложениями Adobe Photoshop и Adobe Premiere, а также с предыдущими версиями After Effects.

Хотим сразу оговориться, что мы старались максимально упростить восприятие материала. Для этого мы сделали акцент на частое использование поясняющих рисунков и экранных форм, на которых при помощи расположения указателя мыши подчеркивали смысл рисунка.

Эта книга, по сути, является одним из двух (равноценных) томов самоучителя, посвященных двум наиболее популярным приложениям для компьютерного видеомонтажа — Adobe After Effects и Adobe Premiere. Обе книги, хотя и имеют одинаковый стиль подачи материала, абсолютно независимы (в том смысле, что для чтения одной не требуется знакомство с другой). Тем не менее, по ходу изложения мы часто упоминаем о второй из программ, поскольку, по замыслу разработчиков, они дополняют друг друга, и большая часть пользователей работает с обоими приложениями.

Не забыли мы и о приверженцах компьютеров Apple (правда, помня о вашей немногочисленности, мы вынесли большинство из интересующих вас сведений в сноски и приложения).

Не сочтите за труд прочитать это введение в книгу, поскольку мы написали здесь не просто общие слова, а даем рекомендации именно вам, конкретным читателям, чтобы вы смогли пользоваться нашей книгой максимально эффективно, в зависимости от ваших познаний в компьютерах и стиля обучения, к которому вы привыкли.


Как устроена эта книга

На уроках решается конкретная проблема видеомонтажа в приложении After Effects. Таким образом, мы постарались охватить все основные приемы и возможности данной программы.

Каждый урок начинается с короткого анонса:

  • Чего мы хотим:

  • здесь мы очень сжато говорим о том, что является целью этого урока. Вам сразу станет ясно, какая проблема решается в данном уроке.

  • Нам потребуется:

  • в этой части урока приведен перечень тех материалов (например, мультимедийных файлов, которые надо подготовить заранее, или внешних устройств, подключаемых к компьютеру), которые будут использоваться при изложении материала данного урока.

  • Что полезно вспомнить:

  • ссылка на предшествующие уроки, знание которых совершенно необходимо для осмысленного чтения данного урока. Здесь мы подумали не только о простой контекстной рекомендации освежить уже прочитанный материал, но и о привычке многих читателей изучать материал не по порядку, а хаотично, в зависимости от интересующей их в данный момент задачи.

Важность такой преамбулы каждого урока продиктована спецификой и, подчас, сложностью самого процесса компьютерной обработки видео, а также печальным опытом некоторых компьютерных книг (зачастую неискушенному пользователю совсем неочевидно, какую именно цель ставит автор при перечислении тех или иных действий при работе с программой, и их смысл становится понятным только в конце раздела). Некоторым читателям удобнее разобраться в проблеме при помощи работы "своими руками", не тратя время на разбор текста книги и ориентируясь в смысле описываемых нами операций по работе самой программы After Effects на экране монитора. Для них мы советуем обратить внимание на участки текста книги, выделенные маркированным или нумерованным списком, например:

1. Сначала сделайте то-то.

2. Потом то-то. Или:

  • первое;
  • второе;
  • третье.

Даже если мы предлагаем вам выполнить какое-то одно простое действие, все равно мы выделяем его маркером или номером списка (для облегчения контекстного поиска интересующего вас места на странице).

Заботясь об упрощении восприятия материала, мы старались сделать многочисленные рисунки полноценным конспектом книги, руководствуясь правилом "лучше один раз увидеть, чем много раз прочитать". Подписи к рисункам сочинялись так, чтобы они давали дополнительную полезную информацию (часто дублируя мысли, изложенные в тексте), например, подпись к рис. 2.11 — "Окно Composition всегда отображает кадр, отмеченный линией редактирования в окне Timeline".

Если вы хотите максимально подробно разобраться в возможностях программы After Effects, читайте весь текст подряд, но если по каким-то причинам вы не хотите отягощать себя излишней информацией, а хотите познакомиться с самым необходимым, то можете пропустить фрагменты книги, которые оформлены в виде примечаний.

В силу специфики книги некоторые из таких примечаний адресованы пользователям (как опытным, так и начинающим и даже потенциальным) другого видеоредактора — Adobe Premiere. Эти фрагменты мы оформляли с помощью заголовка:

Пользователям Adobe Premiere

Наконец, серьезное внимание мы уделили приложениям к книге, которые, как мы планировали, помогут вам в работе с After Effects после того, как вы станете ее опытным пользователем, и будут служить надежной справочной информацией.

Надеемся, что наша книга поможет вам быстро и качественно овладеть всеми тонкостями компьютерной обработки видео при помощи замечательного пакета Adobe After Effects 6.0.